<!DOCTYPE html>
<html lang="en-US"
	itemscope 
	itemtype="http://schema.org/Article" 
	prefix="og: http://ogp.me/ns#" >
<head>
	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=edge" />
	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="http://theballerlife.com/xmlrpc.php">
	<title>Tameka &#8220;Tiny&#8221; Harris Talks Strained Marriage With T.I.,  Her Dancing With Floyd Mayweather , Reality TV And More! (Video) | | The Baller Life -  BallerWives.com</title>

<!-- Twitter Card generated by MashShare 3.4.1 - https://www.mashshare.net -->
<meta name="twitter:card" content="summary">
<meta name="twitter:title" content="Tameka &quot;Tiny&quot; Harris Talks Strained Marriage With T.I.,  Her Dancing With Floyd Mayweather , Reality TV And More! (Video)">
<meta name="twitter:description" content="Tameka &quot;Tiny&quot; Harris stopped by the &quot;Wendy Williams Show&quot; recently and opened up about her strained marriage with husband T.I., her dancing with Floyd Mayweather, the effect reality TV had on her life and much">
<meta name="twitter:site" content="@ballerwives">
<!-- Twitter Card generated by MashShare 3.4.1 - https://www.mashshare.net -->


<!-- All in One SEO Pack 2.3.12.2.1 by Michael Torbert of Semper Fi Web Design[334,523] -->
<link rel="author" href="https://plus.google.com/117266833494320081327" />
<meta name="description"  content="Tameka &quot;Tiny&quot; Harris stopped by the &quot;Wendy Williams Show&quot; recently and opened up about her strained marriage with husband T.I., her dancing with Floyd" />

<meta name="keywords"  content="#trending news,celebrity news,celebrity videos" />

<meta property="og:title" content="Tameka &#8220;Tiny&#8221; Harris Talks Strained Marriage With T.I.,  Her Dancing With Floyd Mayweather , Reality TV And More! (Video) | | The Baller Life -  BallerWives.com" />
<meta property="og:type" content="article" />
<meta property="og:url" content="http://theballerlife.com/2017/04/26/tameka-tiny-harris-talks-strained-marriage-with-t-i-her-dancing-with-floyd-mayweather-reality-tv-and-more-video/" />
<meta property="og:image" content="http://theballerlife.com/wp-content/uploads/2017/04/tiny-talks-marriage-to-TI.jpg" />
<meta property="og:site_name" content="BallerWives.com" />
<meta property="og:description" content="Tameka &quot;Tiny&quot; Harris stopped by the &quot;Wendy Williams Show&quot; recently and opened up about her strained marriage with husband T.I., her dancing with Floyd Mayweather, the effect reality TV had on her life and much more. Watch the video below..." />
<meta property="article:published_time" content="2017-04-26T17:07:43Z" />
<meta property="article:modified_time" content="2017-04-26T17:08:10Z" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@ballerwives" />
<meta name="twitter:domain" content="theballerlife.com" />
<meta name="twitter:title" content="Tameka &#8220;Tiny&#8221; Harris Talks Strained Marriage With T.I.,  Her Dancing With Floyd Mayweather , Reality TV And More! (Video) | | The Baller Life -  BallerWives.com" />
<meta name="twitter:description" content="Tameka &quot;Tiny&quot; Harris stopped by the &quot;Wendy Williams Show&quot; recently and opened up about her strained marriage with husband T.I., her dancing with Floyd Mayweather, the effect reality TV had on her life and much more. Watch the video below..." />
<meta name="twitter:image" content="http://theballerlife.com/wp-content/uploads/2017/04/tiny-talks-marriage-to-TI.jpg" />
<meta itemprop="image" content="http://theballerlife.com/wp-content/uploads/2017/04/tiny-talks-marriage-to-TI.jpg" />
			<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','//www.google-analytics.com/analytics.js','ga');

			ga('create', 'UA-9445838-1', 'auto');
			
			ga('send', 'pageview');
			</script>
<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Baller Life -  BallerWives.com &raquo; Feed" href="http://theballerlife.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Baller Life -  BallerWives.com &raquo; Comments Feed" href="http://theballerlife.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Baller Life -  BallerWives.com &raquo; Tameka &#8220;Tiny&#8221; Harris Talks Strained Marriage With T.I.,  Her Dancing With Floyd Mayweather , Reality TV And More! (Video) Comments Feed" href="http://theballerlife.com/2017/04/26/tameka-tiny-harris-talks-strained-marriage-with-t-i-her-dancing-with-floyd-mayweather-reality-tv-and-more-video/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/theballerlife.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.4"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	  <style type="text/css">
	  .wp-pagenavi{float:left !important; }

	  .wp-pagenavi a,.wp-pagenavi a:link,.wp-pagenavi a:visited,.wp-pagenavi a:active,.wp-pagenavi span.extend { background:#000000 !important; border:1px solid #666666 !important; color:#ffffff !important; }
	  .wp-pagenavi a:hover,.wp-pagenavi span.current
	  {
		  background:#000000 !important; border:1px solid ##444 !important; color:#ffffff !important; 
	  }
	  .wp-pagenavi span.pages { color:#000000 !important; }
	  </style>
	  <link rel='stylesheet' id='generate-fonts-css'  href='//fonts.googleapis.com/css?family=Open+Sans:300,300italic,regular,italic,600,600italic,700,700italic,800,800italic' type='text/css' media='all' />
<link rel='stylesheet' id='crp-style-rounded-thumbs-css'  href='http://theballerlife.com/wp-content/plugins/contextual-related-posts/css/default-style.css?ver=4.7.4' type='text/css' media='all' />
<style id='crp-style-rounded-thumbs-inline-css' type='text/css'>

.crp_related a {
  width: 240px;
  height: 200px;
  text-decoration: none;
}
.crp_related img {
  max-width: 240px;
  margin: auto;
}
.crp_related .crp_title {
  width: 240px;
}
                
</style>
<link rel='stylesheet' id='mashsb-styles-css'  href='http://theballerlife.com/wp-content/plugins/mashsharer/assets/css/mashsb.min.css?ver=3.4.1' type='text/css' media='all' />
<style id='mashsb-styles-inline-css' type='text/css'>
.mashsb-count {color:#cccccc;}@media only screen and (min-width:568px){.mashsb-buttons a {min-width: 177px;}}.mashicon-subscribe {
    background: red;
}

.mashicon-subscribe .icon, .mashicon-subscribe .text {
    color: #fff;
}
</style>
<link rel='stylesheet' id='wpfp-public-style-css'  href='http://theballerlife.com/wp-content/plugins/wpos-featured-post2/assets/css/wpfp-public.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='wposrp-public-style-css'  href='http://theballerlife.com/wp-content/plugins/wpos-recent-post/assets/css/wposrp-public.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='generate-style-grid-css'  href='http://theballerlife.com/wp-content/themes/generatepress/css/unsemantic-grid.min.css?ver=1.3.41' type='text/css' media='all' />
<link rel='stylesheet' id='generate-style-css'  href='http://theballerlife.com/wp-content/themes/generatepress/style.css?ver=1.3.41' type='text/css' media='all' />
<style id='generate-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='generate-mobile-style-css'  href='http://theballerlife.com/wp-content/themes/generatepress/css/mobile.min.css?ver=1.3.41' type='text/css' media='all' />
<link rel='stylesheet' id='generate-child-css'  href='http://theballerlife.com/wp-content/themes/generatepress-child/style.css?ver=1493317822' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='http://theballerlife.com/wp-content/themes/generatepress/css/font-awesome.min.css?ver=4.7' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='generate-ie-css'  href='http://theballerlife.com/wp-content/themes/generatepress/css/ie.min.css?ver=1.3.41' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='scroll-triggered-boxes-css'  href='http://theballerlife.com/wp-content/plugins/scroll-triggered-boxes/assets/css/styles.min.css?ver=2.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='blog-styles-css'  href='http://theballerlife.com/wp-content/plugins/gp-premium/blog/functions/css/style-min.css?ver=1.2.90' type='text/css' media='all' />
<link rel='stylesheet' id='generate-secondary-nav-css'  href='http://theballerlife.com/wp-content/plugins/gp-premium/secondary-nav/functions/css/style.min.css?ver=4.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='generate-secondary-nav-mobile-css'  href='http://theballerlife.com/wp-content/plugins/gp-premium/secondary-nav/functions/css/mobile.min.css?ver=1.2.90' type='text/css' media='all' />
<link rel='stylesheet' id='generate-sticky-css'  href='http://theballerlife.com/wp-content/plugins/gp-premium/menu-plus/functions/css/sticky.min.css?ver=1.2.90' type='text/css' media='all' />
<link rel='stylesheet' id='generate-sliiide-css'  href='http://theballerlife.com/wp-content/plugins/gp-premium/menu-plus/functions/css/sliiide.min.css?ver=1.2.90' type='text/css' media='all' />
<link rel='stylesheet' id='generate-menu-logo-css'  href='http://theballerlife.com/wp-content/plugins/gp-premium/menu-plus/functions/css/menu-logo.min.css?ver=1.2.90' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://theballerlife.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-pagenavi-style-css'  href='http://theballerlife.com/wp-content/plugins/wp-pagenavi-style/style/default.css?ver=1.0' type='text/css' media='all' />
<script type='text/javascript' src='http://theballerlife.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://theballerlife.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='http://theballerlife.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://theballerlife.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://theballerlife.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Serena Williams Opens Up About Pregnancy, Love Life And Career! (Video)' href='http://theballerlife.com/2017/04/26/serena-williams-opens-up-about-pregnancy-love-life-and-career-video/' />
<meta name="generator" content="WordPress 4.7.4" />
<link rel="canonical" href="http://theballerlife.com/2017/04/26/tameka-tiny-harris-talks-strained-marriage-with-t-i-her-dancing-with-floyd-mayweather-reality-tv-and-more-video/" />
<link rel='shortlink' href='http://wp.me/p8eXdY-f2U' />
<link rel="alternate" type="application/json+oembed" href="http://theballerlife.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Ftheballerlife.com%2F2017%2F04%2F26%2Ftameka-tiny-harris-talks-strained-marriage-with-t-i-her-dancing-with-floyd-mayweather-reality-tv-and-more-video%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://theballerlife.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Ftheballerlife.com%2F2017%2F04%2F26%2Ftameka-tiny-harris-talks-strained-marriage-with-t-i-her-dancing-with-floyd-mayweather-reality-tv-and-more-video%2F&#038;format=xml" />
	<style type="text/css">
	 .wp-pagenavi
	{
		font-size:18px !important;
	}
	</style>
	
<link rel='dns-prefetch' href='//v0.wordpress.com'>
<style type='text/css'>img#wpstats{display:none}</style><meta name="viewport" content="width=device-width, initial-scale=1"><style type="text/css">
/* Custom Styles for Box 56807 */
.stb-56807 {
background: #f9f9f9 !important;
color: #1e73be !important;
border-color: #255aea !important;
border-width: 6px !important;
border-style: solid !important;
max-width: 300px;
}

.fb-like {

margin-left: 70px;

}



</style>

<meta name="google-site-verification" content="3BzuJzm54NKE3YhZF_1yTDtZE4x8M0QWaCMWmkbiCEI" />

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-5342939612884568",
    enable_page_level_ads: true
  });
</script>

<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u) {
    e.async = 1;
    e.src = u;
    f.parentNode.insertBefore(e, f);
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  'http://cdn.taboola.com/libtrc/ballerwives/loader.js');
</script>

</head>

<body itemtype='http://schema.org/Blog' itemscope='itemscope' class="post-template-default single single-post postid-57840 single-format-standard post-image-below-header post-image-aligned-left secondary-nav-above-header secondary-nav-aligned-right sections-no-sidebars slideout-enabled slideout-mobile sticky-menu-no-transition navigation-logo sticky-enabled menu-logo menu-logo-enabled both-sticky-menu generatepress  right-sidebar nav-below-header contained-header one-container active-footer-widgets-0 nav-search-enabled nav-aligned-left header-aligned-left dropdown-click dropdown-click-menu-item">
		<a class="screen-reader-text skip-link" href="#content" title="Skip to content">Skip to content</a>
	<header itemtype="http://schema.org/WPHeader" itemscope="itemscope" id="masthead" class="site-header grid-container grid-parent">
		<div class="inside-header grid-container grid-parent">
								<div class="header-widget">
			<aside id="text-640378489" class="widget inner-padding widget_text">			<div class="textwidget"><!-- Conversant Media 468x60 and 728x90 Banner CODE for BallerWives.com -->
<script type="text/javascript">var vclk_options = {sid:58120,media_id:1,media_type:5,version:"1.4"};</script><script class="vclk_pub_code" type="text/javascript" src="http://cdn.fastclick.net/js/adcodes/pubcode.min.js?sid=58120&media_id=1&media_type=5&version=1.4&exc=1"></script><noscript><a href="http://media.fastclick.net/w/click.here?sid=58120&m=1&c=1" target="_blank"><img src="http://media.fastclick.net/w/get.media?sid=58120&m=1&tp=5&d=s&c=1&vcm_acv=1.4" width="728" height="90" border="1"/></a></noscript>
<!-- Conversant Media 468x60 and 728x90 Banner CODE for BallerWives.com --></div>
		</aside>		</div>
						</div><!-- .inside-header -->
	
 


</header><!-- #masthead -->
		<nav itemtype="http://schema.org/SiteNavigationElement" itemscope="itemscope" id="site-navigation" class="main-navigation grid-container grid-parent">
		<div class="inside-navigation grid-container grid-parent">
				<form method="get" class="search-form navigation-search" action="http://theballerlife.com/">
		<input type="search" placeholder="SEARCH HERE...." class="search-field" value="" name="s" title="Search">
	</form>
		<div class="site-logo sticky-logo">
		<a href="http://theballerlife.com/" title="The Baller Life &#8211;  BallerWives.com" rel="home"><img class="header-image" src="http://theballerlife.com/wp-content/uploads/2016/12/blife1.png" alt="The Baller Life &#8211;  BallerWives.com" title="The Baller Life &#8211;  BallerWives.com" /></a>
	</div>
		<div class="mobile-bar-items">
				<span class="search-item" title="Search">
			<a href="#">
				<i class="fa fa-fw fa-search" aria-hidden="true"></i>
				<span class="screen-reader-text">Search</span>
			</a>
		</span>
	</div><!-- .mobile-bar-items -->
				<button class="menu-toggle" aria-controls="primary-menu" aria-expanded="false">
								<span class="mobile-menu">Menu</span>
			</button>
			<div id="primary-menu" class="main-nav"><ul id="menu-men-mobile" class=" menu sf-menu"><li id="menu-item-46666" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-46666"><a href="http://theballerlife.com"><i class="fa fa-home" aria-hidden="true"></i> HOME</a></li>
<li id="menu-item-46663" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-46663"><a href="http://theballerlife.com/category/celebrity-videos/">Videos<span role="button" class="dropdown-menu-toggle" aria-expanded="false"></span></a>
<ul class="sub-menu">
	<li id="menu-item-56718" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56718"><a href="http://theballerlife.com/category/heartfelt-post/">Heartfelt Post</a></li>
	<li id="menu-item-56724" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-56724"><a href="http://theballerlife.com/category/celebrity-videos/">Celebrity Videos</a></li>
	<li id="menu-item-56719" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56719"><a href="http://theballerlife.com/category/motivational-videos/">Motivational Videos</a></li>
</ul>
</li>
<li id="menu-item-46664" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-46664"><a href="http://theballerlife.com/category/celebrity-news/">News<span role="button" class="dropdown-menu-toggle" aria-expanded="false"></span></a>
<ul class="sub-menu">
	<li id="menu-item-56723" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-56723"><a href="http://theballerlife.com/category/celebrity-news/">Celebrity News</a></li>
	<li id="menu-item-56722" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56722"><a href="http://theballerlife.com/category/sports-news/">Sports News</a></li>
</ul>
</li>
<li id="menu-item-56667" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-56667"><a href="http://theballerlife.com/category/baller-lifestyle/">Lifestyle<span role="button" class="dropdown-menu-toggle" aria-expanded="false"></span></a>
<ul class="sub-menu">
	<li id="menu-item-56716" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56716"><a href="http://theballerlife.com/category/baller-cars/">Baller Cars</a></li>
	<li id="menu-item-56717" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56717"><a href="http://theballerlife.com/category/baller-cribs/">Baller Cribs</a></li>
	<li id="menu-item-56715" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56715"><a href="http://theballerlife.com/category/marriage-proposals/">marriage proposals</a></li>
</ul>
</li>
<li id="menu-item-46665" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-46665"><a href="http://theballerlife.com/category/wife-girlfriend/">Wives/Girlfriends<span role="button" class="dropdown-menu-toggle" aria-expanded="false"></span></a>
<ul class="sub-menu">
	<li id="menu-item-56712" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56712"><a href="http://theballerlife.com/category/wife-girlfriend/movie-actors-wives/">Actors Wives</a></li>
	<li id="menu-item-56706" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56706"><a href="http://theballerlife.com/category/nba-ballers/">NBA Wives</a></li>
	<li id="menu-item-56710" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56710"><a href="http://theballerlife.com/category/nba-girlfriends/">NBA Girlfriends</a></li>
	<li id="menu-item-56707" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56707"><a href="http://theballerlife.com/category/nfl-ballers/">NFL Wives</a></li>
	<li id="menu-item-56711" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56711"><a href="http://theballerlife.com/category/nfl-girlfriends/">NFL Girlfriends</a></li>
	<li id="menu-item-56708" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56708"><a href="http://theballerlife.com/category/mlb-girlfriends/">MLB Girlfriends</a></li>
	<li id="menu-item-56709" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56709"><a href="http://theballerlife.com/category/mlb-ballers/">MLB Wives</a></li>
	<li id="menu-item-56713" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56713"><a href="http://theballerlife.com/category/rappers/">Rapper Wives</a></li>
	<li id="menu-item-56714" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56714"><a href="http://theballerlife.com/category/r-b-singer-wives/">R &#038; B Singer Wives</a></li>
	<li id="menu-item-56721" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56721"><a href="http://theballerlife.com/category/other-sports-wives-girlfriends/">Other Sports Wives Girlfriends</a></li>
</ul>
</li>
<li class="search-item" title="Search"><a href="#"><i class="fa fa-fw fa-search" aria-hidden="true"></i><span class="screen-reader-text">Search</span></a></li></ul></div>		</div><!-- .inside-navigation -->
	</nav><!-- #site-navigation -->
		
	<div id="page" class="hfeed site grid-container container grid-parent">
		<div id="content" class="site-content">
			<div class="featured-post-single">

		<div class="wposrp-recent-post design-1 wposrp-clearfix">

							
	<div class="wposrpcolumns wposrp-medium-5 responsive-1">
		<a class="recent-link-overlay" href="http://theballerlife.com/2017/04/18/daymond-john-speaks-on-his-recent-engagement-to-fiancee-heather-taras-prenups-his-successful-career-more-video/"></a>

		<div class="recent-grid">
			<!-- <div class="recent-overlay"> -->
				<div class="recent-image-bg" style="height:150px">

											 <img src="http://theballerlife.com/wp-content/uploads/2017/04/daymond-john-fiancee-wife-heather-taras-pics-photos-engagement.jpg"/> 
					</div><!-- end .recent-image-bg -->				
				<!-- </div> end .recent-overlay -->
				<div class="recent-content">

					<div class="recent-title">
						<h5 style="font-size: 14px">Daymond John Speaks On His Recent Engagement To Fiancee Heather Taras, Prenups, His Successful Career &#038; More! (Video)</h5>
					</div>

				</div><!-- end .recent-content -->
			</div> <!-- End .recent-grid -->
	</div> <!-- End .wposrpcolumns -->	
	<div class="wposrpcolumns wposrp-medium-5 responsive-2">
		<a class="recent-link-overlay" href="http://theballerlife.com/2017/04/18/oh-no-la-la-and-carmelo-anthony-reportedly-separate-after-6-years-of-marriage-video/"></a>

		<div class="recent-grid">
			<!-- <div class="recent-overlay"> -->
				<div class="recent-image-bg" style="height:150px">

											 <img src="http://theballerlife.com/wp-content/uploads/2017/04/carmelo-anthony-lala-split.jpg"/> 
					</div><!-- end .recent-image-bg -->				
				<!-- </div> end .recent-overlay -->
				<div class="recent-content">

					<div class="recent-title">
						<h5 style="font-size: 14px">Oh No: La La and Carmelo Anthony Reportedly Separate After 6 Years Of Marriage! (Video)</h5>
					</div>

				</div><!-- end .recent-content -->
			</div> <!-- End .recent-grid -->
	</div> <!-- End .wposrpcolumns -->	
	<div class="wposrpcolumns wposrp-medium-5 responsive-3">
		<a class="recent-link-overlay" href="http://theballerlife.com/2017/04/16/so-sad-nba-star-isaiah-thomas-sister-chyna-dies-in-car-crash-in-washington-video/"></a>

		<div class="recent-grid">
			<!-- <div class="recent-overlay"> -->
				<div class="recent-image-bg" style="height:150px">

											 <img src="http://theballerlife.com/wp-content/uploads/2017/04/Isaiah-Thomas-pics-photos.jpg"/> 
					</div><!-- end .recent-image-bg -->				
				<!-- </div> end .recent-overlay -->
				<div class="recent-content">

					<div class="recent-title">
						<h5 style="font-size: 14px">So Sad: NBA Star Isaiah Thomas&#8217; Sister, Chyna, Dies In Car Crash In Washington! (Video)</h5>
					</div>

				</div><!-- end .recent-content -->
			</div> <!-- End .recent-grid -->
	</div> <!-- End .wposrpcolumns -->	
	<div class="wposrpcolumns wposrp-medium-5 responsive-4">
		<a class="recent-link-overlay" href="http://theballerlife.com/2017/04/12/tyrese-gibson-says-myblackqueen-samantha-gibson-is-46-black-her-ethnicity-test-proves-it/"></a>

		<div class="recent-grid">
			<!-- <div class="recent-overlay"> -->
				<div class="recent-image-bg" style="height:150px">

											 <img src="http://theballerlife.com/wp-content/uploads/2017/04/tyrese-gibson-new-wife-samantha-gibson-pics.jpg"/> 
					</div><!-- end .recent-image-bg -->				
				<!-- </div> end .recent-overlay -->
				<div class="recent-content">

					<div class="recent-title">
						<h5 style="font-size: 14px">Tyrese Gibson Says #MyBlackQueen Samantha Gibson Is 46% Black: &#8216;Her Ethnicity Test Proves It!&#8217; (Video)</h5>
					</div>

				</div><!-- end .recent-content -->
			</div> <!-- End .recent-grid -->
	</div> <!-- End .wposrpcolumns -->	
	<div class="wposrpcolumns wposrp-medium-5 responsive-5">
		<a class="recent-link-overlay" href="http://theballerlife.com/2017/04/12/dwayne-the-rock-johnsons-long-time-girlfriend-lauren-hashian/"></a>

		<div class="recent-grid">
			<!-- <div class="recent-overlay"> -->
				<div class="recent-image-bg" style="height:150px">

											 <img src="http://theballerlife.com/wp-content/uploads/2017/04/dwayne-the-rock-johnson-wife-girlfriend-lauren-hashian-photos-pics.jpg"/> 
					</div><!-- end .recent-image-bg -->				
				<!-- </div> end .recent-overlay -->
				<div class="recent-content">

					<div class="recent-title">
						<h5 style="font-size: 14px">Dwayne &#8216;The Rock&#8221; Johnson&#8217;s Long Time Girlfriend Lauren Hashian</h5>
					</div>

				</div><!-- end .recent-content -->
			</div> <!-- End .recent-grid -->
	</div> <!-- End .wposrpcolumns -->
		</div><!-- end .wposrp-recent-post -->

	</div>
<div class="under-featured-post-ad-single">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- 728x90 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:90px"
     data-ad-client="ca-pub-5342939612884568"
     data-ad-slot="7719001020"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<div class="under-featured-post-ad-single-mobile">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- 320x100 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:320px;height:100px"
     data-ad-client="ca-pub-5342939612884568"
     data-ad-slot="3796925825"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

		<div id="primary" class="content-area grid-parent mobile-grid-100 grid-70 tablet-grid-70">
		<main id="main" class="site-main">
				

			
<article id="post-57840" class="post-57840 post type-post status-publish format-standard hentry category-trending-news category-celebrity-news category-celebrity-videos" itemtype='http://schema.org/CreativeWork' itemscope='itemscope'>
	<div class="inside-article">
				
		<header class="entry-header">
										<h1 class="entry-title" itemprop="headline">Tameka &#8220;Tiny&#8221; Harris Talks Strained Marriage With T.I.,  Her Dancing With Floyd Mayweather , Reality TV And More! (Video)</h1>								<div class="entry-meta">
			<span class="posted-on"><a href="http://theballerlife.com/2017/04/26/tameka-tiny-harris-talks-strained-marriage-with-t-i-her-dancing-with-floyd-mayweather-reality-tv-and-more-video/" title="5:07 pm" rel="bookmark"><time class="entry-date published" datetime="2017-04-26T17:07:43+00:00" itemprop="datePublished">Wednesday, April 26, 2017</time><time class="updated" datetime="2017-04-26T17:08:10+00:00" itemprop="dateModified">Wednesday, April 26, 2017</time></a></span> <span class="byline"><span class="author vcard" itemtype="http://schema.org/Person" itemscope="itemscope" itemprop="author">by <a class="url fn n" href="http://theballerlife.com/author/admin/" title="View all posts by BW Staff" rel="author" itemprop="url"><span class="author-name" itemprop="name">BW Staff</span></a></span></span>		</div><!-- .entry-meta -->
			</header><!-- .entry-header -->
		
		
<div class="social-media-shre-buttons-top">
<aside class="mashsb-container mashsb-main mashsb-stretched"><div class="mashsb-box"><div class="mashsb-buttons"><a  class="mashicon-facebook mash-large mash-center mashsb-noshadow" href="https://www.facebook.com/sharer.php?u=http%3A%2F%2Ftheballerlife.com%2F2017%2F04%2F26%2Ftameka-tiny-harris-talks-strained-marriage-with-t-i-her-dancing-with-floyd-mayweather-reality-tv-and-more-video%2F" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Share&nbsp;On&nbsp;Facebook</span></a><a  class="mashicon-twitter mash-large mash-center mashsb-noshadow" href="https://twitter.com/intent/tweet?text=Tameka%20%22Tiny%22%20Harris%20Talks%20Strained%20Marriage%20With%20T.I.%2C%20%20Her%20Dancing%20With%20Floyd%20Mayweather%20%2C%20Reality%20TV%20And%20More%21%20%28Video%29&url=http://theballerlife.com/2017/04/26/tameka-tiny-harris-talks-strained-marriage-with-t-i-her-dancing-with-floyd-mayweather-reality-tv-and-more-video/&via=ballerwives" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Tweet&nbsp;This......</span></a><a  class="mashicon-subscribe mash-large mash-center mashsb-noshadow" href="#" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Subscribe&nbsp;To&nbsp;Email&nbsp;List</span></a><div class="onoffswitch2 mash-large mashsb-noshadow" style="display:none;"></div></div></div>
                    <div style="clear:both;"></div></aside>
            <!-- Share buttons made by mashshare.net - Version: 3.4.1--></div>		

<div class="entry-content" itemprop="text">

			<p><a href="http://theballerlife.com/wp-content/uploads/2017/04/tiny-talks-marriage-to-TI.jpg"><img src="http://theballerlife.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="http://theballerlife.com/wp-content/uploads/2017/04/tiny-talks-marriage-to-TI.jpg" data-attachment-id="57841" data-permalink="http://theballerlife.com/2017/04/26/tameka-tiny-harris-talks-strained-marriage-with-t-i-her-dancing-with-floyd-mayweather-reality-tv-and-more-video/tiny-talks-marriage-to-ti/#main" data-orig-file="http://theballerlife.com/wp-content/uploads/2017/04/tiny-talks-marriage-to-TI.jpg" data-orig-size="650,376" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="tiny-talks-marriage-to-TI" data-image-description data-medium-file="http://theballerlife.com/wp-content/uploads/2017/04/tiny-talks-marriage-to-TI-300x174.jpg" data-large-file="http://theballerlife.com/wp-content/uploads/2017/04/tiny-talks-marriage-to-TI.jpg" alt width="650" height="376" class="aligncenter size-full wp-image-57841" srcset="http://theballerlife.com/wp-content/uploads/2017/04/tiny-talks-marriage-to-TI.jpg 650w, http://theballerlife.com/wp-content/uploads/2017/04/tiny-talks-marriage-to-TI-300x174.jpg 300w, http://theballerlife.com/wp-content/uploads/2017/04/tiny-talks-marriage-to-TI-200x116.jpg 200w, http://theballerlife.com/wp-content/uploads/2017/04/tiny-talks-marriage-to-TI-240x139.jpg 240w" sizes="(max-width: 650px) 100vw, 650px"><noscript><img data-attachment-id="57841" data-permalink="http://theballerlife.com/2017/04/26/tameka-tiny-harris-talks-strained-marriage-with-t-i-her-dancing-with-floyd-mayweather-reality-tv-and-more-video/tiny-talks-marriage-to-ti/#main" data-orig-file="http://theballerlife.com/wp-content/uploads/2017/04/tiny-talks-marriage-to-TI.jpg" data-orig-size="650,376" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="tiny-talks-marriage-to-TI" data-image-description="" data-medium-file="http://theballerlife.com/wp-content/uploads/2017/04/tiny-talks-marriage-to-TI-300x174.jpg" data-large-file="http://theballerlife.com/wp-content/uploads/2017/04/tiny-talks-marriage-to-TI.jpg" src="http://theballerlife.com/wp-content/uploads/2017/04/tiny-talks-marriage-to-TI.jpg" alt="" width="650" height="376" class="aligncenter size-full wp-image-57841" srcset="http://theballerlife.com/wp-content/uploads/2017/04/tiny-talks-marriage-to-TI.jpg 650w, http://theballerlife.com/wp-content/uploads/2017/04/tiny-talks-marriage-to-TI-300x174.jpg 300w, http://theballerlife.com/wp-content/uploads/2017/04/tiny-talks-marriage-to-TI-200x116.jpg 200w, http://theballerlife.com/wp-content/uploads/2017/04/tiny-talks-marriage-to-TI-240x139.jpg 240w" sizes="(max-width: 650px) 100vw, 650px" /></noscript></a><br />
<span id="more-57840"></span><br />
Tameka &#8220;Tiny&#8221; Harris stopped by the &#8220;Wendy Williams Show&#8221; recently and opened up about her strained marriage with husband T.I., her dancing with Floyd Mayweather, the effect reality TV had on her life and much more.</p><div><div class="ad-after-first"><script type="text/javascript">var vclk_options = {sid:58120,media_id:1,media_type:5,version:"1.4"};</script><script class="vclk_pub_code" type="text/javascript" src="http://cdn.fastclick.net/js/adcodes/pubcode.min.js?sid=58120&media_id=1&media_type=5&version=1.4&exc=1"></script><noscript><a href="http://media.fastclick.net/w/click.here?sid=58120&m=1&c=1" target="_blank"><img src="http://theballerlife.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="http://media.fastclick.net/w/get.media?sid=58120&#038;m=1&#038;tp=5&#038;d=s&#038;c=1&#038;vcm_acv=1.4" width="728" height="90" border="1"><noscript><img src="http://media.fastclick.net/w/get.media?sid=58120&m=1&tp=5&d=s&c=1&vcm_acv=1.4" width="728" height="90" border="1"></noscript></a></noscript></div>
<div class="ad-after-first-mobile">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Mobile 300x250 Unit -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-5342939612884568"
     data-ad-slot="3453847020"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

</div>
<p><strong>Watch the video below&#8230;</strong></p>
<p><iframe width="760" height="515" src="https://www.youtube.com/embed/n0WI1EDV9HQ" frameborder="0" allowfullscreen></iframe></p>

		
</div><!-- .entry-content -->

<div class="social-media-shre-buttons-bottom">
<aside class="mashsb-container mashsb-main mashsb-stretched"><div class="mashsb-box"><div class="mashsb-buttons"><a  class="mashicon-facebook mash-large mash-center mashsb-noshadow" href="https://www.facebook.com/sharer.php?u=http%3A%2F%2Ftheballerlife.com%2F2017%2F04%2F26%2Ftameka-tiny-harris-talks-strained-marriage-with-t-i-her-dancing-with-floyd-mayweather-reality-tv-and-more-video%2F" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Share&nbsp;On&nbsp;Facebook</span></a><a  class="mashicon-twitter mash-large mash-center mashsb-noshadow" href="https://twitter.com/intent/tweet?text=Tameka%20%22Tiny%22%20Harris%20Talks%20Strained%20Marriage%20With%20T.I.%2C%20%20Her%20Dancing%20With%20Floyd%20Mayweather%20%2C%20Reality%20TV%20And%20More%21%20%28Video%29&url=http://theballerlife.com/2017/04/26/tameka-tiny-harris-talks-strained-marriage-with-t-i-her-dancing-with-floyd-mayweather-reality-tv-and-more-video/&via=ballerwives" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Tweet&nbsp;This......</span></a><a  class="mashicon-subscribe mash-large mash-center mashsb-noshadow" href="#" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Subscribe&nbsp;To&nbsp;Email&nbsp;List</span></a><div class="onoffswitch2 mash-large mashsb-noshadow" style="display:none;"></div></div></div>
                    <div style="clear:both;"></div></aside>
            <!-- Share buttons made by mashshare.net - Version: 3.4.1--></div>

<div class="under-post-320-50ad-mobile">
<!-- Conversant Media 320x50 Small Banner CODE for BallerWives.com -->
<script type="text/javascript">var vclk_options = {sid:58120,media_id:15,media_type:17,version:"1.4"};</script><script class="vclk_pub_code" type="text/javascript" src="http://cdn.fastclick.net/js/adcodes/pubcode.min.js?sid=58120&media_id=15&media_type=17&version=1.4&exc=1"></script><noscript><a href="http://media.fastclick.net/w/click.here?sid=58120&m=15&c=1" target="_blank"><img src="http://media.fastclick.net/w/get.media?sid=58120&m=15&tp=17&d=s&c=1&vcm_acv=1.4" width="320" height="50" border="1"></a></noscript>
<!-- Conversant Media 320x50 Small Banner CODE for BallerWives.com -->
</div>

<div class="taboola-ad">
<div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'thumbnails-a',
    container: 'taboola-below-article-thumbnails',
    placement: 'Below Article Thumbnails',
    target_type: 'mix'
  });
</script> 
</div>

<div class="under-post-300-250ad-mobile">
<!-- Conversant Media 300x250 Medium Rectangle CODE for BallerWives.com -->
<script type="text/javascript">var vclk_options = {sid:58120,media_id:6,media_type:8,version:"1.4"};</script><script class="vclk_pub_code" type="text/javascript" src="http://cdn.fastclick.net/js/adcodes/pubcode.min.js?sid=58120&media_id=6&media_type=8&version=1.4&exc=1"></script><noscript><a href="http://media.fastclick.net/w/click.here?sid=58120&m=6&c=1" target="_blank"><img src="http://media.fastclick.net/w/get.media?sid=58120&m=6&tp=8&d=s&c=1&vcm_acv=1.4" width="300" height="250" border="1"></a></noscript>
<!-- Conversant Media 300x250 Medium Rectangle CODE for BallerWives.com -->
</div>

<div class="related-post-thumb">
<div class="crp_related "><h3>SEE ALSO:</h3><ul><li><a href="http://theballerlife.com/2017/04/21/morris-chestnut-talks-new-fitness-book-fatherhood-marriage-to-his-wife-of-over-20-years-pam-byse-video/"    ><img src="http://theballerlife.com/wp-content/uploads/2017/04/morris-chestnut-wife-pam-pics-photos--168x200.jpg" alt="Morris Chestnut Talks New Fitness Book, Fatherhood &#038; Marriage To His Wife Of Over 20 Years Pam Byse (Video)" title="Morris Chestnut Talks New Fitness Book, Fatherhood &#038; Marriage To His Wife Of Over 20 Years Pam Byse (Video)" width="240" height="200" class="crp_thumb crp_correctfirst" /><span class="crp_title">Morris Chestnut Talks New Fitness Book, Fatherhood &#038; Marriage To His Wife Of Over 20 Years Pam&hellip;</span></a></li><li><a href="http://theballerlife.com/2017/04/06/t-i-talks-writing-letters-to-president-trump-supporting-snoop-dogg-7-kids-more-video/"    ><img src="http://theballerlife.com/wp-content/uploads/2017/04/ti-clifford-harris-interview-theview-240x191.jpg" alt="T.I. Talks Writing Letters To President Trump, Supporting Snoop Dogg, 7 Kids &#038; More! (Video)" title="T.I. Talks Writing Letters To President Trump, Supporting Snoop Dogg, 7 Kids &#038; More! (Video)" width="240" height="200" class="crp_thumb crp_correctfirst" /><span class="crp_title">T.I. Talks Writing Letters To President Trump, Supporting Snoop Dogg, 7 Kids &#038; More! (Video)</span></a></li><li><a href="http://theballerlife.com/2017/03/22/rick-ross-speaks-on-why-he-called-out-birdman-the-advice-he-gave-meek-mill-about-nicki-minaj-new-music-more-video/"    ><img src="http://theballerlife.com/wp-content/uploads/2017/03/rick-ross-interview-wendy-williams-video-240x138.jpg" alt="Rick Ross Speaks On Why He Called Out Birdman, The Advice He Gave Meek Mill About Nicki Minaj, New Music &#038; More! (Video)" title="Rick Ross Speaks On Why He Called Out Birdman, The Advice He Gave Meek Mill About Nicki Minaj, New Music &#038; More! (Video)" width="240" height="200" class="crp_thumb crp_correctfirst" /><span class="crp_title">Rick Ross Speaks On Why He Called Out Birdman, The Advice He Gave Meek Mill About Nicki Minaj, New&hellip;</span></a></li><li><a href="http://theballerlife.com/2017/01/23/meagan-good-speaks-on-how-she-handles-criticism-from-the-church-community-about-the-way-she-dresses-video/"    ><img src="http://theballerlife.com/wp-content/uploads/2017/01/meagan-good-talks-church-community-sexy-dressing-video-240x142.jpg" alt="Meagan Good Speaks On How She Handles Criticism From The Church Community About The Way She Dresses! (Video)" title="Meagan Good Speaks On How She Handles Criticism From The Church Community About The Way She Dresses! (Video)" width="240" height="200" class="crp_thumb crp_correctfirst" /><span class="crp_title">Meagan Good Speaks On How She Handles Criticism From The Church Community About The Way She Dresses!</span></a></li><li><a href="http://theballerlife.com/2017/01/27/kelly-rowland-talks-motherhood-her-2-year-old-son-family-life-music-and-new-lifetime-movie-video/"    ><img src="http://theballerlife.com/wp-content/uploads/2017/01/kelly-rowland-son-husband-pics-photos-203x200.jpg" alt="Kelly Rowland Talks Motherhood, Her 2-Year Old Son, Family Life, Music And New Lifetime Movie! (Video)" title="Kelly Rowland Talks Motherhood, Her 2-Year Old Son, Family Life, Music And New Lifetime Movie! (Video)" width="240" height="200" class="crp_thumb crp_correctfirst" /><span class="crp_title">Kelly Rowland Talks Motherhood, Her 2-Year Old Son, Family Life, Music And New Lifetime Movie!&hellip;</span></a></li><li><a href="http://theballerlife.com/2017/03/07/heartfelt-wendy-williams-breaks-down-in-tears-while-discussing-chris-browns-alleged-drug-addiction-video/"    ><img src="http://theballerlife.com/wp-content/uploads/2017/03/wendy-williams-cries-over-chris-brown-alleged-drug-abuse-240x150.jpg" alt="Heartfelt: Wendy Williams Breaks Down In Tears While Discussing Chris Brown&#8217;s Alleged Drug Addiction! (Video)" title="Heartfelt: Wendy Williams Breaks Down In Tears While Discussing Chris Brown&#8217;s Alleged Drug Addiction! (Video)" width="240" height="200" class="crp_thumb crp_correctfirst" /><span class="crp_title">Heartfelt: Wendy Williams Breaks Down In Tears While Discussing Chris Brown&#8217;s Alleged Drug&hellip;</span></a></li></ul><div class="crp_clear"></div></div></div>

		<footer class="entry-meta">
			<span class="cat-links"><span class="screen-reader-text">Categories </span><a href="http://theballerlife.com/category/trending-news/" rel="category tag">#Trending News</a>, <a href="http://theballerlife.com/category/celebrity-news/" rel="category tag">Celebrity News</a>, <a href="http://theballerlife.com/category/celebrity-videos/" rel="category tag">Celebrity Videos</a></span>				<nav id="nav-below" class="post-navigation">
		<h6 class="screen-reader-text">Post navigation</h6>

	
		<div class="nav-previous"><span class="prev" title="Previous"><a href="http://theballerlife.com/2017/04/26/serena-williams-opens-up-about-pregnancy-love-life-and-career-video/" rel="prev">Serena Williams Opens Up About Pregnancy, Love Life And Career! (Video)</a></span></div>		
	
	</nav><!-- #nav-below -->
			</footer><!-- .entry-meta -->
	

<div class="matched-content">
<div id="zergnet-widget-51646"></div>

<script language="javascript" type="text/javascript">
    (function() {
        var zergnet = document.createElement('script');
        zergnet.type = 'text/javascript'; zergnet.async = true;
        zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=51646';
        var znscr = document.getElementsByTagName('script')[0];
        znscr.parentNode.insertBefore(zergnet, znscr);
    })();
</script>
</div>

<div class="under-post-300-250ad-mobile">
<!-- Conversant Media 300x250 Medium Rectangle CODE for BallerWives.com -->
<script type="text/javascript">var vclk_options = {sid:58120,media_id:6,media_type:8,version:"1.4"};</script><script class="vclk_pub_code" type="text/javascript" src="http://cdn.fastclick.net/js/adcodes/pubcode.min.js?sid=58120&media_id=6&media_type=8&version=1.4&exc=1"></script><noscript><a href="http://media.fastclick.net/w/click.here?sid=58120&m=6&c=1" target="_blank"><img src="http://media.fastclick.net/w/get.media?sid=58120&m=6&tp=8&d=s&c=1&vcm_acv=1.4" width="300" height="250" border="1"></a></noscript>
<!-- Conversant Media 300x250 Medium Rectangle CODE for BallerWives.com -->
</div>		

<h4 class="first-post-title"><span>Check Out These Related Post</span></h4>

<div class="related-post-thumb1">
<div style="clear: both"></div><div style="border: 0pt none ; margin: 0pt; padding: 0pt;"><a onmouseout="this.style.backgroundColor='#fff'" onmouseover="this.style.backgroundColor='#FFFFFF'" style="background-color: #fff; border-right: 1px solid #FFFFFF; border-bottom: medium none; margin: 0pt; padding: 6px; display: block; float: left; text-decoration: none; text-align: left; cursor: pointer;" href="http://theballerlife.com/2017/01/28/michael-jordan-surprises-serena-williams-with-some-custom-jordans-for-her-23rd-grand-slam-win-video/"><div style="border: 0pt none ; margin: 0pt; padding: 0pt; width: 150px; height: 215px;"><div style="border: 0pt none ; margin: 0pt; padding: 0pt; background: transparent url(http://theballerlife.com/wp-content/uploads/2017/01/serena-williams-23-grand-slam-video-jordan--150x150.jpg) no-repeat scroll 0% 0%; -moz-background-clip: border; -moz-background-origin: padding; -moz-background-inline-policy: continuous; width: 150px; height: 150px;"></div><div style="border: 0pt none; margin: 3px 0pt 0pt; padding: 0pt; font-family: ; font-style: normal; font-variant: normal; font-weight: normal; font-size: 12px; line-height: normal; font-size-adjust: none; font-stretch: normal; -x-system-font: none; color: #000000;">Michael Jordan Surprises Serena Williams With Some Custom Jordans For Her 23rd Grand Slam Win! (Vide...</div></div></a><a onmouseout="this.style.backgroundColor='#fff'" onmouseover="this.style.backgroundColor='#FFFFFF'" style="background-color: #fff; border-right: 1px solid #FFFFFF; border-bottom: medium none; margin: 0pt; padding: 6px; display: block; float: left; text-decoration: none; text-align: left; cursor: pointer;" href="http://theballerlife.com/2017/02/05/watch-atlanta-falcons-fans-get-into-an-airport-wide-dance-off-while-headed-to-the-superbowl-51-video/"><div style="border: 0pt none ; margin: 0pt; padding: 0pt; width: 150px; height: 215px;"><div style="border: 0pt none ; margin: 0pt; padding: 0pt; background: transparent url(http://theballerlife.com/wp-content/uploads/2017/02/atlanta-falcon-fans-dance-off-airport-video-150x150.jpg) no-repeat scroll 0% 0%; -moz-background-clip: border; -moz-background-origin: padding; -moz-background-inline-policy: continuous; width: 150px; height: 150px;"></div><div style="border: 0pt none; margin: 3px 0pt 0pt; padding: 0pt; font-family: ; font-style: normal; font-variant: normal; font-weight: normal; font-size: 12px; line-height: normal; font-size-adjust: none; font-stretch: normal; -x-system-font: none; color: #000000;">Watch: Atlanta Falcons Fans Get Into An Airport Wide Dance Off While Headed To The SuperBowl 51! (Vi...</div></div></a><a onmouseout="this.style.backgroundColor='#fff'" onmouseover="this.style.backgroundColor='#FFFFFF'" style="background-color: #fff; border-right: 1px solid #FFFFFF; border-bottom: medium none; margin: 0pt; padding: 6px; display: block; float: left; text-decoration: none; text-align: left; cursor: pointer;" href="http://theballerlife.com/2017/02/18/johnny-gill-dishes-on-the-new-edition-story-tension-in-the-group-stacy-lattisaw-much-more-video/"><div style="border: 0pt none ; margin: 0pt; padding: 0pt; width: 150px; height: 215px;"><div style="border: 0pt none ; margin: 0pt; padding: 0pt; background: transparent url(http://theballerlife.com/wp-content/uploads/2017/02/johnny-gill-interview-breakfast-video-150x150.jpg) no-repeat scroll 0% 0%; -moz-background-clip: border; -moz-background-origin: padding; -moz-background-inline-policy: continuous; width: 150px; height: 150px;"></div><div style="border: 0pt none; margin: 3px 0pt 0pt; padding: 0pt; font-family: ; font-style: normal; font-variant: normal; font-weight: normal; font-size: 12px; line-height: normal; font-size-adjust: none; font-stretch: normal; -x-system-font: none; color: #000000;">Johnny Gill Dishes On The New Edition Story, Tension In The Group, Stacy Lattisaw &amp; Much More! (...</div></div></a><a onmouseout="this.style.backgroundColor='#fff'" onmouseover="this.style.backgroundColor='#FFFFFF'" style="background-color: #fff; border-right: 1px solid #FFFFFF; border-bottom: medium none; margin: 0pt; padding: 6px; display: block; float: left; text-decoration: none; text-align: left; cursor: pointer;" href="http://theballerlife.com/2017/03/04/remy-ma-reveals-the-real-reason-she-went-hard-dissing-nicki-minaj-on-shether-track-video/"><div style="border: 0pt none ; margin: 0pt; padding: 0pt; width: 150px; height: 215px;"><div style="border: 0pt none ; margin: 0pt; padding: 0pt; background: transparent url(http://theballerlife.com/wp-content/uploads/2017/03/remy-ma-interview-wendy-williams-nicki-minaj-150x150.jpg) no-repeat scroll 0% 0%; -moz-background-clip: border; -moz-background-origin: padding; -moz-background-inline-policy: continuous; width: 150px; height: 150px;"></div><div style="border: 0pt none; margin: 3px 0pt 0pt; padding: 0pt; font-family: ; font-style: normal; font-variant: normal; font-weight: normal; font-size: 12px; line-height: normal; font-size-adjust: none; font-stretch: normal; -x-system-font: none; color: #000000;">Remy Ma Reveals The Real Reason She Went Hard Dissing Nicki Minaj On 'Shether' Track! (Video)</div></div></a><a onmouseout="this.style.backgroundColor='#fff'" onmouseover="this.style.backgroundColor='#FFFFFF'" style="background-color: #fff; border-right: 1px solid #FFFFFF; border-bottom: medium none; margin: 0pt; padding: 6px; display: block; float: left; text-decoration: none; text-align: left; cursor: pointer;" href="http://theballerlife.com/2017/03/29/wow-read-this-story-of-the-woman-uber-driver-who-unexpectedly-picked-up-her-boyfriends-side-chick-and-drove-her-to-his-house/"><div style="border: 0pt none ; margin: 0pt; padding: 0pt; width: 150px; height: 215px;"><div style="border: 0pt none ; margin: 0pt; padding: 0pt; background: transparent url(http://theballerlife.com/wp-content/uploads/2017/03/UBERBAE-Msixella-PICS-STORY-150x150.jpg) no-repeat scroll 0% 0%; -moz-background-clip: border; -moz-background-origin: padding; -moz-background-inline-policy: continuous; width: 150px; height: 150px;"></div><div style="border: 0pt none; margin: 3px 0pt 0pt; padding: 0pt; font-family: ; font-style: normal; font-variant: normal; font-weight: normal; font-size: 12px; line-height: normal; font-size-adjust: none; font-stretch: normal; -x-system-font: none; color: #000000;">Wow: Read This Story Of The Woman Uber Driver Who Unexpectedly Picked Up Her Boyfriend’s Side Chick ...</div></div></a><a onmouseout="this.style.backgroundColor='#fff'" onmouseover="this.style.backgroundColor='#FFFFFF'" style="background-color: #fff; border-right: 1px solid #FFFFFF; border-bottom: medium none; margin: 0pt; padding: 6px; display: block; float: left; text-decoration: none; text-align: left; cursor: pointer;" href="http://theballerlife.com/2017/04/02/sanaa-lathan-talks-police-brutality-race-president-trump-and-new-series-shots-fired-video/"><div style="border: 0pt none ; margin: 0pt; padding: 0pt; width: 150px; height: 215px;"><div style="border: 0pt none ; margin: 0pt; padding: 0pt; background: transparent url(http://theballerlife.com/wp-content/uploads/2017/04/sanna-lathan-interview-150x150.jpg) no-repeat scroll 0% 0%; -moz-background-clip: border; -moz-background-origin: padding; -moz-background-inline-policy: continuous; width: 150px; height: 150px;"></div><div style="border: 0pt none; margin: 3px 0pt 0pt; padding: 0pt; font-family: ; font-style: normal; font-variant: normal; font-weight: normal; font-size: 12px; line-height: normal; font-size-adjust: none; font-stretch: normal; -x-system-font: none; color: #000000;">Sanaa Lathan Talks Police Brutality, Race, President Trump And New Series 'Shots Fired' (Video)</div></div></a><a onmouseout="this.style.backgroundColor='#fff'" onmouseover="this.style.backgroundColor='#FFFFFF'" style="background-color: #fff; border-right: 1px solid #FFFFFF; border-bottom: medium none; margin: 0pt; padding: 6px; display: block; float: left; text-decoration: none; text-align: left; cursor: pointer;" href="http://theballerlife.com/2017/04/05/still-on-katie-holmes-and-jamie-foxx-are-reportedly-still-going-strong-video/"><div style="border: 0pt none ; margin: 0pt; padding: 0pt; width: 150px; height: 215px;"><div style="border: 0pt none ; margin: 0pt; padding: 0pt; background: transparent url(http://theballerlife.com/wp-content/uploads/2017/04/katie0holmes-jamie-fox-dating-pics-photos-150x150.jpg) no-repeat scroll 0% 0%; -moz-background-clip: border; -moz-background-origin: padding; -moz-background-inline-policy: continuous; width: 150px; height: 150px;"></div><div style="border: 0pt none; margin: 3px 0pt 0pt; padding: 0pt; font-family: ; font-style: normal; font-variant: normal; font-weight: normal; font-size: 12px; line-height: normal; font-size-adjust: none; font-stretch: normal; -x-system-font: none; color: #000000;">Still On: Katie Holmes and Jamie Foxx Are Reportedly Still Going Strong!! (Video)</div></div></a><a onmouseout="this.style.backgroundColor='#fff'" onmouseover="this.style.backgroundColor='#FFFFFF'" style="background-color: #fff; border-right: 1px solid #FFFFFF; border-bottom: medium none; margin: 0pt; padding: 6px; display: block; float: left; text-decoration: none; text-align: left; cursor: pointer;" href="http://theballerlife.com/2017/04/18/daymond-john-speaks-on-his-recent-engagement-to-fiancee-heather-taras-prenups-his-successful-career-more-video/"><div style="border: 0pt none ; margin: 0pt; padding: 0pt; width: 150px; height: 215px;"><div style="border: 0pt none ; margin: 0pt; padding: 0pt; background: transparent url(http://theballerlife.com/wp-content/uploads/2017/04/daymond-john-fiancee-wife-heather-taras-pics-photos-engagement-150x150.jpg) no-repeat scroll 0% 0%; -moz-background-clip: border; -moz-background-origin: padding; -moz-background-inline-policy: continuous; width: 150px; height: 150px;"></div><div style="border: 0pt none; margin: 3px 0pt 0pt; padding: 0pt; font-family: ; font-style: normal; font-variant: normal; font-weight: normal; font-size: 12px; line-height: normal; font-size-adjust: none; font-stretch: normal; -x-system-font: none; color: #000000;">Daymond John Speaks On His Recent Engagement To Fiancee Heather Taras, Prenups, His Successful Caree...</div></div></a></div><div style="clear: both"></div></div>

<h4 class="first-post-title"><span>Check Out These Stories</span></h4>

<div class="earnify-widget" data-widget-id="7948"></div>

<div id="spaceundernav">
<div class="facebook">
<div class="fb-page" data-href="https://www.facebook.com/ballerwives" data-width="330" data-height="250" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><blockquote cite="https://www.facebook.com/ballerwives" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/ballerwives">BallerWives.com</a></blockquote></div>
</div>
<div class="banner300">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- 300x250, created 6/22/10 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-5342939612884568"
     data-ad-slot="2117225603"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</div>

<div class="related-post-thumb-mobile">
<div class="crp_related "><h3>SEE ALSO:</h3><ul><li><a href="http://theballerlife.com/2017/04/21/morris-chestnut-talks-new-fitness-book-fatherhood-marriage-to-his-wife-of-over-20-years-pam-byse-video/"    ><img src="http://theballerlife.com/wp-content/uploads/2017/04/morris-chestnut-wife-pam-pics-photos--168x200.jpg" alt="Morris Chestnut Talks New Fitness Book, Fatherhood &#038; Marriage To His Wife Of Over 20 Years Pam Byse (Video)" title="Morris Chestnut Talks New Fitness Book, Fatherhood &#038; Marriage To His Wife Of Over 20 Years Pam Byse (Video)" width="240" height="200" class="crp_thumb crp_correctfirst" /><span class="crp_title">Morris Chestnut Talks New Fitness Book, Fatherhood &#038; Marriage To His Wife Of Over 20 Years Pam&hellip;</span></a></li><li><a href="http://theballerlife.com/2017/04/06/t-i-talks-writing-letters-to-president-trump-supporting-snoop-dogg-7-kids-more-video/"    ><img src="http://theballerlife.com/wp-content/uploads/2017/04/ti-clifford-harris-interview-theview-240x191.jpg" alt="T.I. Talks Writing Letters To President Trump, Supporting Snoop Dogg, 7 Kids &#038; More! (Video)" title="T.I. Talks Writing Letters To President Trump, Supporting Snoop Dogg, 7 Kids &#038; More! (Video)" width="240" height="200" class="crp_thumb crp_correctfirst" /><span class="crp_title">T.I. Talks Writing Letters To President Trump, Supporting Snoop Dogg, 7 Kids &#038; More! (Video)</span></a></li><li><a href="http://theballerlife.com/2017/03/22/rick-ross-speaks-on-why-he-called-out-birdman-the-advice-he-gave-meek-mill-about-nicki-minaj-new-music-more-video/"    ><img src="http://theballerlife.com/wp-content/uploads/2017/03/rick-ross-interview-wendy-williams-video-240x138.jpg" alt="Rick Ross Speaks On Why He Called Out Birdman, The Advice He Gave Meek Mill About Nicki Minaj, New Music &#038; More! (Video)" title="Rick Ross Speaks On Why He Called Out Birdman, The Advice He Gave Meek Mill About Nicki Minaj, New Music &#038; More! (Video)" width="240" height="200" class="crp_thumb crp_correctfirst" /><span class="crp_title">Rick Ross Speaks On Why He Called Out Birdman, The Advice He Gave Meek Mill About Nicki Minaj, New&hellip;</span></a></li><li><a href="http://theballerlife.com/2017/01/23/meagan-good-speaks-on-how-she-handles-criticism-from-the-church-community-about-the-way-she-dresses-video/"    ><img src="http://theballerlife.com/wp-content/uploads/2017/01/meagan-good-talks-church-community-sexy-dressing-video-240x142.jpg" alt="Meagan Good Speaks On How She Handles Criticism From The Church Community About The Way She Dresses! (Video)" title="Meagan Good Speaks On How She Handles Criticism From The Church Community About The Way She Dresses! (Video)" width="240" height="200" class="crp_thumb crp_correctfirst" /><span class="crp_title">Meagan Good Speaks On How She Handles Criticism From The Church Community About The Way She Dresses!</span></a></li><li><a href="http://theballerlife.com/2017/01/27/kelly-rowland-talks-motherhood-her-2-year-old-son-family-life-music-and-new-lifetime-movie-video/"    ><img src="http://theballerlife.com/wp-content/uploads/2017/01/kelly-rowland-son-husband-pics-photos-203x200.jpg" alt="Kelly Rowland Talks Motherhood, Her 2-Year Old Son, Family Life, Music And New Lifetime Movie! (Video)" title="Kelly Rowland Talks Motherhood, Her 2-Year Old Son, Family Life, Music And New Lifetime Movie! (Video)" width="240" height="200" class="crp_thumb crp_correctfirst" /><span class="crp_title">Kelly Rowland Talks Motherhood, Her 2-Year Old Son, Family Life, Music And New Lifetime Movie!&hellip;</span></a></li><li><a href="http://theballerlife.com/2017/03/07/heartfelt-wendy-williams-breaks-down-in-tears-while-discussing-chris-browns-alleged-drug-addiction-video/"    ><img src="http://theballerlife.com/wp-content/uploads/2017/03/wendy-williams-cries-over-chris-brown-alleged-drug-abuse-240x150.jpg" alt="Heartfelt: Wendy Williams Breaks Down In Tears While Discussing Chris Brown&#8217;s Alleged Drug Addiction! (Video)" title="Heartfelt: Wendy Williams Breaks Down In Tears While Discussing Chris Brown&#8217;s Alleged Drug Addiction! (Video)" width="240" height="200" class="crp_thumb crp_correctfirst" /><span class="crp_title">Heartfelt: Wendy Williams Breaks Down In Tears While Discussing Chris Brown&#8217;s Alleged Drug&hellip;</span></a></li></ul><div class="crp_clear"></div></div></div>		

</div><!-- .inside-article -->
</article><!-- #post-## -->
<input type="hidden" name="IL_IN_TAG" value="2"/>
<h4 class="first-post-title"><span>Leave A Comment</span></h4>
								<div class="comments-area">
						
	<div id="comments">

	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/04/26/tameka-tiny-harris-talks-strained-marriage-with-t-i-her-dancing-with-floyd-mayweather-reality-tv-and-more-video/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://theballerlife.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-form-comment"><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><input placeholder="Name *" id="author" name="author" type="text" value="" size="30" />
<input placeholder="Email *" id="email" name="email" type="text" value="" size="30" />
<input placeholder="Website" id="url" name="url" type="text" value="" size="30" />
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='57840' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="b87474bcb2" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="120"/></p>			</form>
			</div><!-- #respond -->
	
</div><!-- #comments -->
					</div>
			
		
				</main><!-- #main -->

	</div><!-- #primary -->

<div id="right-sidebar" itemtype="http://schema.org/WPSideBar" itemscope="itemscope" role="complementary" class="widget-area grid-30 tablet-grid-30 grid-parent sidebar">
	<div class="inside-right-sidebar">
				<aside id="text-640378483" class="widget inner-padding widget_text">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- 336x280 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:336px;height:280px"
     data-ad-client="ca-pub-5342939612884568"
     data-ad-slot="3391707423"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</aside><aside id="text-640378492" class="widget inner-padding widget_text">			<div class="textwidget"><!-- Conversant Media 300x250 Medium Rectangle CODE for BallerWives.com -->
<script type="text/javascript">var vclk_options = {sid:58120,media_id:6,media_type:8,version:"1.4"};</script><script class="vclk_pub_code" type="text/javascript" src="http://cdn.fastclick.net/js/adcodes/pubcode.min.js?sid=58120&media_id=6&media_type=8&version=1.4&exc=1"></script><noscript><a href="http://media.fastclick.net/w/click.here?sid=58120&m=6&c=1" target="_blank"><img src="http://media.fastclick.net/w/get.media?sid=58120&m=6&tp=8&d=s&c=1&vcm_acv=1.4" width="300" height="250" border="1"/></a></noscript>
<!-- Conversant Media 300x250 Medium Rectangle CODE for BallerWives.com --></div>
		</aside><aside id="text-640378495" class="widget inner-padding widget_text">			<div class="textwidget"><div id="zergnet-widget-51647"></div>

<script language="javascript" type="text/javascript">
    (function() {
        var zergnet = document.createElement('script');
        zergnet.type = 'text/javascript'; zergnet.async = true;
        zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=51647';
        var znscr = document.getElementsByTagName('script')[0];
        znscr.parentNode.insertBefore(zergnet, znscr);
    })();
</script></div>
		</aside><aside id="text-640378494" class="widget inner-padding widget_text"><div class="widget-title"><span>You May Also Like:</span></div>			<div class="textwidget"><div id="taboola-right-rail-thumbnails"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'right-rail-bulk1',
    container: 'taboola-right-rail-thumbnails',
    placement: 'Right Rail Thumbnails',
    target_type: 'mix'
  });
</script></div>
		</aside><aside id="text-640378493" class="widget inner-padding widget_text">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- 300x600 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-5342939612884568"
     data-ad-slot="3112505826"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</aside><aside id="wpfp_recentpostlist_widget-5" class="widget inner-padding wpfp-featured-fplw"><div class="widget-title"><span>Latest Celeb News</span></div>
        <div class="wpfp-featured-post-widget-wrp wpfp-clearfix ">
            <div class="wpfp-widget wpfp-recent-post-widget" id="wpfp-recent-post-widget-1">

                
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/04/26/tameka-tiny-harris-talks-strained-marriage-with-t-i-her-dancing-with-floyd-mayweather-reality-tv-and-more-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/04/tiny-talks-marriage-to-TI.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/04/26/tameka-tiny-harris-talks-strained-marriage-with-t-i-her-dancing-with-floyd-mayweather-reality-tv-and-more-video/" title="Tameka &#8220;Tiny&#8221; Harris Talks Strained Marriage With T.I.,  Her Dancing With Floyd Mayweather , Reality TV And More! (Video)" style="font-size: 14px">Tameka &#8220;Tiny&#8221; Harris Talks Strained Marriage With T.I.,  Her Dancing With Floyd Mayweather , Reality TV And More! (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/04/26/serena-williams-opens-up-about-pregnancy-love-life-and-career-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/04/serena-williams-talks-pregnancy-interview-video.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/04/26/serena-williams-opens-up-about-pregnancy-love-life-and-career-video/" title="Serena Williams Opens Up About Pregnancy, Love Life And Career! (Video)" style="font-size: 14px">Serena Williams Opens Up About Pregnancy, Love Life And Career! (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                            </div><!-- end .wpfp-recent-post -->

    </div><!-- end .wpfp-featured-post-widget-wrp -->

    </aside><aside id="wpfp_recentpostlist_widget-2" class="widget inner-padding wpfp-featured-fplw"><div class="widget-title"><span>NFL Wives &#038; Girlfriends</span></div>
        <div class="wpfp-featured-post-widget-wrp wpfp-clearfix ">
            <div class="wpfp-widget wpfp-recent-post-widget" id="wpfp-recent-post-widget-2">

                
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/03/08/wow-emmanuel-sanders-wife-gabriella-files-divorce-docs-breaking-down-how-he-spent-a-ton-of-money-on-his-side-chicks-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/03/emanuel-sanders-wife-gabriella-waheed-pics-photos.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/03/08/wow-emmanuel-sanders-wife-gabriella-files-divorce-docs-breaking-down-how-he-spent-a-ton-of-money-on-his-side-chicks-video/" title="Wow: Emmanuel Sanders’ Wife Gabriella Files Divorce Docs Breaking Down How He Spent A Ton Of Money On His Side Chicks! (Video)" style="font-size: 14px">Wow: Emmanuel Sanders’ Wife Gabriella Files Divorce Docs Breaking Down How He Spent A Ton Of Money On His Side Chicks! (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/01/25/watch-pregnant-ciara-wilson-sings-a-rendition-of-diana-ross-im-coming-out-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/01/ciara-singing-diana-ross-im-coming-out.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/01/25/watch-pregnant-ciara-wilson-sings-a-rendition-of-diana-ross-im-coming-out-video/" title="Watch: Pregnant Ciara Wilson Sings A Rendition Of  Diana Ross’ &#8220;I’m Coming Out!&#8221; (Video)" style="font-size: 14px">Watch: Pregnant Ciara Wilson Sings A Rendition Of  Diana Ross’ &#8220;I’m Coming Out!&#8221; (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                            </div><!-- end .wpfp-recent-post -->

    </div><!-- end .wpfp-featured-post-widget-wrp -->

    </aside><aside id="wpfp_recentpostlist_widget-3" class="widget inner-padding wpfp-featured-fplw"><div class="widget-title"><span>NBA Wives &#038; Girlfriends</span></div>
        <div class="wpfp-featured-post-widget-wrp wpfp-clearfix ">
            <div class="wpfp-widget wpfp-recent-post-widget" id="wpfp-recent-post-widget-3">

                
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/04/18/oh-no-la-la-and-carmelo-anthony-reportedly-separate-after-6-years-of-marriage-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/04/carmelo-anthony-lala-split.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/04/18/oh-no-la-la-and-carmelo-anthony-reportedly-separate-after-6-years-of-marriage-video/" title="Oh No: La La and Carmelo Anthony Reportedly Separate After 6 Years Of Marriage! (Video)" style="font-size: 14px">Oh No: La La and Carmelo Anthony Reportedly Separate After 6 Years Of Marriage! (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/03/07/congratulations-russell-westbrook-and-wife-nina-announce-their-expecting-first-child-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/03/russell-westbrook-wife-nina-pics-photos.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/03/07/congratulations-russell-westbrook-and-wife-nina-announce-their-expecting-first-child-video/" title="Congratulations: Russell Westbrook And Wife Nina Announce Their Expecting First Child! (Video)" style="font-size: 14px">Congratulations: Russell Westbrook And Wife Nina Announce Their Expecting First Child! (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                            </div><!-- end .wpfp-recent-post -->

    </div><!-- end .wpfp-featured-post-widget-wrp -->

    </aside><aside id="wpfp_recentpostlist_widget-4" class="widget inner-padding wpfp-featured-fplw"><div class="widget-title"><span>Actor Wives &#038; Girlfriends</span></div>
        <div class="wpfp-featured-post-widget-wrp wpfp-clearfix ">
            <div class="wpfp-widget wpfp-recent-post-widget" id="wpfp-recent-post-widget-4">

                
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/04/25/oh-no-jesse-williams-wife-aryn-drake-lee-amicably-file-for-divorce-after-5-years-of-marriage-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/04/jesse-williams-wife-Aryn_Drake-Lee-photos-pics.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/04/25/oh-no-jesse-williams-wife-aryn-drake-lee-amicably-file-for-divorce-after-5-years-of-marriage-video/" title="Oh No: Jesse Williams &#038; Wife Aryn Drake-Lee Amicably File For Divorce After 5 Years Of Marriage! (Video)" style="font-size: 14px">Oh No: Jesse Williams &#038; Wife Aryn Drake-Lee Amicably File For Divorce After 5 Years Of Marriage! (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/04/12/tyrese-gibson-says-myblackqueen-samantha-gibson-is-46-black-her-ethnicity-test-proves-it/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/04/tyrese-gibson-new-wife-samantha-gibson-pics.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/04/12/tyrese-gibson-says-myblackqueen-samantha-gibson-is-46-black-her-ethnicity-test-proves-it/" title="Tyrese Gibson Says #MyBlackQueen Samantha Gibson Is 46% Black: &#8216;Her Ethnicity Test Proves It!&#8217; (Video)" style="font-size: 14px">Tyrese Gibson Says #MyBlackQueen Samantha Gibson Is 46% Black: &#8216;Her Ethnicity Test Proves It!&#8217; (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                            </div><!-- end .wpfp-recent-post -->

    </div><!-- end .wpfp-featured-post-widget-wrp -->

    </aside><aside id="wpfp_recentpostlist_widget-8" class="widget inner-padding wpfp-featured-fplw"><div class="widget-title"><span>Heartfelt Stories</span></div>
        <div class="wpfp-featured-post-widget-wrp wpfp-clearfix ">
            <div class="wpfp-widget wpfp-recent-post-widget" id="wpfp-recent-post-widget-5">

                
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/04/16/so-sad-nba-star-isaiah-thomas-sister-chyna-dies-in-car-crash-in-washington-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/04/Isaiah-Thomas-pics-photos.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/04/16/so-sad-nba-star-isaiah-thomas-sister-chyna-dies-in-car-crash-in-washington-video/" title="So Sad: NBA Star Isaiah Thomas&#8217; Sister, Chyna, Dies In Car Crash In Washington! (Video)" style="font-size: 14px">So Sad: NBA Star Isaiah Thomas&#8217; Sister, Chyna, Dies In Car Crash In Washington! (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/04/15/so-sad-ex-nfl-player-todd-heap-accidentally-hits-kills-his-3-year-old-daughter-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/04/todd-heap-daughter-killed-accidentally-by-truck.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/04/15/so-sad-ex-nfl-player-todd-heap-accidentally-hits-kills-his-3-year-old-daughter-video/" title="So Sad: Ex-NFL Player Todd Heap Accidentally Hits &#038; Kills His 3-Year-Old Daughter! (Video)" style="font-size: 14px">So Sad: Ex-NFL Player Todd Heap Accidentally Hits &#038; Kills His 3-Year-Old Daughter! (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                            </div><!-- end .wpfp-recent-post -->

    </div><!-- end .wpfp-featured-post-widget-wrp -->

    </aside><aside id="text-640378490" class="widget inner-padding widget_text">			<div class="textwidget"><div class="fb-page" data-href="https://www.facebook.com/ballerwives" data-width="330" data-height="100" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><blockquote cite="https://www.facebook.com/ballerwives" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/ballerwives">BallerWives.com</a></blockquote></div></div>
		</aside>			</div><!-- .inside-right-sidebar -->
</div><!-- #secondary -->
	</div><!-- #content -->
</div><!-- #page -->



<div class="site-footer grid-container grid-parent">
		<footer class="site-info" itemtype="http://schema.org/WPFooter" itemscope="itemscope">
		<div class="inside-site-info grid-container grid-parent">
			<a href='http://theballerlife.com/contact-us'>Contact Us</a> | <a href='http://theballerlife.com/terms-of-use'>Terms of Use</a> | <a href='http://theballerlife.com/sitemap.xml'>Site Map</a> | <a href='http://theballerlife.com/privacy'>Privacy Statement</a><br />Copyright © 2016 TheBallerLife.com All Rights Reserved.
		</div>
	</footer><!-- .site-info -->
	</div><!-- .site-footer -->

	<nav itemtype="http://schema.org/SiteNavigationElement" itemscope="itemscope" id="generate-slideout-menu" class="main-navigation slideout-navigation">
		<div class="inside-navigation grid-container grid-parent">
						<div class="screen-reader-text skip-link"><a href="#content" title="Skip to content">Skip to content</a></div>
			<div class="main-nav"><ul id="menu-men-mobile-1" class=" slideout-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-46666"><a href="http://theballerlife.com"><i class="fa fa-home" aria-hidden="true"></i> HOME</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-46663"><a href="http://theballerlife.com/category/celebrity-videos/">Videos<span role="button" class="dropdown-menu-toggle" aria-expanded="false"></span></a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56718"><a href="http://theballerlife.com/category/heartfelt-post/">Heartfelt Post</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-56724"><a href="http://theballerlife.com/category/celebrity-videos/">Celebrity Videos</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56719"><a href="http://theballerlife.com/category/motivational-videos/">Motivational Videos</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-46664"><a href="http://theballerlife.com/category/celebrity-news/">News<span role="button" class="dropdown-menu-toggle" aria-expanded="false"></span></a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-56723"><a href="http://theballerlife.com/category/celebrity-news/">Celebrity News</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56722"><a href="http://theballerlife.com/category/sports-news/">Sports News</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-56667"><a href="http://theballerlife.com/category/baller-lifestyle/">Lifestyle<span role="button" class="dropdown-menu-toggle" aria-expanded="false"></span></a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56716"><a href="http://theballerlife.com/category/baller-cars/">Baller Cars</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56717"><a href="http://theballerlife.com/category/baller-cribs/">Baller Cribs</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56715"><a href="http://theballerlife.com/category/marriage-proposals/">marriage proposals</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-46665"><a href="http://theballerlife.com/category/wife-girlfriend/">Wives/Girlfriends<span role="button" class="dropdown-menu-toggle" aria-expanded="false"></span></a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56712"><a href="http://theballerlife.com/category/wife-girlfriend/movie-actors-wives/">Actors Wives</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56706"><a href="http://theballerlife.com/category/nba-ballers/">NBA Wives</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56710"><a href="http://theballerlife.com/category/nba-girlfriends/">NBA Girlfriends</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56707"><a href="http://theballerlife.com/category/nfl-ballers/">NFL Wives</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56711"><a href="http://theballerlife.com/category/nfl-girlfriends/">NFL Girlfriends</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56708"><a href="http://theballerlife.com/category/mlb-girlfriends/">MLB Girlfriends</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56709"><a href="http://theballerlife.com/category/mlb-ballers/">MLB Wives</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56713"><a href="http://theballerlife.com/category/rappers/">Rapper Wives</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56714"><a href="http://theballerlife.com/category/r-b-singer-wives/">R &#038; B Singer Wives</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56721"><a href="http://theballerlife.com/category/other-sports-wives-girlfriends/">Other Sports Wives Girlfriends</a></li>
</ul>
</li>
</ul></div>					</div><!-- .inside-navigation -->
	</nav><!-- #site-navigation -->
	<div class="slideout-overlay" style="display: none;"></div>
		<div style="display:none">
	</div>
	<a title="Scroll back to top" rel="nofollow" href="#" class="generate-back-to-top" style="opacity:0;visibility:hidden;" data-scroll-speed="400" data-start-scroll="300"><i class="fa fa-angle-up" aria-hidden="true"></i><span class="screen-reader-text">Scroll back to top</span></a>
	<!-- Scroll Triggered Boxes v2.2.1 - https://wordpress.org/plugins/scroll-triggered-boxes/-->			<div class="stb-container stb-center-container">
				<div class="scroll-triggered-box stb stb-56807 stb-center"
				     id="stb-56807"
				     style="display: none;">
					<div class="stb-content">
						<h3 style="text-align: center;"><strong><span style="color: #000000;">LIKE OUR SITE?</span></strong></h3>
<h4 style="text-align: center;"><span style="color: #000000;"><strong>Well, show us some love and click the Facebook <span style="color: #3366ff;">&#8220;Like&#8221; </span>Button Below!</strong></span></h4>
<div class="fb-like" data-href="https://facebook.com/ballerwives" data-layout="button_count" data-action="like" data-size="large" data-show-faces="false" data-share="false"></div>
<p>&nbsp;<br />
<a href="http://theballerlife.com/category/nba-ballers/" target="_blank"><img class="aligncenter size-full wp-image-57211" src="http://theballerlife.com/wp-content/uploads/2017/01/ballerwives-popup.png" alt="" width="300" height="152" /></a></p>
					</div>
											<span class="stb-close">&times;</span>
									</div>
			</div>
			<div id="stb-overlay"></div><!-- / Scroll Triggered Box --><script type='text/javascript' src='http://theballerlife.com/wp-content/plugins/akismet/_inc/form.js?ver=3.3'></script>
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='http://theballerlife.com/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel-ie8fix.css?ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript' src='http://theballerlife.com/wp-content/plugins/gp-premium/menu-plus/functions/js/sticky.min.js?ver=1.2.90'></script>
<!--[if lt IE 10]>
<script type='text/javascript' src='http://theballerlife.com/wp-content/plugins/gp-premium/menu-plus/functions/js/matchMedia.min.js?ver=1.2.90'></script>
<![endif]-->
<script type='text/javascript' src='http://theballerlife.com/wp-content/plugins/gp-premium/menu-plus/functions/js/sliiide.min.js?ver=1.2.90'></script>
<script type='text/javascript' src='http://theballerlife.com/wp-content/plugins/gp-premium/menu-plus/functions/js/navigation.min.js?ver=1.2.90'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201717'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mashsb = {"shares":"0","round_shares":"1","animate_shares":"0","dynamic_buttons":"0","share_url":"http:\/\/theballerlife.com\/2017\/04\/26\/tameka-tiny-harris-talks-strained-marriage-with-t-i-her-dancing-with-floyd-mayweather-reality-tv-and-more-video\/","title":"Tameka+%E2%80%9CTiny%E2%80%9D+Harris+Talks+Strained+Marriage+With+T.I.%2C++Her+Dancing+With+Floyd+Mayweather+%2C+Reality+TV+And+More%21+%28Video%29","image":null,"desc":"Tameka \"Tiny\" Harris stopped by the \"Wendy Williams Show\" recently and opened up about her strained marriage with husband T.I., her dancing with Floyd Mayweather, the effect reality TV had on her life and much \u2026","hashtag":"@ballerwives","subscribe":"link","subscribe_url":"http:\/\/feedburner.google.com\/fb\/a\/mailverify?uri=BallerWives","activestatus":"1","singular":"1","twitter_popup":"1","refresh":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='http://theballerlife.com/wp-content/plugins/mashsharer/assets/js/mashsb.min.js?ver=3.4.1'></script>
<script type='text/javascript' src='http://theballerlife.com/wp-content/themes/generatepress/js/dropdown-click.min.js?ver=1.3.41'></script>
<script type='text/javascript' src='http://theballerlife.com/wp-content/themes/generatepress/js/navigation-search.min.js?ver=1.3.41'></script>
<script type='text/javascript' src='http://theballerlife.com/wp-content/themes/generatepress/js/back-to-top.min.js?ver=1.3.41'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='http://theballerlife.com/wp-content/themes/generatepress/js/html5shiv.min.js?ver=1.3.41'></script>
<![endif]-->
<script type='text/javascript' src='http://theballerlife.com/wp-content/plugins/lazy-load/js/jquery.sonar.min.js?ver=0.6.1'></script>
<script type='text/javascript' src='http://theballerlife.com/wp-content/plugins/lazy-load/js/lazy-load.js?ver=0.6.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var STB_Global_Options = {"testMode":""};
var STB_Box_Options = {"56807":{"id":56807,"title":"Facebook Like Message","trigger":"percentage","triggerPercentage":70,"triggerElementSelector":"","animation":"fade","cookieTime":1,"autoHide":true,"autoShow":true,"position":"center","minimumScreenWidth":0,"unclosable":false}};
/* ]]> */
</script>
<script type='text/javascript' src='http://theballerlife.com/wp-content/plugins/scroll-triggered-boxes/assets/js/script.min.js?ver=2.2.1'></script>
<script type='text/javascript' src='http://theballerlife.com/wp-content/plugins/gp-premium/secondary-nav/functions/js/navigation.min.js?ver=1.2.90'></script>
<script type='text/javascript' src='http://theballerlife.com/wp-includes/js/wp-embed.min.js?ver=4.7.4'></script>
<script type='text/javascript' src='http://theballerlife.com/wp-content/plugins/jetpack/_inc/spin.js?ver=1.3'></script>
<script type='text/javascript' src='http://theballerlife.com/wp-content/plugins/jetpack/_inc/jquery.spin.js?ver=1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"http:\/\/theballerlife.com\/wp-admin\/admin-ajax.php","nonce":"fa66c5ab4f","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"http:\/\/theballerlife.com\/wp-login.php?redirect_to=http%3A%2F%2Ftheballerlife.com%2F2017%2F04%2F26%2Ftameka-tiny-harris-talks-strained-marriage-with-t-i-her-dancing-with-floyd-mayweather-reality-tv-and-more-video%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='http://theballerlife.com/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel.js?ver=20170209'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201717.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.8.2',blog:'121774942',post:'57840',tz:'-7',srv:'theballerlife.com'} ]);
	_stq.push([ 'clickTrackerInit', '121774942', '57840' ]);
</script>

<script src="http://services.picadmedia.com/js/picad.js" type="text/javascript"></script><script type="text/javascript">picadService.set('token','');picadService.initialize(); </script>

<script>ggv2id='e473d7fe';</script><script src="https://g2.gumgum.com/javascripts/ggv2.js"></script> 

<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script> 


<!-- start Vibrant Media IntelliTXT script section -->
<script type="text/javascript" src="http://ballerwives.us.intellitxt.com/intellitxt/front.asp?ipid=30857"></script>
<!-- end Vibrant Media IntelliTXT script section -->

<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({flush: true});
</script>

<script type="text/javascript">
var infolinks_pid = 2407402;
var infolinks_wsid = 1;
</script>
<script type="text/javascript" src="//resources.infolinks.com/js/infolinks_main.js"></script>
<script type="text/javascript">
    (function() {
        var a = document.createElement("script");
        var b = document.getElementsByTagName("script")[0];
        a.async = 1;
        a.src = "//cdn.earnify.com/widget.min.js";
        b.parentNode.insertBefore(a, b);
    })();
</script>
</body>
</html>
<!-- This Quick Cache file was built for (  theballerlife.com/2017/04/26/tameka-tiny-harris-talks-strained-marriage-with-t-i-her-dancing-with-floyd-mayweather-reality-tv-and-more-video/ ) in 0.94579 seconds, on Apr 27th, 2017 at 6:43 pm UTC. -->
<!-- This Quick Cache file will automatically expire ( and be re-built automatically ) on Apr 27th, 2017 at 7:43 pm UTC -->