<!DOCTYPE html>
<html lang="en-US"
	prefix="og: http://ogp.me/ns#" >
<head>
	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=edge" />
	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="http://theballerlife.com/xmlrpc.php">
	<title>Watch: LeBron James Surprises Students At His &quot;I PROMISE School&quot; With $1 Million Dollar Grant For New Gym (Video) | | The Baller Life -  BallerWives.com</title>

<!-- All in One SEO Pack 2.12.1 by Michael Torbert of Semper Fi Web Design[276,457] -->
<link rel="author" href="https://plus.google.com/117266833494320081327" />
<meta name="description"  content="TheBallerLife.com has learned that NBA star LeBron James surprised students at his new &quot;I PROMISE&#039; school in Akron, Ohio with a $1 million dollar grant from the" />

<meta name="keywords"  content="baller lifestyle" />

<link rel="canonical" href="http://theballerlife.com/2019/05/12/watch-lebron-james-surprises-students-at-his-i-promise-school-with-1-million-dollar-grant-for-new-gym-video/" />
<meta property="og:title" content="Watch: LeBron James Surprises Students At His &quot;I PROMISE School&quot; With $1 Million Dollar Grant For New Gym (Video)" />
<meta property="og:type" content="article" />
<meta property="og:url" content="http://theballerlife.com/2019/05/12/watch-lebron-james-surprises-students-at-his-i-promise-school-with-1-million-dollar-grant-for-new-gym-video/" />
<meta property="og:image" content="http://theballerlife.com/wp-content/uploads/2019/05/lebron-james-1-million-dollar-gym.jpg" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="315" />
<meta property="og:site_name" content="TheBallerLife.com - BallerWives.com" />
<meta property="fb:admins" content="148854525161108" />
<meta property="fb:app_id" content="117418662243617" />
<meta property="og:description" content="Watch: LeBron James Surprises Students At His &quot;I PROMISE School&quot; With $1 Million Dollar Grant For New Gym (Video)" />
<meta property="article:tag" content="baller lifestyle" />
<meta property="article:publisher" content="https://facebook.com/ballerwives" />
<meta property="article:published_time" content="2019-05-12T15:43:36Z" />
<meta property="article:modified_time" content="2019-05-12T15:43:36Z" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@ballerwives" />
<meta name="twitter:domain" content="theballerlife.com" />
<meta name="twitter:title" content="Watch: LeBron James Surprises Students At His &quot;I PROMISE School&quot; With $1 Million Dollar Grant For New Gym (Video)" />
<meta name="twitter:description" content="Watch: LeBron James Surprises Students At His &quot;I PROMISE School&quot; With $1 Million Dollar Grant For New Gym (Video)" />
<meta name="twitter:image" content="http://theballerlife.com/wp-content/uploads/2019/05/lebron-james-1-million-dollar-gym.jpg" />
<meta itemprop="image" content="http://theballerlife.com/wp-content/uploads/2019/05/lebron-james-1-million-dollar-gym.jpg" />
			<script type="text/javascript" >
				window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
				ga('create', 'UA-9445838-1', 'auto');
				// Plugins
				
				ga('send', 'pageview');
			</script>
			<script async src="https://www.google-analytics.com/analytics.js"></script>
			<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="The Baller Life -  BallerWives.com &raquo; Feed" href="http://theballerlife.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Baller Life -  BallerWives.com &raquo; Comments Feed" href="http://theballerlife.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Baller Life -  BallerWives.com &raquo; Watch: LeBron James Surprises Students At His &#8220;I PROMISE School&#8221; With $1 Million Dollar Grant For New Gym (Video) Comments Feed" href="http://theballerlife.com/2019/05/12/watch-lebron-james-surprises-students-at-his-i-promise-school-with-1-million-dollar-grant-for-new-gym-video/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/theballerlife.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.1.1"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
		  <style type="text/css">
	  .wp-pagenavi{float:left !important; }

	  .wp-pagenavi a,.wp-pagenavi a:link,.wp-pagenavi a:visited,.wp-pagenavi a:active,.wp-pagenavi span.extend { background:#000000 !important; border:1px solid #666666 !important; color:#ffffff !important; }
	  .wp-pagenavi a:hover,.wp-pagenavi span.current
	  {
		  background:#000000 !important; border:1px solid ##444 !important; color:#ffffff !important; 
	  }
	  .wp-pagenavi span.pages { color:#000000 !important; }
	  </style>
	  <link rel='stylesheet' id='generate-fonts-css'  href='//fonts.googleapis.com/css?family=Open+Sans:300,300italic,regular,italic,600,600italic,700,700italic,800,800italic' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.1.1/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='crp-style-rounded-thumbs-css'  href='http://theballerlife.com/wp-content/plugins/contextual-related-posts/css/default-style.css?ver=1.0' type='text/css' media='all' />
<style id='crp-style-rounded-thumbs-inline-css' type='text/css'>

.crp_related a {
  width: 240px;
  height: 200px;
  text-decoration: none;
}
.crp_related img {
  max-width: 240px;
  margin: auto;
}
.crp_related .crp_title {
  width: 100%;
}
                
</style>
<link rel='stylesheet' id='generate-page-header-css'  href='http://theballerlife.com/wp-content/plugins/gp-premium/page-header/functions/css/page-header-min.css?ver=1.5.2' type='text/css' media='all' />
<link rel='stylesheet' id='mashsb-styles-css'  href='http://theballerlife.com/wp-content/plugins/mashsharer/assets/css/mashsb.min.css?ver=3.6.3' type='text/css' media='all' />
<style id='mashsb-styles-inline-css' type='text/css'>
.mashsb-count {color:#cccccc;}@media only screen and (min-width:568px){.mashsb-buttons a {min-width: 160px;}}.mashicon-subscribe {
    background: red;
}

.mashicon-subscribe .icon, .mashicon-subscribe .text {
    color: #fff;
}
</style>
<link rel='stylesheet' id='wpfp-public-style-css'  href='http://theballerlife.com/wp-content/plugins/wpos-featured-post2/assets/css/wpfp-public.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='wposrp-public-style-css'  href='http://theballerlife.com/wp-content/plugins/wpos-recent-post/assets/css/wposrp-public.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='generate-style-grid-css'  href='http://theballerlife.com/wp-content/themes/generatepress/css/unsemantic-grid.min.css?ver=1.4' type='text/css' media='all' />
<link rel='stylesheet' id='generate-style-css'  href='http://theballerlife.com/wp-content/themes/generatepress/style.css?ver=1.4' type='text/css' media='all' />
<style id='generate-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='generate-mobile-style-css'  href='http://theballerlife.com/wp-content/themes/generatepress/css/mobile.min.css?ver=1.4' type='text/css' media='all' />
<link rel='stylesheet' id='generate-child-css'  href='http://theballerlife.com/wp-content/themes/generatepress-child/style.css?ver=1549731908' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='http://theballerlife.com/wp-content/themes/generatepress/css/font-awesome.min.css?ver=4.7' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='generate-ie-css'  href='http://theballerlife.com/wp-content/themes/generatepress/css/ie.min.css?ver=1.4' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='rpt_front_style-css'  href='http://theballerlife.com/wp-content/plugins/related-posts-thumbnails/assets/css/front.css?ver=1.6.2' type='text/css' media='all' />
<link rel='stylesheet' id='scroll-triggered-boxes-css'  href='http://theballerlife.com/wp-content/plugins/scroll-triggered-boxes/assets/css/styles.min.css?ver=2.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='generate-blog-css'  href='http://theballerlife.com/wp-content/plugins/gp-premium/blog/functions/css/style-min.css?ver=1.5.2' type='text/css' media='all' />
<link rel='stylesheet' id='generate-secondary-nav-css'  href='http://theballerlife.com/wp-content/plugins/gp-premium/secondary-nav/functions/css/style.min.css?ver=1.5.2' type='text/css' media='all' />
<style id='generate-secondary-nav-inline-css' type='text/css'>
.secondary-navigation{background-color:#333333;}.secondary-navigation .main-nav ul li a,.secondary-navigation .menu-toggle{color:#ffffff;font-weight:bold;text-transform:uppercase;padding-left:10px;padding-right:10px;line-height:30px;}button.secondary-menu-toggle:hover,button.secondary-menu-toggle:focus{color:#ffffff;}.widget-area .secondary-navigation{margin-bottom:10px;}.secondary-navigation ul ul{background-color:#303030;top:auto;}.secondary-navigation .main-nav ul ul li a{color:#ffffff;padding-left:10px;padding-right:10px;}.secondary-navigation .menu-item-has-children .dropdown-menu-toggle{padding-right:10px;}.secondary-navigation .main-nav ul li > a:hover,.secondary-navigation .main-nav ul li > a:focus,.secondary-navigation .main-nav ul li.sfHover > a{color:#ffffff;background-color:#ed2700;}.secondary-navigation .main-nav ul ul li > a:hover,.secondary-navigation .main-nav ul ul li > a:focus,.secondary-navigation .main-nav ul ul li.sfHover > a{color:#ffffff;background-color:#474747;}.secondary-navigation .main-nav ul li[class*="current-menu-"] > a, .secondary-navigation .main-nav ul li[class*="current-menu-"] > a:hover,.secondary-navigation .main-nav ul li[class*="current-menu-"].sfHover > a{color:#ffffff;background-color:#333333;}.secondary-navigation .main-nav ul ul li[class*="current-menu-"] > a,.secondary-navigation .main-nav ul ul li[class*="current-menu-"] > a:hover,.secondary-navigation .main-nav ul ul li[class*="current-menu-"].sfHover > a{color:#ffffff;background-color:#474747;}
</style>
<link rel='stylesheet' id='generate-sticky-css'  href='http://theballerlife.com/wp-content/plugins/gp-premium/menu-plus/functions/css/sticky.min.css?ver=1.5.2' type='text/css' media='all' />
<link rel='stylesheet' id='generate-sliiide-css'  href='http://theballerlife.com/wp-content/plugins/gp-premium/menu-plus/functions/css/sliiide.min.css?ver=1.5.2' type='text/css' media='all' />
<link rel='stylesheet' id='generate-menu-logo-css'  href='http://theballerlife.com/wp-content/plugins/gp-premium/menu-plus/functions/css/menu-logo.min.css?ver=1.5.2' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/7.3/css/jetpack.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-pagenavi-style-css'  href='http://theballerlife.com/wp-content/plugins/wp-pagenavi-style/style/default.css?ver=1.0' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/5.1.1/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.1.1/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<link rel='https://api.w.org/' href='http://theballerlife.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://theballerlife.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://theballerlife.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Common Opens Up About Relationship With His Daughter, Being Molested  As A Child, Finding Love And Much More! (Video)' href='http://theballerlife.com/2019/05/12/common-opens-up-about-relationship-with-his-daughter-being-molested-as-a-child-finding-love-and-much-more-video/' />
<link rel='next' title='Shaquille O’Neal Buys 10 Pairs Of Shoes For Georgia Teen With Size 18 Feet (Video)' href='http://theballerlife.com/2019/05/12/shaquille-oneal-buys-10-pairs-of-shoes-for-georgia-teen-with-size-18-feet-video/' />
<meta name="generator" content="WordPress 5.1.1" />
<link rel='shortlink' href='http://theballerlife.com/?p=63506' />
<link rel="alternate" type="application/json+oembed" href="http://theballerlife.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Ftheballerlife.com%2F2019%2F05%2F12%2Fwatch-lebron-james-surprises-students-at-his-i-promise-school-with-1-million-dollar-grant-for-new-gym-video%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://theballerlife.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Ftheballerlife.com%2F2019%2F05%2F12%2Fwatch-lebron-james-surprises-students-at-his-i-promise-school-with-1-million-dollar-grant-for-new-gym-video%2F&#038;format=xml" />
	<style type="text/css">
	 .wp-pagenavi
	{
		font-size:25px !important;
	}
	</style>
	
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<link rel='dns-prefetch' href='//c0.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style><link rel="pingback" href="http://theballerlife.com/xmlrpc.php">
<meta name="viewport" content="width=device-width, initial-scale=1">       <style>
        #related_posts_thumbnails li{
            border-right: 1px solid #000;
            background-color: #000       }
        #related_posts_thumbnails li:hover{
            background-color: #000;
        }
        .relpost_content{
            font-size: 13px;
            color: #fff;
        }
        .relpost-block-single{
            background-color: #000;
            border-right: 1px solid  #000;
            border-left: 1px solid  #000;
            margin-right: -1px;
        }
        .relpost-block-single:hover{
            background-color: #000;
        }
        </style>

        <style type="text/css">
/* Custom Styles for Box 56807 */
.stb-56807 {
background: #f9f9f9 !important;
color: #1e73be !important;
border-color: #255aea !important;
border-width: 6px !important;
border-style: solid !important;
max-width: 320px;
}

.fb-like {

margin-left: 70px;
}

h4#fb-message {
    background: #3241AF;
     color: #fff;
padding: 5px 0 5px 10px!important;
    margin-top: 8px;
    margin-right: -10px;
    margin-left: -10px;
text-align: center;
height:25px;
}


</style>

<meta name="google-site-verification" content="3BzuJzm54NKE3YhZF_1yTDtZE4x8M0QWaCMWmkbiCEI" />

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-5342939612884568",
    enable_page_level_ads: true
  });
</script>

<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u) {
    e.async = 1;
    e.src = u;
    f.parentNode.insertBefore(e, f);
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  'http://cdn.taboola.com/libtrc/ballerwives/loader.js');
</script>
	
<script type="application/javascript" src="//ced.sascdn.com/tag/3265/smart.js" async></script>
<script type="application/javascript">
    var sas = sas || {};
    sas.cmd = sas.cmd || [];
    sas.cmd.push(function() {
        sas.setup({ networkid: 3265, domain: "//www15.smartadserver.com", async: true });
    });
    sas.cmd.push(function() {
        sas.call("onecall", {
            siteId: 276891,
            pageId: 1027095,
            formats: [
                 { id: 71430 }
                ,{ id: 71427 }
                ,{ id: 71428 }
            ],
            target: ''
        });
    });
</script>
	
</head>

<body itemtype='http://schema.org/Blog' itemscope='itemscope' class="post-template-default single single-post postid-63506 single-format-standard post-image-above-header post-image-aligned-center secondary-nav-below-header secondary-nav-aligned-center slideout-enabled slideout-mobile sticky-menu-no-transition sticky-enabled menu-logo menu-logo-enabled both-sticky-menu  right-sidebar nav-below-header contained-header one-container active-footer-widgets-0 nav-search-enabled nav-aligned-left header-aligned-left dropdown-click dropdown-click-menu-item">
		<a class="screen-reader-text skip-link" href="#content" title="Skip to content">Skip to content</a>
	<header itemtype="http://schema.org/WPHeader" itemscope="itemscope" id="masthead" class="site-header grid-container grid-parent">
		<div class="inside-header grid-container grid-parent">
								<div class="header-widget">
			<aside id="text-640378489" class="widget inner-padding widget_text">			<div class="textwidget"><!-- Conversant Media 468x60 and 728x90 Banner CODE for BallerWives.com -->
<script type="text/javascript">var vclk_options = {sid:58120,media_id:1,media_type:5,version:"1.4"};</script><script class="vclk_pub_code" type="text/javascript" src="http://cdn.fastclick.net/js/adcodes/pubcode.min.js?sid=58120&media_id=1&media_type=5&version=1.4&exc=1"></script><noscript><a href="http://media.fastclick.net/w/click.here?sid=58120&m=1&c=1" target="_blank"><img src="http://media.fastclick.net/w/get.media?sid=58120&m=1&tp=5&d=s&c=1&vcm_acv=1.4" width="728" height="90" border="1"/></a></noscript>
<!-- Conversant Media 468x60 and 728x90 Banner CODE for BallerWives.com --></div>
		</aside>		</div>
						</div><!-- .inside-header -->
	
 


</header><!-- #masthead -->
		<nav itemtype="http://schema.org/SiteNavigationElement" itemscope="itemscope" id="site-navigation" class="main-navigation grid-container grid-parent">
		<div class="inside-navigation grid-container grid-parent">
				<form method="get" class="search-form navigation-search" action="http://theballerlife.com/">
		<input type="search" placeholder="SEARCH HERE...." class="search-field" value="" name="s" title="Search">
	</form>
	<div class="site-logo sticky-logo navigation-logo">
			<a href="http://theballerlife.com/" title="The Baller Life &#8211;  BallerWives.com" rel="home">
				<img class="header-image" src="http://theballerlife.com/wp-content/uploads/2019/02/B6.png" alt="The Baller Life &#8211;  BallerWives.com" />
			</a>
		</div>	<div class="mobile-bar-items">
				<span class="search-item" title="Search">
			<a href="#">
				<i class="fa fa-fw fa-search" aria-hidden="true"></i>
				<span class="screen-reader-text">Search</span>
			</a>
		</span>
	</div><!-- .mobile-bar-items -->
				<button class="menu-toggle" aria-controls="primary-menu" aria-expanded="false">
								<span class="mobile-menu">Menu</span>
			</button>
			<div id="primary-menu" class="main-nav"><ul id="menu-men-mobile" class=" menu sf-menu"><li id="menu-item-46666" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-46666"><a href="http://theballerlife.com"><i class="fa fa-home" aria-hidden="true"></i> HOME</a></li>
<li id="menu-item-46663" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-46663"><a href="http://theballerlife.com/category/celebrity-videos/">Videos<span role="button" class="dropdown-menu-toggle" aria-expanded="false"></span></a>
<ul class="sub-menu">
	<li id="menu-item-56718" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56718"><a href="http://theballerlife.com/category/heartfelt-post/">Heartfelt Post</a></li>
	<li id="menu-item-56724" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56724"><a href="http://theballerlife.com/category/celebrity-videos/">Celebrity Videos</a></li>
	<li id="menu-item-56719" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56719"><a href="http://theballerlife.com/category/motivational-videos/">Motivational Videos</a></li>
</ul>
</li>
<li id="menu-item-46664" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-46664"><a href="http://theballerlife.com/category/celebrity-news/">News<span role="button" class="dropdown-menu-toggle" aria-expanded="false"></span></a>
<ul class="sub-menu">
	<li id="menu-item-56723" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56723"><a href="http://theballerlife.com/category/celebrity-news/">Celebrity News</a></li>
	<li id="menu-item-56722" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56722"><a href="http://theballerlife.com/category/sports-news/">Sports News</a></li>
</ul>
</li>
<li id="menu-item-56667" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-56667"><a href="http://theballerlife.com/category/baller-lifestyle/">Lifestyle<span role="button" class="dropdown-menu-toggle" aria-expanded="false"></span></a>
<ul class="sub-menu">
	<li id="menu-item-56716" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56716"><a href="http://theballerlife.com/category/baller-cars/">Baller Cars</a></li>
	<li id="menu-item-56717" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56717"><a href="http://theballerlife.com/category/baller-cribs/">Baller Cribs</a></li>
	<li id="menu-item-56715" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56715"><a href="http://theballerlife.com/category/marriage-proposals/">marriage proposals</a></li>
</ul>
</li>
<li id="menu-item-46665" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-46665"><a href="http://theballerlife.com/category/wife-girlfriend/">Baller Wives<span role="button" class="dropdown-menu-toggle" aria-expanded="false"></span></a>
<ul class="sub-menu">
	<li id="menu-item-56712" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56712"><a href="http://theballerlife.com/category/wife-girlfriend/movie-actors-wives/">Actors Wives</a></li>
	<li id="menu-item-56706" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56706"><a href="http://theballerlife.com/category/nba-ballers/">NBA Wives</a></li>
	<li id="menu-item-56710" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56710"><a href="http://theballerlife.com/category/nba-girlfriends/">NBA Girlfriends</a></li>
	<li id="menu-item-56707" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56707"><a href="http://theballerlife.com/category/nfl-ballers/">NFL Wives</a></li>
	<li id="menu-item-56711" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56711"><a href="http://theballerlife.com/category/nfl-girlfriends/">NFL Girlfriends</a></li>
	<li id="menu-item-56708" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56708"><a href="http://theballerlife.com/category/mlb-girlfriends/">MLB Girlfriends</a></li>
	<li id="menu-item-56709" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56709"><a href="http://theballerlife.com/category/mlb-ballers/">MLB Wives</a></li>
	<li id="menu-item-56713" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56713"><a href="http://theballerlife.com/category/rappers/">Rapper Wives</a></li>
	<li id="menu-item-56714" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56714"><a href="http://theballerlife.com/category/r-b-singer-wives/">R &#038; B Singer Wives</a></li>
	<li id="menu-item-56721" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56721"><a href="http://theballerlife.com/category/other-sports-wives-girlfriends/">Other Sports Wives Girlfriends</a></li>
</ul>
</li>
<li class="search-item" title="Search"><a href="#"><i class="fa fa-fw fa-search" aria-hidden="true"></i><span class="screen-reader-text">Search</span></a></li></ul></div>		</div><!-- .inside-navigation -->
	</nav><!-- #site-navigation -->
			<nav itemtype="http://schema.org/SiteNavigationElement" itemscope="itemscope" id="secondary-navigation" class="secondary-navigation grid-container grid-parent">
			<div class="inside-navigation grid-container grid-parent">
								<button class="menu-toggle secondary-menu-toggle">
										<span class="mobile-menu">Menu</span>
				</button>
				<div class="main-nav"><ul id="menu-second-nav-menu" class=" secondary-menu sf-menu"><li id="menu-item-59453" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-59453"><a href="http://theballerlife.com">HOME</a></li>
<li id="menu-item-59458" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-59458"><a href="http://theballerlife.com/category/celebrity-news/">News<span role="button" class="dropdown-menu-toggle" aria-expanded="false"></span></a>
<ul class="sub-menu">
	<li id="menu-item-59459" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59459"><a href="http://theballerlife.com/category/celebrity-news/">Celebrity News</a></li>
	<li id="menu-item-59460" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59460"><a href="http://theballerlife.com/category/sports-news/">Sports News</a></li>
	<li id="menu-item-59454" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59454"><a href="http://theballerlife.com/category/celebrity-videos/">Videos</a></li>
	<li id="menu-item-59455" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59455"><a href="http://theballerlife.com/category/heartfelt-post/">Heartfelt Post</a></li>
	<li id="menu-item-59456" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59456"><a href="http://theballerlife.com/category/celebrity-videos/">Celebrity Videos</a></li>
	<li id="menu-item-59457" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59457"><a href="http://theballerlife.com/category/motivational-videos/">Motivational Videos</a></li>
</ul>
</li>
<li id="menu-item-59461" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-59461"><a href="http://theballerlife.com/category/baller-lifestyle/">Lifestyle<span role="button" class="dropdown-menu-toggle" aria-expanded="false"></span></a>
<ul class="sub-menu">
	<li id="menu-item-59462" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59462"><a href="http://theballerlife.com/category/baller-cars/">Baller Cars</a></li>
	<li id="menu-item-59463" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59463"><a href="http://theballerlife.com/category/baller-cribs/">Baller Cribs</a></li>
	<li id="menu-item-59464" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59464"><a href="http://theballerlife.com/category/marriage-proposals/">marriage proposals</a></li>
</ul>
</li>
<li id="menu-item-59465" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-59465"><a href="http://theballerlife.com/category/wife-girlfriend/">Wives/GF&#8217;s<span role="button" class="dropdown-menu-toggle" aria-expanded="false"></span></a>
<ul class="sub-menu">
	<li id="menu-item-59466" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59466"><a href="http://theballerlife.com/category/wife-girlfriend/movie-actors-wives/">Actors Wives</a></li>
	<li id="menu-item-59467" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59467"><a href="http://theballerlife.com/category/nba-ballers/">NBA Wives</a></li>
	<li id="menu-item-59468" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59468"><a href="http://theballerlife.com/category/nba-girlfriends/">NBA Girlfriends</a></li>
	<li id="menu-item-59469" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59469"><a href="http://theballerlife.com/category/nfl-ballers/">NFL Wives</a></li>
	<li id="menu-item-59470" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59470"><a href="http://theballerlife.com/category/nfl-girlfriends/">NFL Girlfriends</a></li>
	<li id="menu-item-59471" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59471"><a href="http://theballerlife.com/category/mlb-girlfriends/">MLB Girlfriends</a></li>
	<li id="menu-item-59472" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59472"><a href="http://theballerlife.com/category/mlb-ballers/">MLB Wives</a></li>
</ul>
</li>
</ul></div>			</div><!-- .inside-navigation -->
		</nav><!-- #secondary-navigation -->
			
	<div id="page" class="hfeed site grid-container container grid-parent">
		<div id="content" class="site-content">
			<div class="featured-post-single">

		<div class="wposrp-recent-post design-1 wposrp-clearfix">

							
	<div class="wposrpcolumns wposrp-medium-5 responsive-1">
		<a class="recent-link-overlay" href="http://theballerlife.com/2019/05/13/watch-nfl-baller-mike-davis-surprises-his-mother-with-new-home-for-mothers-day-video/"></a>

		<div class="recent-grid">
			<!-- <div class="recent-overlay"> -->
				<div class="recent-image-bg" style="height:150px">

											 <img src="http://theballerlife.com/wp-content/uploads/2019/05/nfl-mike-davis-buys-mother-brand-new-home-.jpg"/> 
					</div><!-- end .recent-image-bg -->				
				<!-- </div> end .recent-overlay -->
				<div class="recent-content">

					<div class="recent-title">
						<h5 style="font-size: 14px">Watch: NFL Baller Mike Davis Surprises His Mother With New Home For Mother&#8217;s Day! (Video)</h5>
					</div>

				</div><!-- end .recent-content -->
			</div> <!-- End .recent-grid -->
	</div> <!-- End .wposrpcolumns -->	
	<div class="wposrpcolumns wposrp-medium-5 responsive-2">
		<a class="recent-link-overlay" href="http://theballerlife.com/2019/05/13/watch-russel-wilson-suprises-his-mother-with-a-brand-new-house-for-mothers-day-video/"></a>

		<div class="recent-grid">
			<!-- <div class="recent-overlay"> -->
				<div class="recent-image-bg" style="height:150px">

											 <img src="http://theballerlife.com/wp-content/uploads/2019/05/russell-wilson-buys-mom-brand-new-house1.jpg"/> 
					</div><!-- end .recent-image-bg -->				
				<!-- </div> end .recent-overlay -->
				<div class="recent-content">

					<div class="recent-title">
						<h5 style="font-size: 14px">Watch: Russel Wilson Suprises His Mother With A Brand New House For Mother&#8217;s Day! (Video)</h5>
					</div>

				</div><!-- end .recent-content -->
			</div> <!-- End .recent-grid -->
	</div> <!-- End .wposrpcolumns -->	
	<div class="wposrpcolumns wposrp-medium-5 responsive-3">
		<a class="recent-link-overlay" href="http://theballerlife.com/2019/04/28/congratulations-idris-elba-marries-longtime-girlfriend-sabrina-dhowre-video/"></a>

		<div class="recent-grid">
			<!-- <div class="recent-overlay"> -->
				<div class="recent-image-bg" style="height:150px">

											 <img src="http://theballerlife.com/wp-content/uploads/2019/04/idris-elba-marries-sabrina-dhowre-.jpg"/> 
					</div><!-- end .recent-image-bg -->				
				<!-- </div> end .recent-overlay -->
				<div class="recent-content">

					<div class="recent-title">
						<h5 style="font-size: 14px">Congratulations: Idris Elba Marries Longtime Girlfriend Sabrina Dhowre (Video)</h5>
					</div>

				</div><!-- end .recent-content -->
			</div> <!-- End .recent-grid -->
	</div> <!-- End .wposrpcolumns -->	
	<div class="wposrpcolumns wposrp-medium-5 responsive-4">
		<a class="recent-link-overlay" href="http://theballerlife.com/2019/04/28/heartfelt-listen-to-d-k-metcalfs-emotional-phone-call-after-being-drafted-by-the-nfls-seattle-seahawks-video/"></a>

		<div class="recent-grid">
			<!-- <div class="recent-overlay"> -->
				<div class="recent-image-bg" style="height:150px">

											 <img src="http://theballerlife.com/wp-content/uploads/2019/04/dj-metcalf-emotional-phone-call-getting-drafted-.jpg"/> 
					</div><!-- end .recent-image-bg -->				
				<!-- </div> end .recent-overlay -->
				<div class="recent-content">

					<div class="recent-title">
						<h5 style="font-size: 14px">Heartfelt: Listen To D.K. Metcalf&#8217;s Emotional Phone Call After Being Drafted By The NFL&#8217;s Seattle Seahawks! (Video)</h5>
					</div>

				</div><!-- end .recent-content -->
			</div> <!-- End .recent-grid -->
	</div> <!-- End .wposrpcolumns -->	
	<div class="wposrpcolumns wposrp-medium-5 responsive-5">
		<a class="recent-link-overlay" href="http://theballerlife.com/2019/04/07/dwyane-wade-and-wife-gabrielle-union-open-up-about-life-after-the-nba-video/"></a>

		<div class="recent-grid">
			<!-- <div class="recent-overlay"> -->
				<div class="recent-image-bg" style="height:150px">

											 <img src="http://theballerlife.com/wp-content/uploads/2019/04/dwyane-wade-gabriel-union-baby-girl-video-.jpg"/> 
					</div><!-- end .recent-image-bg -->				
				<!-- </div> end .recent-overlay -->
				<div class="recent-content">

					<div class="recent-title">
						<h5 style="font-size: 14px">Dwyane Wade and Wife Gabrielle Union Open Up About Life After The NBA (Video)</h5>
					</div>

				</div><!-- end .recent-content -->
			</div> <!-- End .recent-grid -->
	</div> <!-- End .wposrpcolumns -->
		</div><!-- end .wposrp-recent-post -->

	</div>
<div class="under-featured-post-ad-single">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- 728x90 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:90px"
     data-ad-client="ca-pub-5342939612884568"
     data-ad-slot="7719001020"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

		<div id="primary" class="content-area grid-parent mobile-grid-100 grid-70 tablet-grid-70">
		<main id="main" class="site-main">
				
			
<article id="post-63506" class="post-63506 post type-post status-publish format-standard hentry category-baller-lifestyle" itemtype='http://schema.org/CreativeWork' itemscope='itemscope'>
	<div class="inside-article">
				
		<header class="entry-header">
										<h1 class="entry-title" itemprop="headline">Watch: LeBron James Surprises Students At His &#8220;I PROMISE School&#8221; With $1 Million Dollar Grant For New Gym (Video)</h1>								<div class="entry-meta">
			<span class="posted-on"><a href="http://theballerlife.com/2019/05/12/watch-lebron-james-surprises-students-at-his-i-promise-school-with-1-million-dollar-grant-for-new-gym-video/" title="8:43 am" rel="bookmark"><time class="entry-date published" datetime="2019-05-12T08:43:36-07:00" itemprop="datePublished">Sunday, May 12, 2019</time></a></span> <span class="byline"><span class="author vcard" itemtype="http://schema.org/Person" itemscope="itemscope" itemprop="author">by <a class="url fn n" href="http://theballerlife.com/author/admin/" title="View all posts by TBL Staff" rel="author" itemprop="url"><span class="author-name" itemprop="name">TBL Staff</span></a></span></span>		</div><!-- .entry-meta -->
			</header><!-- .entry-header -->
		
		
<div class="social-media-shre-buttons-top">
<aside class="mashsb-container mashsb-main mashsb-stretched"><div class="mashsb-box"><div class="mashsb-buttons"><a  class="mashicon-facebook mash-large mash-center mashsb-noshadow" href="https://www.facebook.com/sharer.php?u=http%3A%2F%2Ftheballerlife.com%2F2019%2F05%2F12%2Fwatch-lebron-james-surprises-students-at-his-i-promise-school-with-1-million-dollar-grant-for-new-gym-video%2F" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Share&nbsp;On&nbsp;Facebook</span></a><a  class="mashicon-twitter mash-large mash-center mashsb-noshadow" href="https://twitter.com/intent/tweet?text=Watch%3A%20LeBron%20James%20Surprises%20Students%20At%20His%20%22I%20PROMISE%20School%22%20With%20%241%20Million%20Dollar%20Grant%20For%20New%20Gym%20%28Video%29&url=http://theballerlife.com/2019/05/12/watch-lebron-james-surprises-students-at-his-i-promise-school-with-1-million-dollar-grant-for-new-gym-video/&via=ballerwives" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Tweet&nbsp;This......</span></a><div class="onoffswitch2 mash-large mashsb-noshadow" style="display:none;"></div></div></div>
                    <div style="clear:both;"></div></aside>
            <!-- Share buttons made by mashshare.net - Version: 3.6.3--></div>		

<div class="entry-content" itemprop="text">

			<p><img src="https://i2.wp.com/theballerlife.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://i1.wp.com/theballerlife.com/wp-content/uploads/2019/05/lebron-james-1-million-dollar-gym.jpg?resize=600%2C336" alt width="600" height="336" class="alignnone size-full wp-image-63510" srcset="https://i1.wp.com/theballerlife.com/wp-content/uploads/2019/05/lebron-james-1-million-dollar-gym.jpg?w=600 600w, https://i1.wp.com/theballerlife.com/wp-content/uploads/2019/05/lebron-james-1-million-dollar-gym.jpg?resize=300%2C168 300w, https://i1.wp.com/theballerlife.com/wp-content/uploads/2019/05/lebron-james-1-million-dollar-gym.jpg?resize=400%2C224 400w, https://i1.wp.com/theballerlife.com/wp-content/uploads/2019/05/lebron-james-1-million-dollar-gym.jpg?resize=240%2C134 240w" sizes="(max-width: 600px) 100vw, 600px" data-recalc-dims="1"><noscript><img src="https://i1.wp.com/theballerlife.com/wp-content/uploads/2019/05/lebron-james-1-million-dollar-gym.jpg?resize=600%2C336" alt="" width="600" height="336" class="alignnone size-full wp-image-63510" srcset="https://i1.wp.com/theballerlife.com/wp-content/uploads/2019/05/lebron-james-1-million-dollar-gym.jpg?w=600 600w, https://i1.wp.com/theballerlife.com/wp-content/uploads/2019/05/lebron-james-1-million-dollar-gym.jpg?resize=300%2C168 300w, https://i1.wp.com/theballerlife.com/wp-content/uploads/2019/05/lebron-james-1-million-dollar-gym.jpg?resize=400%2C224 400w, https://i1.wp.com/theballerlife.com/wp-content/uploads/2019/05/lebron-james-1-million-dollar-gym.jpg?resize=240%2C134 240w" sizes="(max-width: 600px) 100vw, 600px" data-recalc-dims="1" /></noscript><br />
<span id="more-63506"></span><br />
<strong>TheBallerLife.com</strong> has learned that NBA star LeBron James surprised students at his new &#8220;I PROMISE&#8217; school in Akron, Ohio with a $1 million dollar grant from the Dick’s Sporting Goods Foundation to build a brand new gym.</p><div id="single-between-post-ad"><div class="ad-after-first"><script type="text/javascript">var vclk_options = {sid:58120,media_id:1,media_type:5,version:"1.4"};</script><script class="vclk_pub_code" type="text/javascript" src="http://cdn.fastclick.net/js/adcodes/pubcode.min.js?sid=58120&media_id=1&media_type=5&version=1.4&exc=1"></script><noscript><a href="http://media.fastclick.net/w/click.here?sid=58120&m=1&c=1" target="_blank"><img src="http://theballerlife.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="http://media.fastclick.net/w/get.media?sid=58120&#038;m=1&#038;tp=5&#038;d=s&#038;c=1&#038;vcm_acv=1.4" width="728" height="90" border="1"><noscript><img src="http://media.fastclick.net/w/get.media?sid=58120&m=1&tp=5&d=s&c=1&vcm_acv=1.4" width="728" height="90" border="1"></noscript></a></noscript></div>
<div class="text-before-ad">ADVERTISEMENT - CONTINUE READING BELOW</div>
<div class="ad-after-first-mobile"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Mobile 300x250 Unit -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-5342939612884568"
     data-ad-slot="3453847020"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div>
<p>James&#8217; new &#8220;I Promise&#8221; school opened last summer to 240 of Akron&#8217;s most at-risk 3rd and 4th graders, who were performing below grade level. After a year open, 90 percent of those students are now &#8220;meeting or exceeding their individual growth goals in reading and math, outpacing peers across the school district,&#8221; according to a statement from the school.</p><div class="ad-after-second-mobile"></div>
<p><strong>Watch the video below:</strong></p>
<p><center><iframe width="560" height="315" src="https://www.youtube.com/embed/oiuPLMlBvQo" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></center></p>

		
</div><!-- .entry-content -->

<div class="social-media-share-buttons-bottom-small">
<iframe src="https://www.facebook.com/plugins/like.php?href=http://theballerlife.com/2019/05/12/watch-lebron-james-surprises-students-at-his-i-promise-school-with-1-million-dollar-grant-for-new-gym-video/&width=90&layout=button_count&action=like&size=large&show_faces=false&share=false&height=21&appId" width="90" height="27" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true"></iframe>

<a href="#" onclick="window.open('https://www.facebook.com/sharer/sharer.php?u='+encodeURIComponent(location.href),'facebook-share-dialog','width=626,height=436');return false;"><img src="http://theballerlife.com/wp-content/uploads/2017/05/facebook-share-button-large.jpg" style="opacity:0.98;"></a>

<iframe id="tweet-button" allowtransparency="true" frameborder="0" scrolling="no"
            src="http://platform.twitter.com/widgets/tweet_button.html?size=l&via=ballerwives&amp;text=Watch: LeBron James Surprises Students At His &#8220;I PROMISE School&#8221; With $1 Million Dollar Grant For New Gym (Video)"
            style="width:80px; height:28px;"></iframe>
</div>

<div class="social-media-shre-buttons-bottom">
<aside class="mashsb-container mashsb-main mashsb-stretched"><div class="mashsb-box"><div class="mashsb-buttons"><a  class="mashicon-facebook mash-large mash-center mashsb-noshadow" href="https://www.facebook.com/sharer.php?u=http%3A%2F%2Ftheballerlife.com%2F2019%2F05%2F12%2Fwatch-lebron-james-surprises-students-at-his-i-promise-school-with-1-million-dollar-grant-for-new-gym-video%2F" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Share&nbsp;On&nbsp;Facebook</span></a><a  class="mashicon-twitter mash-large mash-center mashsb-noshadow" href="https://twitter.com/intent/tweet?text=Watch%3A%20LeBron%20James%20Surprises%20Students%20At%20His%20%22I%20PROMISE%20School%22%20With%20%241%20Million%20Dollar%20Grant%20For%20New%20Gym%20%28Video%29&url=http://theballerlife.com/2019/05/12/watch-lebron-james-surprises-students-at-his-i-promise-school-with-1-million-dollar-grant-for-new-gym-video/&via=ballerwives" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Tweet&nbsp;This......</span></a><div class="onoffswitch2 mash-large mashsb-noshadow" style="display:none;"></div></div></div>
                    <div style="clear:both;"></div></aside>
            <!-- Share buttons made by mashshare.net - Version: 3.6.3--></div>

<div class="taboola-ad">
<div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'thumbnails-a',
    container: 'taboola-below-article-thumbnails',
    placement: 'Below Article Thumbnails',
    target_type: 'mix'
  });
</script> 
</div>

<div class="matched-content">
<div id="zergnet-widget-51646"></div>

<script language="javascript" type="text/javascript">
    (function() {
        var zergnet = document.createElement('script');
        zergnet.type = 'text/javascript'; zergnet.async = true;
        zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=51646';
        var znscr = document.getElementsByTagName('script')[0];
        znscr.parentNode.insertBefore(zergnet, znscr);
    })();
</script>
</div>

<div class="related-post-thumb">
<div class="crp_related "><h3>SEE ALSO:</h3><ul><li><a href="http://theballerlife.com/2019/04/07/lebron-james-opens-up-about-nipsey-hussles-untimely-death-video/"    ><img src="https://i2.wp.com/theballerlife.com/wp-content/uploads/2019/04/lebron-james-talks-nipsey-hustle-death.jpg?fit=240%2C175" alt="LeBron James Opens Up About Nipsey Hussle&#8217;s Untimely Death! (Video)" title="LeBron James Opens Up About Nipsey Hussle&#8217;s Untimely Death! (Video)" width="240" height="200" class="crp_thumb crp_correctfirst" /><span class="crp_title">LeBron James Opens Up About Nipsey Hussle&#8217;s Untimely Death! (Video)</span></a></li><li><a href="http://theballerlife.com/2019/04/18/jalen-rose-says-russell-wilson-announcing-his-new-record-breaking-140-million-contract-in-bed-with-wife-ciara-was-a-real-boss-move-video/"    ><img src="https://i1.wp.com/theballerlife.com/wp-content/uploads/2019/04/jalen-rose-russell-wilson-140-million-dollar-deal-.jpg?fit=240%2C193" alt="Jalen Rose Says Russell Wilson Announcing His New Record-Breaking $140 Million Contract In Bed With Wife Ciara Was A Real &#8216;Boss Move!&#8217; (Video)" title="Jalen Rose Says Russell Wilson Announcing His New Record-Breaking $140 Million Contract In Bed With Wife Ciara Was A Real &#8216;Boss Move!&#8217; (Video)" width="240" height="200" class="crp_thumb crp_correctfirst" /><span class="crp_title">Jalen Rose Says Russell Wilson Announcing His New Record-Breaking $140 Million Contract In&hellip;</span></a></li><li><a href="http://theballerlife.com/2019/02/11/priceless-nfl-star-darius-leonard-surprises-mom-with-brand-new-car-video/"    ><img src="https://i2.wp.com/theballerlife.com/wp-content/uploads/2019/02/Darius-Leonard-surprises-mom-new-car-video-.jpg?fit=240%2C134" alt="Priceless: NFL Star Darius Leonard Surprises Mom With Brand New Car! (Video)" title="Priceless: NFL Star Darius Leonard Surprises Mom With Brand New Car! (Video)" width="240" height="200" class="crp_thumb crp_correctfirst" /><span class="crp_title">Priceless: NFL Star Darius Leonard Surprises Mom With Brand New Car! (Video)</span></a></li><li><a href="http://theballerlife.com/2019/05/07/shaquille-oneal-speaks-on-meeting-his-biological-father-for-the-first-time-at-age-44-i-dont-judge-him-video/"    ><img src="https://i0.wp.com/theballerlife.com/wp-content/uploads/2019/05/shaq-on-meeting-biological-dad-joe-toney-.jpg?fit=240%2C126" alt="Shaquille O’Neal Speaks On Meeting His Biological Father For The First Time At Age 44: ‘I Don’t Judge Him!’ (Video)" title="Shaquille O’Neal Speaks On Meeting His Biological Father For The First Time At Age 44: ‘I Don’t Judge Him!’ (Video)" width="240" height="200" class="crp_thumb crp_correctfirst" /><span class="crp_title">Shaquille O’Neal Speaks On Meeting His Biological Father For The First Time At Age 44: ‘I&hellip;</span></a></li><li><a href="http://theballerlife.com/2019/03/10/meet-malcolm-jenkins-wife-morrisa-jenkins/"    ><img src="https://i2.wp.com/theballerlife.com/wp-content/uploads/2019/02/malcolm-jenkins-wife-morrisa-jenkins-pics-photos-.jpg?fit=219%2C200" alt="Meet Malcolm Jenkins&#8217; Wife Morrisa Jenkins" title="Meet Malcolm Jenkins&#8217; Wife Morrisa Jenkins" width="240" height="200" class="crp_thumb crp_correctfirst" /><span class="crp_title">Meet Malcolm Jenkins&#8217; Wife Morrisa Jenkins</span></a></li><li><a href="http://theballerlife.com/2019/04/03/look-inside-rapper-birdmans-miami-beach-mega-mansion-video/"    ><img src="https://i2.wp.com/theballerlife.com/wp-content/uploads/2019/04/birdman-miami-mansion-pics-.jpg?fit=240%2C158" alt="Look: Inside Rapper Birdman&#8217;s Miami Beach Mega Mansion (Video)" title="Look: Inside Rapper Birdman&#8217;s Miami Beach Mega Mansion (Video)" width="240" height="200" class="crp_thumb crp_correctfirst" /><span class="crp_title">Look: Inside Rapper Birdman&#8217;s Miami Beach Mega Mansion (Video)</span></a></li></ul><div class="crp_clear"></div></div></div>

		<footer class="entry-meta">
			<span class="cat-links"><span class="screen-reader-text">Categories </span><a href="http://theballerlife.com/category/baller-lifestyle/" rel="category tag">Baller Lifestyle</a></span>				<nav id="nav-below" class="post-navigation">
		<span class="screen-reader-text">Post navigation</span>

		<div class="nav-previous"><span class="prev" title="Previous"><a href="http://theballerlife.com/2019/05/12/common-opens-up-about-relationship-with-his-daughter-being-molested-as-a-child-finding-love-and-much-more-video/" rel="prev">Common Opens Up About Relationship With His Daughter, Being Molested  As A Child, Finding Love And Much More! (Video)</a></span></div><div class="nav-next"><span class="next" title="Next"><a href="http://theballerlife.com/2019/05/12/shaquille-oneal-buys-10-pairs-of-shoes-for-georgia-teen-with-size-18-feet-video/" rel="next">Shaquille O’Neal Buys 10 Pairs Of Shoes For Georgia Teen With Size 18 Feet (Video)</a></span></div>	</nav><!-- #nav-below -->
			</footer><!-- .entry-meta -->
	


<div class="aha-health-post">
<a href="http://ahahealthnews.com/ananda-lewis-do-not-watch-this-if-you-eat-figs-youve-been-warned-video/" target="_blank" rel="noopener"><img class="aligncenter size-full wp-image-60636" src="http://theballerlife.com/wp-content/uploads/2017/11/ananda-lewis-talks-eating-figs-.jpg" alt="" width="650" height="550" /></a>
</div>


<h4 class="first-post-title"><span>Check Out These Related Post</span></h4>

<div class="related-post-thumb1">
<!-- relpost-thumb-wrapper --><div class="relpost-thumb-wrapper"><!-- filter-class --><div class=""><div style="clear: both"></div><div style="clear: both"></div><!-- relpost-block-container --><div class="relpost-block-container"><a class="relpost-block-single" href="http://theballerlife.com/2018/02/06/lebron-james-talks-building-wealth-signing-90-million-dollar-nike-contract-at-18-investing-in-blaze-pizza-and-more-video/"><div style="width: 150px; height: 245px;"><div class="relpost-block-single-image" alt="LeBron James Talks Building Wealth, Signing $90 Million Dollar Nike Contract At 18, Investing In Bla..."  style=" background: transparent url(http://theballerlife.com/wp-content/uploads/2018/02/lebron-james-talks-business-building-weath--150x150.jpg) no-repeat scroll 0% 0%; width: 150px; height: 150px; "></div><div class="relpost-block-single-text"  style="font-family: Arial;  font-size: 13px;  color: #fff;">LeBron James Talks Building Wealth, Signing $90 Million Dollar Nike Contract At 18, Investing In Bla...</div></div></a><a class="relpost-block-single" href="http://theballerlife.com/2018/02/09/lebron-james-on-daughter-zuri-cant-have-nothing-with-her-around-video/"><div style="width: 150px; height: 245px;"><div class="relpost-block-single-image" alt="LeBron James On Daughter Zuri: Can't Have Nothing With Her Around! (Video)"  style=" background: transparent url(http://theballerlife.com/wp-content/uploads/2018/02/lebron-james-with-daughter-zuri-video--150x150.jpg) no-repeat scroll 0% 0%; width: 150px; height: 150px; "></div><div class="relpost-block-single-text"  style="font-family: Arial;  font-size: 13px;  color: #fff;">LeBron James On Daughter Zuri: "Can't Have Nothing With Her Around!" (Video)</div></div></a><a class="relpost-block-single" href="http://theballerlife.com/2018/02/14/nfl-star-leveon-bell-shoots-his-shot-at-singer-sza-says-she-can-have-whatever-she-wants-for-valentines-day-video/"><div style="width: 150px; height: 245px;"><div class="relpost-block-single-image" alt="NFL Star Le’Veon Bell Shoots His Shot At Singer SZA; Says She Can Have Whatever She Wants For Valent..."  style=" background: transparent url(http://theballerlife.com/wp-content/uploads/2018/02/leveon-bell-valentines-crush-singer-sza--150x150.jpg) no-repeat scroll 0% 0%; width: 150px; height: 150px; "></div><div class="relpost-block-single-text"  style="font-family: Arial;  font-size: 13px;  color: #fff;">NFL Star Le’Veon Bell Shoots His Shot At Singer SZA; Says She Can Have Whatever She Wants For Valent...</div></div></a><a class="relpost-block-single" href="http://theballerlife.com/2018/04/14/andre-ingrams-wife-marilee-says-she-lost-it-when-she-found-out-he-signed-with-the-nbas-los-angeles-lakers-after-spending-11-long-years-in-the-d-league-video/"><div style="width: 150px; height: 245px;"><div class="relpost-block-single-image" alt="Andre Ingram's Wife Marilee Says She 'Lost It' When She Found Out He Signed With The NBA's Los Angel..."  style=" background: transparent url(http://theballerlife.com/wp-content/uploads/2018/04/andre-ingram-wife-marille-ingram-photos-pics-150x150.jpg) no-repeat scroll 0% 0%; width: 150px; height: 150px; "></div><div class="relpost-block-single-text"  style="font-family: Arial;  font-size: 13px;  color: #fff;">Andre Ingram's Wife Marilee Says She 'Lost It' When She Found Out He Signed With The NBA's Los Angel...</div></div></a><a class="relpost-block-single" href="http://theballerlife.com/2018/04/24/nfl-star-david-irvings-girlfriend-angela-sanchez-hacks-his-twitter-account-and-accuses-him-of-domestic-violence-but-now-admits-she-lied-about-it-video/"><div style="width: 150px; height: 245px;"><div class="relpost-block-single-image" alt="NFL Star David Irving’s Girlfriend Angela Sanchez Hacks His Twitter Account And Accuses Him of Domes..."  style=" background: transparent url(http://theballerlife.com/wp-content/uploads/2018/04/David-Irving-girlfriend-Angela-Sanchez-pics-photos-150x150.jpg) no-repeat scroll 0% 0%; width: 150px; height: 150px; "></div><div class="relpost-block-single-text"  style="font-family: Arial;  font-size: 13px;  color: #fff;">NFL Star David Irving’s Girlfriend Angela Sanchez Hacks His Twitter Account And Accuses Him of Domes...</div></div></a><a class="relpost-block-single" href="http://theballerlife.com/2018/04/25/derek-fisher-proposes-to-girlfriend-gloria-govan-and-she-said-yes-video/"><div style="width: 150px; height: 245px;"><div class="relpost-block-single-image" alt="Derek Fisher Proposes To Girlfriend Gloria Govan And She Said 'Yes!' (Video)"  style=" background: transparent url(http://theballerlife.com/wp-content/uploads/2018/04/derek-fisher-proposes-to-gloria-govan--150x150.jpg) no-repeat scroll 0% 0%; width: 150px; height: 150px; "></div><div class="relpost-block-single-text"  style="font-family: Arial;  font-size: 13px;  color: #fff;">Derek Fisher Proposes To Girlfriend Gloria Govan And She Said 'Yes!' (Video)</div></div></a><a class="relpost-block-single" href="http://theballerlife.com/2018/08/04/rapper-ludacris-brings-a-widow-who-was-down-to-her-last-dollars-to-tears-after-he-paid-for-all-of-her-groceries-at-whole-foods-market-video/"><div style="width: 150px; height: 245px;"><div class="relpost-block-single-image" alt="Rapper Ludacris Brings A Widow, Who Was Down To Her Last Dollars, To Tears After He Paid For All of ..."  style=" background: transparent url(http://theballerlife.com/wp-content/uploads/2018/08/chris-ludacris-bridges-pays-for-widows-groceries-whole-foods-Optimized-150x150.jpg) no-repeat scroll 0% 0%; width: 150px; height: 150px; "></div><div class="relpost-block-single-text"  style="font-family: Arial;  font-size: 13px;  color: #fff;">Rapper Ludacris Brings A Widow, Who Was Down To Her Last Dollars, To Tears After He Paid For All of ...</div></div></a><a class="relpost-block-single" href="http://theballerlife.com/2019/02/11/priceless-nfl-star-darius-leonard-surprises-mom-with-brand-new-car-video/"><div style="width: 150px; height: 245px;"><div class="relpost-block-single-image" alt="Priceless: NFL Star Darius Leonard Surprises Mom With Brand New Car! (Video)"  style=" background: transparent url(http://theballerlife.com/wp-content/uploads/2019/02/Darius-Leonard-surprises-mom-new-car-video--150x150.jpg) no-repeat scroll 0% 0%; width: 150px; height: 150px; "></div><div class="relpost-block-single-text"  style="font-family: Arial;  font-size: 13px;  color: #fff;">Priceless: NFL Star Darius Leonard Surprises Mom With Brand New Car! (Video)</div></div></a></div><!-- close relpost-block-container --><div style="clear: both"></div></div><!-- close filter class --></div><!-- close relpost-thumb-wrapper --></div>

<h4 class="first-post-title"><span>Check Out These Stories</span></h4>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-5342939612884568"
     data-ad-slot="4938485821"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>

<div id="spaceundernav">
<div class="facebook">
<iframe src="https://www.facebook.com/plugins/page.php?href=https%3A%2F%2Fwww.facebook.com%2Fballerwives%2F&tabs&width=330&height=250&small_header=false&adapt_container_width=true&hide_cover=false&show_facepile=true&appId" width="330" height="250" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true"></iframe>
</div>
<div class="banner300">
<a href="http://theballerlife.com/2018/01/14/trae-waynes-fiancee-kyra-luther/" target="_blank" rel="noopener"><img class="alignnone size-full wp-image-61549" src="http://theballerlife.com/wp-content/uploads/2018/01/trae-wayne-fiance.jpg" alt="" width="300" height="250" /></a>
</div>
</div>

</div><!-- .inside-article -->
</article><!-- #post-## -->
<input type="hidden" name="IL_IN_TAG" value="2"/>
<h4 class="first-post-title"><span>Leave A Comment</span></h4>			
								<div class="comments-area">
						
	<div id="comments">

	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2019/05/12/watch-lebron-james-surprises-students-at-his-i-promise-school-with-1-million-dollar-grant-for-new-gym-video/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://theballerlife.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-form-comment"><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><input placeholder="Name *" id="author" name="author" type="text" value="" size="30" />
<input placeholder="Email *" id="email" name="email" type="text" value="" size="30" />
<input placeholder="Website" id="url" name="url" type="text" value="" size="30" />
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='63506' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="50e43a9395" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="215"/></p>			</form>
			</div><!-- #respond -->
	
</div><!-- #comments -->
					</div>
			
		
				</main><!-- #main -->

	</div><!-- #primary -->

<div id="right-sidebar" itemtype="http://schema.org/WPSideBar" itemscope="itemscope" role="complementary" class="widget-area grid-30 tablet-grid-30 grid-parent sidebar">
	<div class="inside-right-sidebar">
				<aside id="text-640378491" class="widget inner-padding widget_text">			<div class="textwidget"><!-- Conversant Media 300x250 Medium Rectangle CODE for BallerWives.com -->
<script type="text/javascript">var vclk_options = {sid:58120,media_id:6,media_type:8,version:"1.4"};</script><script class="vclk_pub_code" type="text/javascript" src="http://cdn.fastclick.net/js/adcodes/pubcode.min.js?sid=58120&media_id=6&media_type=8&version=1.4&exc=1"></script><noscript><a href="http://media.fastclick.net/w/click.here?sid=58120&m=6&c=1" target="_blank"><img src="http://media.fastclick.net/w/get.media?sid=58120&m=6&tp=8&d=s&c=1&vcm_acv=1.4" width="300" height="250" border="1"/></a></noscript>
<!-- Conversant Media 300x250 Medium Rectangle CODE for BallerWives.com --></div>
		</aside><aside id="text-640378483" class="widget inner-padding widget_text">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- 336x280 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:336px;height:280px"
     data-ad-client="ca-pub-5342939612884568"
     data-ad-slot="3391707423"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</aside><aside id="text-640378496" class="widget inner-padding widget_text">			<div class="textwidget"><p><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<!-- 300x600 --><br />
<ins class="adsbygoogle" style="display: inline-block; width: 300px; height: 600px;" data-ad-client="ca-pub-5342939612884568" data-ad-slot="3112505826"></ins><br />
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></p>
</div>
		</aside><aside id="text-640378497" class="widget inner-padding widget_text">			<div class="textwidget"><div id="zergnet-widget-66817"></div>
<p><script language="javascript" type="text/javascript">
    (function() {
        var zergnet = document.createElement('script');
        zergnet.type = 'text/javascript'; zergnet.async = true;
        zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=66817';
        var znscr = document.getElementsByTagName('script')[0];
        znscr.parentNode.insertBefore(zergnet, znscr);
    })();
</script></p>
</div>
		</aside><aside id="text-640378494" class="widget inner-padding widget_text"><div class="widget-title"><span>You May Also Like:</span></div>			<div class="textwidget"><div id="taboola-right-rail-thumbnails"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'right-rail-bulk1',
    container: 'taboola-right-rail-thumbnails',
    placement: 'Right Rail Thumbnails',
    target_type: 'mix'
  });
</script></div>
		</aside><aside id="text-640378495" class="widget inner-padding widget_text">			<div class="textwidget"><div id="zergnet-widget-51647"></div>

<script language="javascript" type="text/javascript">
    (function() {
        var zergnet = document.createElement('script');
        zergnet.type = 'text/javascript'; zergnet.async = true;
        zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=51647';
        var znscr = document.getElementsByTagName('script')[0];
        znscr.parentNode.insertBefore(zergnet, znscr);
    })();
</script></div>
		</aside><aside id="wpfp_recentpostlist_widget-5" class="widget inner-padding wpfp-featured-fplw"><div class="widget-title"><span>Latest Celeb News</span></div>
        <div class="wpfp-featured-post-widget-wrp wpfp-clearfix ">
            <div class="wpfp-widget wpfp-recent-post-widget" id="wpfp-recent-post-widget-1">

                
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2019/05/12/common-opens-up-about-relationship-with-his-daughter-being-molested-as-a-child-finding-love-and-much-more-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2019/05/common-rapper-daughter-pics.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2019/05/12/common-opens-up-about-relationship-with-his-daughter-being-molested-as-a-child-finding-love-and-much-more-video/" title="Common Opens Up About Relationship With His Daughter, Being Molested  As A Child, Finding Love And Much More! (Video)" style="font-size: 14px">Common Opens Up About Relationship With His Daughter, Being Molested  As A Child, Finding Love And Much More! (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2019/05/05/taye-diggs-recounts-a-joke-angela-bassett-played-on-him-prior-to-their-kissing-scene-in-how-stella-got-her-groove-back-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2019/05/taye-diggs-angela-bassett.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2019/05/05/taye-diggs-recounts-a-joke-angela-bassett-played-on-him-prior-to-their-kissing-scene-in-how-stella-got-her-groove-back-video/" title="Taye Diggs Recounts A Joke Angela Bassett Played On Him Prior To Their Kissing Scene In &#8220;How Stella Got Her Groove Back.&#8221; (Video)" style="font-size: 14px">Taye Diggs Recounts A Joke Angela Bassett Played On Him Prior To Their Kissing Scene In &#8220;How Stella Got Her Groove Back.&#8221; (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                            </div><!-- end .wpfp-recent-post -->

    </div><!-- end .wpfp-featured-post-widget-wrp -->

    </aside><aside id="wpfp_recentpostlist_widget-2" class="widget inner-padding wpfp-featured-fplw"><div class="widget-title"><span>NFL Wives &#038; Girlfriends</span></div>
        <div class="wpfp-featured-post-widget-wrp wpfp-clearfix ">
            <div class="wpfp-widget wpfp-recent-post-widget" id="wpfp-recent-post-widget-2">

                
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2019/03/10/meet-malcolm-jenkins-wife-morrisa-jenkins/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2019/02/malcolm-jenkins-wife-morrisa-jenkins-pics-photos-.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2019/03/10/meet-malcolm-jenkins-wife-morrisa-jenkins/" title="Meet Malcolm Jenkins&#8217; Wife Morrisa Jenkins" style="font-size: 14px">Meet Malcolm Jenkins&#8217; Wife Morrisa Jenkins</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2019/02/25/meet-brandon-williams-wife-alyssa-williams/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2019/02/brandon-williams-wife-alyssa-williams-pics-photos.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2019/02/25/meet-brandon-williams-wife-alyssa-williams/" title="Meet Brandon William&#8217;s Wife Alyssa Williams" style="font-size: 14px">Meet Brandon William&#8217;s Wife Alyssa Williams</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2019/02/24/meet-charles-leno-jr-s-fiancee-jennifer-roth/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2019/02/charles-leno-fiancee-wife-jennifer-roth-pics-photos-.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2019/02/24/meet-charles-leno-jr-s-fiancee-jennifer-roth/" title="Meet Charles Leno Jr.&#8217;s Fiancee Jennifer Roth" style="font-size: 14px">Meet Charles Leno Jr.&#8217;s Fiancee Jennifer Roth</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                            </div><!-- end .wpfp-recent-post -->

    </div><!-- end .wpfp-featured-post-widget-wrp -->

    </aside><aside id="wpfp_recentpostlist_widget-3" class="widget inner-padding wpfp-featured-fplw"><div class="widget-title"><span>NBA Wives &#038; Girlfriends</span></div>
        <div class="wpfp-featured-post-widget-wrp wpfp-clearfix ">
            <div class="wpfp-widget wpfp-recent-post-widget" id="wpfp-recent-post-widget-3">

                
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2019/03/09/meet-david-fizdales-wife-natasha-sen-fizdale/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2019/03/david-fizdale-wife-natasha-sen-fizdale-pics-photos.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2019/03/09/meet-david-fizdales-wife-natasha-sen-fizdale/" title="Meet David Fizdale’s Wife Natasha Sen Fizdale" style="font-size: 14px">Meet David Fizdale’s Wife Natasha Sen Fizdale</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2019/02/14/former-nba-star-kevin-garnett-files-court-docs-to-avoid-paying-his-wife-brandi-spousal-support-after-she-files-for-divorce-details/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2019/02/kevin-garnett-wife-brandi-padilla-drama.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2019/02/14/former-nba-star-kevin-garnett-files-court-docs-to-avoid-paying-his-wife-brandi-spousal-support-after-she-files-for-divorce-details/" title="Former NBA Star Kevin Garnett Files Court Docs To Avoid Paying His Wife Brandi Spousal Support After She Files For Divorce! (Details)" style="font-size: 14px">Former NBA Star Kevin Garnett Files Court Docs To Avoid Paying His Wife Brandi Spousal Support After She Files For Divorce! (Details)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2019/02/14/congratulations-dennis-schroder-and-fiancee-ellen-ziolo-announce-the-birth-of-their-new-baby-boy-photos/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2019/02/Dennis-Schröder-girlfriend-Ellen-ziola-pics-photos1-.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2019/02/14/congratulations-dennis-schroder-and-fiancee-ellen-ziolo-announce-the-birth-of-their-new-baby-boy-photos/" title="Congratulations: Dennis Schroder And Fiancee Ellen Ziolo Announce The Birth Of Their New Baby Boy! (Photos)" style="font-size: 14px">Congratulations: Dennis Schroder And Fiancee Ellen Ziolo Announce The Birth Of Their New Baby Boy! (Photos)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                            </div><!-- end .wpfp-recent-post -->

    </div><!-- end .wpfp-featured-post-widget-wrp -->

    </aside><aside id="wpfp_recentpostlist_widget-4" class="widget inner-padding wpfp-featured-fplw"><div class="widget-title"><span>Actor Wives &#038; Girlfriends</span></div>
        <div class="wpfp-featured-post-widget-wrp wpfp-clearfix ">
            <div class="wpfp-widget wpfp-recent-post-widget" id="wpfp-recent-post-widget-4">

                
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2018/06/24/congratulations-actor-mike-colter-and-wife-iva-announce-they-are-expecting-second-child-together-photos-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2018/06/mike-colter-wife-iva-colter-pics-Optimized.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2018/06/24/congratulations-actor-mike-colter-and-wife-iva-announce-they-are-expecting-second-child-together-photos-video/" title="Congratulations: Actor Mike Colter And Wife Iva Announce They Are Expecting Second Child Together! (Photos &#8211; Video)" style="font-size: 14px">Congratulations: Actor Mike Colter And Wife Iva Announce They Are Expecting Second Child Together! (Photos &#8211; Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2018/05/09/michael-b-jordan-dodges-relationship-questions-about-rumored-girlfriend-ashlyn-castro-talks-life-after-black-panther-movie-and-more-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2018/05/michael-b-jordan-interview-breakfast-club.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2018/05/09/michael-b-jordan-dodges-relationship-questions-about-rumored-girlfriend-ashlyn-castro-talks-life-after-black-panther-movie-and-more-video/" title="Michael B. Jordan Dodges Relationship Questions About Rumored Girlfriend Ashlyn Castro, Talks Life After Black Panther Movie And More (Video)" style="font-size: 14px">Michael B. Jordan Dodges Relationship Questions About Rumored Girlfriend Ashlyn Castro, Talks Life After Black Panther Movie And More (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2018/02/19/winston-duke-5-quick-facts-you-probably-did-not-know-about-the-black-panther-star-video-pics/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2018/02/winston-duke-wiki-bio-pics-photos.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2018/02/19/winston-duke-5-quick-facts-you-probably-did-not-know-about-the-black-panther-star-video-pics/" title="Winston Duke: 5 Quick Facts You Probably Did Not Know About The &#8216;Black Panther&#8217; Star (Video-Pics)" style="font-size: 14px">Winston Duke: 5 Quick Facts You Probably Did Not Know About The &#8216;Black Panther&#8217; Star (Video-Pics)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                            </div><!-- end .wpfp-recent-post -->

    </div><!-- end .wpfp-featured-post-widget-wrp -->

    </aside><aside id="wpfp_recentpostlist_widget-8" class="widget inner-padding wpfp-featured-fplw"><div class="widget-title"><span>Heartfelt Stories</span></div>
        <div class="wpfp-featured-post-widget-wrp wpfp-clearfix ">
            <div class="wpfp-widget wpfp-recent-post-widget" id="wpfp-recent-post-widget-5">

                
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2019/05/12/shaquille-oneal-buys-10-pairs-of-shoes-for-georgia-teen-with-size-18-feet-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2019/05/shaq-surprises-teen-with-shoes.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2019/05/12/shaquille-oneal-buys-10-pairs-of-shoes-for-georgia-teen-with-size-18-feet-video/" title="Shaquille O’Neal Buys 10 Pairs Of Shoes For Georgia Teen With Size 18 Feet (Video)" style="font-size: 14px">Shaquille O’Neal Buys 10 Pairs Of Shoes For Georgia Teen With Size 18 Feet (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2019/05/12/wow-friends-of-12-years-learn-theyre-half-brothers-after-23andme-genetic-test-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2019/05/twofriends-learn-they-brothers-genetic-testing-.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2019/05/12/wow-friends-of-12-years-learn-theyre-half-brothers-after-23andme-genetic-test-video/" title="Wow: Friends Of 12 Years Learn They’re Half Brothers After 23andMe Genetic Test (Video)" style="font-size: 14px">Wow: Friends Of 12 Years Learn They’re Half Brothers After 23andMe Genetic Test (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                            </div><!-- end .wpfp-recent-post -->

    </div><!-- end .wpfp-featured-post-widget-wrp -->

    </aside>			</div><!-- .inside-right-sidebar -->
</div><!-- #secondary -->
	</div><!-- #content -->
</div><!-- #page -->



<div class="site-footer grid-container grid-parent  ">
		<footer class="site-info" itemtype="http://schema.org/WPFooter" itemscope="itemscope">
		<div class="inside-site-info grid-container grid-parent">
			<a href='http://theballerlife.com/contact-us'>Contact Us</a> | <a href='http://theballerlife.com/terms-of-use'>Terms of Use</a> | <a href='http://theballerlife.com/sitemap.xml'>Site Map</a> | <a href='http://theballerlife.com/privacy'>Privacy Statement</a><br />Copyright © 2016 TheBallerLife.com All Rights Reserved.
		</div>
	</footer><!-- .site-info -->
	</div><!-- .site-footer -->

	<nav itemtype="http://schema.org/SiteNavigationElement" itemscope="itemscope" id="generate-slideout-menu" class="main-navigation slideout-navigation">
		<div class="inside-navigation grid-container grid-parent">
			<div class="main-nav"><ul id="menu-second-nav-menu-1" class=" slideout-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-59453"><a href="http://theballerlife.com">HOME</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-59458"><a href="http://theballerlife.com/category/celebrity-news/">News<span role="button" class="dropdown-menu-toggle" aria-expanded="false"></span></a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59459"><a href="http://theballerlife.com/category/celebrity-news/">Celebrity News</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59460"><a href="http://theballerlife.com/category/sports-news/">Sports News</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59454"><a href="http://theballerlife.com/category/celebrity-videos/">Videos</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59455"><a href="http://theballerlife.com/category/heartfelt-post/">Heartfelt Post</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59456"><a href="http://theballerlife.com/category/celebrity-videos/">Celebrity Videos</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59457"><a href="http://theballerlife.com/category/motivational-videos/">Motivational Videos</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-59461"><a href="http://theballerlife.com/category/baller-lifestyle/">Lifestyle<span role="button" class="dropdown-menu-toggle" aria-expanded="false"></span></a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59462"><a href="http://theballerlife.com/category/baller-cars/">Baller Cars</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59463"><a href="http://theballerlife.com/category/baller-cribs/">Baller Cribs</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59464"><a href="http://theballerlife.com/category/marriage-proposals/">marriage proposals</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-59465"><a href="http://theballerlife.com/category/wife-girlfriend/">Wives/GF&#8217;s<span role="button" class="dropdown-menu-toggle" aria-expanded="false"></span></a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59466"><a href="http://theballerlife.com/category/wife-girlfriend/movie-actors-wives/">Actors Wives</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59467"><a href="http://theballerlife.com/category/nba-ballers/">NBA Wives</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59468"><a href="http://theballerlife.com/category/nba-girlfriends/">NBA Girlfriends</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59469"><a href="http://theballerlife.com/category/nfl-ballers/">NFL Wives</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59470"><a href="http://theballerlife.com/category/nfl-girlfriends/">NFL Girlfriends</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59471"><a href="http://theballerlife.com/category/mlb-girlfriends/">MLB Girlfriends</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59472"><a href="http://theballerlife.com/category/mlb-ballers/">MLB Wives</a></li>
</ul>
</li>
</ul></div>					</div><!-- .inside-navigation -->
	</nav><!-- #site-navigation -->
	<div class="slideout-overlay" style="display: none;"></div>
	<a title="Scroll back to top" rel="nofollow" href="#" class="generate-back-to-top" style="opacity:0;visibility:hidden;" data-scroll-speed="400" data-start-scroll="300">
			<i class="fa fa-angle-up" aria-hidden="true"></i>
			<span class="screen-reader-text">Scroll back to top</span>
		</a><!-- Scroll Triggered Boxes v2.2.1 - https://wordpress.org/plugins/scroll-triggered-boxes/-->			<div class="stb-container stb-center-container">
				<div class="scroll-triggered-box stb stb-56807 stb-center"
				     id="stb-56807"
				     style="display: none;">
					<div class="stb-content">
						<h4 id="fb-message"><strong>LIKE OUR SITE??</strong></h4>
<h4 style="text-align: center;"><span style="color: #000000;"><strong>Well, show us some love and support by clicking the Facebook <span style="color: #3366ff;">&#8220;Like&#8221; </span>Button Below!</strong></span></h4>
<p><iframe style="border: none; overflow: hidden;" src="https://www.facebook.com/plugins/like.php?href=https%3A%2F%2Fwww.facebook.com%2Fballerwives%2F&amp;width=320&amp;layout=standard&amp;action=like&amp;size=large&amp;show_faces=false&amp;share=false&amp;height=35&amp;appId" width="320" height="35" frameborder="0" scrolling="no"></iframe><br />
<a href="http://theballerlife.com/category/nba-ballers/" target="_blank" rel="noopener noreferrer"><img class="alignnone size-full wp-image-61688" src="http://theballerlife.com/wp-content/uploads/2018/02/fb-ballerwives.jpg" alt="" width="320" height="158" /></a></p>
					</div>
											<span class="stb-close">&times;</span>
									</div>
			</div>
			<div id="stb-overlay"></div><!-- / Scroll Triggered Box --><script type='text/javascript' src='http://theballerlife.com/wp-content/plugins/gp-premium/menu-plus/functions/js/sticky.min.js?ver=1.5.2'></script>
<script type='text/javascript' src='http://theballerlife.com/wp-content/plugins/gp-premium/menu-plus/functions/js/sliiide.min.js?ver=1.5.2'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.3/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201920'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mashsb = {"shares":"0","round_shares":"1","animate_shares":"0","dynamic_buttons":"0","share_url":"http:\/\/theballerlife.com\/2019\/05\/12\/watch-lebron-james-surprises-students-at-his-i-promise-school-with-1-million-dollar-grant-for-new-gym-video\/","title":"Watch%3A+LeBron+James+Surprises+Students+At+His+%E2%80%9CI+PROMISE+School%E2%80%9D+With+%241+Million+Dollar+Grant+For+New+Gym+%28Video%29","image":null,"desc":"TheBallerLife.com has learned that NBA star LeBron James surprised students at his new \"I PROMISE' school in Akron, Ohio with a $1 million dollar grant from the Dick\u2019s Sporting Goods Foundation to build a brand \u2026","hashtag":"@ballerwives","subscribe":"link","subscribe_url":"http:\/\/feedburner.google.com\/fb\/a\/mailverify?uri=BallerWives","activestatus":"1","singular":"1","twitter_popup":"1","refresh":"0","nonce":"186e7a4419","postid":"63506","servertime":"1558032303","ajaxurl":"http:\/\/theballerlife.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://theballerlife.com/wp-content/plugins/mashsharer/assets/js/mashsb.min.js?ver=3.6.3'></script>
<script type='text/javascript' src='http://theballerlife.com/wp-content/themes/generatepress/js/navigation.min.js?ver=1.4'></script>
<script type='text/javascript'>
jQuery( document ).ready( function($) {
				$( '.secondary-navigation .menu-toggle' ).on( 'click', function( e ) {
					e.preventDefault();
					$( this ).closest( '.secondary-navigation' ).toggleClass( 'toggled' );
					$( this ).closest( '.secondary-navigation' ).attr( 'aria-expanded', $( this ).closest( '.secondary-navigation' ).attr( 'aria-expanded' ) === 'true' ? 'false' : 'true' );
					$( this ).toggleClass( 'toggled' );
					$( this ).children( 'i' ).toggleClass( 'fa-bars' ).toggleClass( 'fa-close' );
					$( this ).attr( 'aria-expanded', $( this ).attr( 'aria-expanded' ) === 'false' ? 'true' : 'false' );
				});
			});
</script>
<script type='text/javascript' src='http://theballerlife.com/wp-content/themes/generatepress/js/dropdown-click.min.js?ver=1.4'></script>
<script type='text/javascript' src='http://theballerlife.com/wp-content/themes/generatepress/js/navigation-search.min.js?ver=1.4'></script>
<script type='text/javascript' src='http://theballerlife.com/wp-content/themes/generatepress/js/back-to-top.min.js?ver=1.4'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='http://theballerlife.com/wp-content/themes/generatepress/js/html5shiv.min.js?ver=1.4'></script>
<![endif]-->
<script type='text/javascript' src='http://theballerlife.com/wp-content/plugins/lazy-load/js/jquery.sonar.min.js?ver=0.6.1'></script>
<script type='text/javascript' src='http://theballerlife.com/wp-content/plugins/lazy-load/js/lazy-load.js?ver=0.6.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var STB_Global_Options = {"testMode":""};
var STB_Box_Options = {"56807":{"id":56807,"title":"Facebook Like Message","trigger":"percentage","triggerPercentage":65,"triggerElementSelector":"","animation":"fade","cookieTime":1,"autoHide":true,"autoShow":true,"position":"center","minimumScreenWidth":0,"unclosable":false}};
/* ]]> */
</script>
<script type='text/javascript' src='http://theballerlife.com/wp-content/plugins/scroll-triggered-boxes/assets/js/script.min.js?ver=2.2.1'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.1.1/wp-includes/js/wp-embed.min.js'></script>
<script async="async" type='text/javascript' src='http://theballerlife.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.1'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201920.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.3',blog:'121774942',post:'63506',tz:'-7',srv:'theballerlife.com'} ]);
	_stq.push([ 'clickTrackerInit', '121774942', '63506' ]);
</script>

<script src="http://services.picadmedia.com/js/picad.js" type="text/javascript"></script><script type="text/javascript">picadService.set('token','');picadService.initialize(); </script>

<script>!function(){var a,b="e473d7fe",c="https://g2.gumgum.com/javascripts/ggv2.js",d=top,e="script",f=d.document,g=f.getElementsByTagName(e)[0],h=d.XMLHttpRequest||d.XDomainRequest,i=function(a){var b=f.createElement(e);b.src=a,b.async=!0,g.parentNode.insertBefore(b,g)},j=function(){d.clearTimeout(a)};return d.ggv2id=b,h?(h=new h,h.open("GET",c),h.onload=function(){j();try{(d.execScript||function(a){d.eval.call(d,a)})(h.responseText)}catch(a){}},a=d.setTimeout(function(){h.abort()},3e3),void h.send()):i(c)}();</script>


 
<!-- start Vibrant Media IntelliTXT script section -->
<script type="text/javascript" src="http://ballerwives.us.intellitxt.com/intellitxt/front.asp?ipid=30857"></script>
<!-- end Vibrant Media IntelliTXT script section -->

<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({flush: true});
</script>

<script type="text/javascript">
var infolinks_pid = 2407402;
var infolinks_wsid = 1;
</script>
<script type="text/javascript" src="//resources.infolinks.com/js/infolinks_main.js"></script>
<script type="text/javascript">
    (function() {
        var a = document.createElement("script");
        var b = document.getElementsByTagName("script")[0];
        a.async = 1;
        a.src = "//cdn.earnify.com/widget.min.js";
        b.parentNode.insertBefore(a, b);
    })();
</script>
<!-- START MadadsMedia.com Private Marketplace Tag For TheBallerLife.com -->
<!-- Size: 300x250 Slider -->
<script data-cfasync="false" src="//ads-by.madadsmedia.com/tags/204/11633/async/slider/300x250s.js" type="text/javascript"></script>
<!-- MadadsMedia.com Private Marketplace Tag For TheBallerLife.com -->

<!-- START MadadsMedia.com Private Marketplace Tag For TheBallerLife.com -->
<!-- Size: 728x90 Slider -->
<script data-cfasync="false" src="//ads-by.madadsmedia.com/tags/204/11633/async/slider/728x90s.js" type="text/javascript"></script>
<!-- MadadsMedia.com Private Marketplace Tag For TheBallerLife.com -->


<script type="text/javascript">
        // Asynchronous Loading
        var script = document.createElement("script");
        script.src = script.src = document.location.protocol + '//platform.twitter.com/widgets.js';
        script.async = true;
        document.getElementsByTagName("body")[0].appendChild(script);
    </script>

<script>!function(d,s,id) {
	var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';
	if(!d.getElementById(id)) {
		js=d.createElement(s);
		js.id=id;
		js.async=true;
		js.src=p+'://platform.twitter.com/widgets.js';
		fjs.parentNode.insertBefore(js,fjs);
	}
}(document, 'script', 'twitter-wjs');</script>
</body>
</html>
<!-- This Quick Cache file was built for (  theballerlife.com/2019/05/12/watch-lebron-james-surprises-students-at-his-i-promise-school-with-1-million-dollar-grant-for-new-gym-video/ ) in 1.84340 seconds, on May 16th, 2019 at 6:45 pm UTC. -->
<!-- This Quick Cache file will automatically expire ( and be re-built automatically ) on May 16th, 2019 at 7:45 pm UTC -->
<!-- +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ -->
<!-- Quick Cache Is Fully Functional :-) ... A Quick Cache file was just served for (  theballerlife.com/2019/05/12/watch-lebron-james-surprises-students-at-his-i-promise-school-with-1-million-dollar-grant-for-new-gym-video/ ) in 0.00376 seconds, on May 16th, 2019 at 7:41 pm UTC. -->