<!DOCTYPE html>
<html lang="en-US"
	itemscope 
	itemtype="http://schema.org/Article" 
	prefix="og: http://ogp.me/ns#" >
<head>
	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=edge" />
	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="http://theballerlife.com/xmlrpc.php">
	<title>2 Chainz Shows Off His Vacation Home And Plays Basketball On A $450,000 Court! (Video) | | The Baller Life -  BallerWives.com</title>

<!-- All in One SEO Pack 2.4.3.1 by Michael Torbert of Semper Fi Web Design[334,476] -->
<link rel="author" href="https://plus.google.com/117266833494320081327" />
<meta name="keywords"  content="#trending news,celebrity news,celebrity videos" />

<link rel="canonical" href="http://theballerlife.com/2018/01/07/2-chainz-shows-off-his-vacation-home-and-plays-basketball-on-a-450000-court-video/" />
<meta property="og:title" content="2 Chainz Shows Off His Vacation Home And Plays Basketball On A $450,000 Court! (Video) | | The Baller Life -  BallerWives.com" />
<meta property="og:type" content="article" />
<meta property="og:url" content="http://theballerlife.com/2018/01/07/2-chainz-shows-off-his-vacation-home-and-plays-basketball-on-a-450000-court-video/" />
<meta property="og:image" content="http://theballerlife.com/wp-content/uploads/2018/01/2chainz-vacation-home-video.jpg" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="315" />
<meta property="og:site_name" content="TheBallerLife.com - BallerWives.com" />
<meta property="fb:admins" content="148854525161108" />
<meta property="fb:app_id" content="117418662243617" />
<meta property="og:description" content="Rapper 2 Chainz teamed up with GQ and gave his fans an inside peek at his vacation home and played basketball on a $450,000 court. Watch the video below:" />
<meta property="article:tag" content="#trending news" />
<meta property="article:tag" content="celebrity news" />
<meta property="article:tag" content="celebrity videos" />
<meta property="article:publisher" content="https://facebook.com/ballerwives" />
<meta property="article:published_time" content="2018-01-07T21:18:05Z" />
<meta property="article:modified_time" content="2018-01-07T21:18:05Z" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@ballerwives" />
<meta name="twitter:domain" content="theballerlife.com" />
<meta name="twitter:title" content="2 Chainz Shows Off His Vacation Home And Plays Basketball On A $450,000 Court! (Video) | | The Baller Life -  BallerWives.com" />
<meta name="twitter:description" content="Rapper 2 Chainz teamed up with GQ and gave his fans an inside peek at his vacation home and played basketball on a $450,000 court. Watch the video below:" />
<meta name="twitter:image" content="http://theballerlife.com/wp-content/uploads/2018/01/2chainz-vacation-home-video.jpg" />
<meta itemprop="image" content="http://theballerlife.com/wp-content/uploads/2018/01/2chainz-vacation-home-video.jpg" />
			<script type="text/javascript" >
				window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
				ga('create', 'UA-9445838-1', 'auto');
				// Plugins
				
				ga('send', 'pageview');
			</script>
			<script async src="https://www.google-analytics.com/analytics.js"></script>
			<!-- /all in one seo pack -->
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="The Baller Life -  BallerWives.com &raquo; Feed" href="http://theballerlife.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Baller Life -  BallerWives.com &raquo; Comments Feed" href="http://theballerlife.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Baller Life -  BallerWives.com &raquo; 2 Chainz Shows Off His Vacation Home And Plays Basketball On A $450,000 Court! (Video) Comments Feed" href="http://theballerlife.com/2018/01/07/2-chainz-shows-off-his-vacation-home-and-plays-basketball-on-a-450000-court-video/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/theballerlife.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.1"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56794,8205,9794,65039],[55358,56794,8203,9794,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	  <style type="text/css">
	  .wp-pagenavi{float:left !important; }

	  .wp-pagenavi a,.wp-pagenavi a:link,.wp-pagenavi a:visited,.wp-pagenavi a:active,.wp-pagenavi span.extend { background:#000000 !important; border:1px solid #666666 !important; color:#ffffff !important; }
	  .wp-pagenavi a:hover,.wp-pagenavi span.current
	  {
		  background:#000000 !important; border:1px solid ##444 !important; color:#ffffff !important; 
	  }
	  .wp-pagenavi span.pages { color:#000000 !important; }
	  </style>
	  <link rel='stylesheet' id='generate-fonts-css'  href='//fonts.googleapis.com/css?family=Open+Sans:300,300italic,regular,italic,600,600italic,700,700italic,800,800italic' type='text/css' media='all' />
<link rel='stylesheet' id='crp-style-rounded-thumbs-css'  href='http://theballerlife.com/wp-content/plugins/contextual-related-posts/css/default-style.css?ver=4.9.1' type='text/css' media='all' />
<style id='crp-style-rounded-thumbs-inline-css' type='text/css'>

.crp_related a {
  width: 240px;
  height: 200px;
  text-decoration: none;
}
.crp_related img {
  max-width: 240px;
  margin: auto;
}
.crp_related .crp_title {
  width: 240px;
}
                
</style>
<link rel='stylesheet' id='generate-page-header-css'  href='http://theballerlife.com/wp-content/plugins/gp-premium/page-header/functions/css/page-header-min.css?ver=1.5.2' type='text/css' media='all' />
<link rel='stylesheet' id='mashsb-styles-css'  href='http://theballerlife.com/wp-content/plugins/mashsharer/assets/css/mashsb.min.css?ver=3.4.7' type='text/css' media='all' />
<style id='mashsb-styles-inline-css' type='text/css'>
.mashsb-count {color:#cccccc;}@media only screen and (min-width:568px){.mashsb-buttons a {min-width: 160px;}}.mashicon-subscribe {
    background: red;
}

.mashicon-subscribe .icon, .mashicon-subscribe .text {
    color: #fff;
}
</style>
<link rel='stylesheet' id='wpfp-public-style-css'  href='http://theballerlife.com/wp-content/plugins/wpos-featured-post2/assets/css/wpfp-public.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='wposrp-public-style-css'  href='http://theballerlife.com/wp-content/plugins/wpos-recent-post/assets/css/wposrp-public.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='generate-style-grid-css'  href='http://theballerlife.com/wp-content/themes/generatepress/css/unsemantic-grid.min.css?ver=1.4' type='text/css' media='all' />
<link rel='stylesheet' id='generate-style-css'  href='http://theballerlife.com/wp-content/themes/generatepress/style.css?ver=1.4' type='text/css' media='all' />
<style id='generate-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='generate-mobile-style-css'  href='http://theballerlife.com/wp-content/themes/generatepress/css/mobile.min.css?ver=1.4' type='text/css' media='all' />
<link rel='stylesheet' id='generate-child-css'  href='http://theballerlife.com/wp-content/themes/generatepress-child/style.css?ver=1510762366' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='http://theballerlife.com/wp-content/themes/generatepress/css/font-awesome.min.css?ver=4.7' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='generate-ie-css'  href='http://theballerlife.com/wp-content/themes/generatepress/css/ie.min.css?ver=1.4' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='scroll-triggered-boxes-css'  href='http://theballerlife.com/wp-content/plugins/scroll-triggered-boxes/assets/css/styles.min.css?ver=2.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='generate-blog-css'  href='http://theballerlife.com/wp-content/plugins/gp-premium/blog/functions/css/style-min.css?ver=1.5.2' type='text/css' media='all' />
<link rel='stylesheet' id='generate-secondary-nav-css'  href='http://theballerlife.com/wp-content/plugins/gp-premium/secondary-nav/functions/css/style.min.css?ver=1.5.2' type='text/css' media='all' />
<style id='generate-secondary-nav-inline-css' type='text/css'>
.secondary-navigation{background-color:#000000;}.secondary-navigation .main-nav ul li a,.secondary-navigation .menu-toggle{color:#ffffff;font-weight:bold;text-transform:uppercase;font-size:11px;padding-left:5px;padding-right:5px;line-height:35px;}button.secondary-menu-toggle:hover,button.secondary-menu-toggle:focus{color:#ffffff;}.widget-area .secondary-navigation{margin-bottom:10px;}.secondary-navigation ul ul{background-color:#303030;top:auto;}.secondary-navigation .main-nav ul ul li a{color:#ffffff;font-size:10px;padding-left:5px;padding-right:5px;}.secondary-navigation .menu-item-has-children .dropdown-menu-toggle{padding-right:5px;}.secondary-navigation .main-nav ul li > a:hover,.secondary-navigation .main-nav ul li > a:focus,.secondary-navigation .main-nav ul li.sfHover > a{color:#ffffff;background-color:#303030;}.secondary-navigation .main-nav ul ul li > a:hover,.secondary-navigation .main-nav ul ul li > a:focus,.secondary-navigation .main-nav ul ul li.sfHover > a{color:#ffffff;background-color:#474747;}.secondary-navigation .main-nav ul li[class*="current-menu-"] > a, .secondary-navigation .main-nav ul li[class*="current-menu-"] > a:hover,.secondary-navigation .main-nav ul li[class*="current-menu-"].sfHover > a{color:#ffffff;background-color:#000000;}.secondary-navigation .main-nav ul ul li[class*="current-menu-"] > a,.secondary-navigation .main-nav ul ul li[class*="current-menu-"] > a:hover,.secondary-navigation .main-nav ul ul li[class*="current-menu-"].sfHover > a{color:#ffffff;background-color:#474747;}
</style>
<link rel='stylesheet' id='generate-sticky-css'  href='http://theballerlife.com/wp-content/plugins/gp-premium/menu-plus/functions/css/sticky.min.css?ver=1.5.2' type='text/css' media='all' />
<link rel='stylesheet' id='generate-sliiide-css'  href='http://theballerlife.com/wp-content/plugins/gp-premium/menu-plus/functions/css/sliiide.min.css?ver=1.5.2' type='text/css' media='all' />
<link rel='stylesheet' id='generate-menu-logo-css'  href='http://theballerlife.com/wp-content/plugins/gp-premium/menu-plus/functions/css/menu-logo.min.css?ver=1.5.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-pagenavi-style-css'  href='http://theballerlife.com/wp-content/plugins/wp-pagenavi-style/style/default.css?ver=1.0' type='text/css' media='all' />
<script type='text/javascript' src='http://theballerlife.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://theballerlife.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='http://theballerlife.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://theballerlife.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://theballerlife.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Kevin Durant Donates $3 Million Dollars To His Alma Mater The University of Texas (Video)' href='http://theballerlife.com/2018/01/07/kevin-durant-donates-3-million-dollars-to-his-alma-mater-the-university-of-texas-video/' />
<link rel='next' title='Donovan McNabb And Eric Davis Fired From ESPN After S#xual Misconduct Investigation (Video)' href='http://theballerlife.com/2018/01/07/donovan-mcnabb-and-eric-davis-fired-from-espn-after-sxual-misconduct-investigation-video/' />
<meta name="generator" content="WordPress 4.9.1" />
<link rel='shortlink' href='http://theballerlife.com/?p=61291' />
<link rel="alternate" type="application/json+oembed" href="http://theballerlife.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Ftheballerlife.com%2F2018%2F01%2F07%2F2-chainz-shows-off-his-vacation-home-and-plays-basketball-on-a-450000-court-video%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://theballerlife.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Ftheballerlife.com%2F2018%2F01%2F07%2F2-chainz-shows-off-his-vacation-home-and-plays-basketball-on-a-450000-court-video%2F&#038;format=xml" />
	<style type="text/css">
	 .wp-pagenavi
	{
		font-size:25px !important;
	}
	</style>
	
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel="pingback" href="http://theballerlife.com/xmlrpc.php">
<meta name="viewport" content="width=device-width, initial-scale=1"><style type="text/css">
/* Custom Styles for Box 56807 */
.stb-56807 {
background: #f9f9f9 !important;
color: #1e73be !important;
border-color: #255aea !important;
border-width: 6px !important;
border-style: solid !important;
max-width: 320px;
}

.fb-like {

margin-left: 70px;
}

h4#fb-message {
    background: #3241AF;
     color: #fff;
padding: 5px 0 5px 10px!important;
    margin-top: 8px;
    margin-right: -10px;
    margin-left: -10px;
text-align: center;
height:25px;
}


</style>

<meta name="google-site-verification" content="3BzuJzm54NKE3YhZF_1yTDtZE4x8M0QWaCMWmkbiCEI" />

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-5342939612884568",
    enable_page_level_ads: true
  });
</script>

<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u) {
    e.async = 1;
    e.src = u;
    f.parentNode.insertBefore(e, f);
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  'http://cdn.taboola.com/libtrc/ballerwives/loader.js');
</script>
</head>

<body itemtype='http://schema.org/Blog' itemscope='itemscope' class="post-template-default single single-post postid-61291 single-format-standard post-image-above-header post-image-aligned-center secondary-nav-below-header secondary-nav-aligned-center slideout-enabled slideout-mobile sticky-menu-no-transition sticky-enabled menu-logo menu-logo-enabled both-sticky-menu  right-sidebar nav-below-header contained-header one-container active-footer-widgets-0 nav-search-enabled nav-aligned-left header-aligned-left dropdown-click dropdown-click-menu-item">
		<a class="screen-reader-text skip-link" href="#content" title="Skip to content">Skip to content</a>
	<header itemtype="http://schema.org/WPHeader" itemscope="itemscope" id="masthead" class="site-header grid-container grid-parent">
		<div class="inside-header grid-container grid-parent">
								<div class="header-widget">
			<aside id="text-640378489" class="widget inner-padding widget_text">			<div class="textwidget"><!-- Conversant Media 468x60 and 728x90 Banner CODE for BallerWives.com -->
<script type="text/javascript">var vclk_options = {sid:58120,media_id:1,media_type:5,version:"1.4"};</script><script class="vclk_pub_code" type="text/javascript" src="http://cdn.fastclick.net/js/adcodes/pubcode.min.js?sid=58120&media_id=1&media_type=5&version=1.4&exc=1"></script><noscript><a href="http://media.fastclick.net/w/click.here?sid=58120&m=1&c=1" target="_blank"><img src="http://media.fastclick.net/w/get.media?sid=58120&m=1&tp=5&d=s&c=1&vcm_acv=1.4" width="728" height="90" border="1"/></a></noscript>
<!-- Conversant Media 468x60 and 728x90 Banner CODE for BallerWives.com --></div>
		</aside>		</div>
						</div><!-- .inside-header -->
	
 


</header><!-- #masthead -->
		<nav itemtype="http://schema.org/SiteNavigationElement" itemscope="itemscope" id="site-navigation" class="main-navigation grid-container grid-parent">
		<div class="inside-navigation grid-container grid-parent">
				<form method="get" class="search-form navigation-search" action="http://theballerlife.com/">
		<input type="search" placeholder="SEARCH HERE...." class="search-field" value="" name="s" title="Search">
	</form>
	<div class="site-logo sticky-logo navigation-logo">
			<a href="http://theballerlife.com/" title="The Baller Life &#8211;  BallerWives.com" rel="home">
				<img class="header-image" src="http://theballerlife.com/wp-content/uploads/2017/09/blife1.png" alt="The Baller Life &#8211;  BallerWives.com" />
			</a>
		</div>	<div class="mobile-bar-items">
				<span class="search-item" title="Search">
			<a href="#">
				<i class="fa fa-fw fa-search" aria-hidden="true"></i>
				<span class="screen-reader-text">Search</span>
			</a>
		</span>
	</div><!-- .mobile-bar-items -->
				<button class="menu-toggle" aria-controls="primary-menu" aria-expanded="false">
								<span class="mobile-menu">Menu</span>
			</button>
			<div id="primary-menu" class="main-nav"><ul id="menu-men-mobile" class=" menu sf-menu"><li id="menu-item-46666" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-46666"><a href="http://theballerlife.com"><i class="fa fa-home" aria-hidden="true"></i> HOME</a></li>
<li id="menu-item-46663" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-46663"><a href="http://theballerlife.com/category/celebrity-videos/">Videos<span role="button" class="dropdown-menu-toggle" aria-expanded="false"></span></a>
<ul class="sub-menu">
	<li id="menu-item-56718" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56718"><a href="http://theballerlife.com/category/heartfelt-post/">Heartfelt Post</a></li>
	<li id="menu-item-56724" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-56724"><a href="http://theballerlife.com/category/celebrity-videos/">Celebrity Videos</a></li>
	<li id="menu-item-56719" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56719"><a href="http://theballerlife.com/category/motivational-videos/">Motivational Videos</a></li>
</ul>
</li>
<li id="menu-item-46664" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-46664"><a href="http://theballerlife.com/category/celebrity-news/">News<span role="button" class="dropdown-menu-toggle" aria-expanded="false"></span></a>
<ul class="sub-menu">
	<li id="menu-item-56723" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-56723"><a href="http://theballerlife.com/category/celebrity-news/">Celebrity News</a></li>
	<li id="menu-item-56722" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56722"><a href="http://theballerlife.com/category/sports-news/">Sports News</a></li>
</ul>
</li>
<li id="menu-item-56667" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-56667"><a href="http://theballerlife.com/category/baller-lifestyle/">Lifestyle<span role="button" class="dropdown-menu-toggle" aria-expanded="false"></span></a>
<ul class="sub-menu">
	<li id="menu-item-56716" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56716"><a href="http://theballerlife.com/category/baller-cars/">Baller Cars</a></li>
	<li id="menu-item-56717" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56717"><a href="http://theballerlife.com/category/baller-cribs/">Baller Cribs</a></li>
	<li id="menu-item-56715" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56715"><a href="http://theballerlife.com/category/marriage-proposals/">marriage proposals</a></li>
</ul>
</li>
<li id="menu-item-46665" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-46665"><a href="http://theballerlife.com/category/wife-girlfriend/">Baller Wives<span role="button" class="dropdown-menu-toggle" aria-expanded="false"></span></a>
<ul class="sub-menu">
	<li id="menu-item-56712" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56712"><a href="http://theballerlife.com/category/wife-girlfriend/movie-actors-wives/">Actors Wives</a></li>
	<li id="menu-item-56706" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56706"><a href="http://theballerlife.com/category/nba-ballers/">NBA Wives</a></li>
	<li id="menu-item-56710" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56710"><a href="http://theballerlife.com/category/nba-girlfriends/">NBA Girlfriends</a></li>
	<li id="menu-item-56707" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56707"><a href="http://theballerlife.com/category/nfl-ballers/">NFL Wives</a></li>
	<li id="menu-item-56711" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56711"><a href="http://theballerlife.com/category/nfl-girlfriends/">NFL Girlfriends</a></li>
	<li id="menu-item-56708" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56708"><a href="http://theballerlife.com/category/mlb-girlfriends/">MLB Girlfriends</a></li>
	<li id="menu-item-56709" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56709"><a href="http://theballerlife.com/category/mlb-ballers/">MLB Wives</a></li>
	<li id="menu-item-56713" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56713"><a href="http://theballerlife.com/category/rappers/">Rapper Wives</a></li>
	<li id="menu-item-56714" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56714"><a href="http://theballerlife.com/category/r-b-singer-wives/">R &#038; B Singer Wives</a></li>
	<li id="menu-item-56721" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56721"><a href="http://theballerlife.com/category/other-sports-wives-girlfriends/">Other Sports Wives Girlfriends</a></li>
</ul>
</li>
<li class="search-item" title="Search"><a href="#"><i class="fa fa-fw fa-search" aria-hidden="true"></i><span class="screen-reader-text">Search</span></a></li></ul></div>		</div><!-- .inside-navigation -->
	</nav><!-- #site-navigation -->
			<nav itemtype="http://schema.org/SiteNavigationElement" itemscope="itemscope" id="secondary-navigation" class="secondary-navigation grid-container grid-parent">
			<div class="inside-navigation grid-container grid-parent">
								<button class="menu-toggle secondary-menu-toggle">
										<span class="mobile-menu">Menu</span>
				</button>
				<div class="main-nav"><ul id="menu-second-nav-menu" class=" secondary-menu sf-menu"><li id="menu-item-59453" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-59453"><a href="http://theballerlife.com">HOME</a></li>
<li id="menu-item-59458" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-59458"><a href="http://theballerlife.com/category/celebrity-news/">News<span role="button" class="dropdown-menu-toggle" aria-expanded="false"></span></a>
<ul class="sub-menu">
	<li id="menu-item-59459" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-59459"><a href="http://theballerlife.com/category/celebrity-news/">Celebrity News</a></li>
	<li id="menu-item-59460" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59460"><a href="http://theballerlife.com/category/sports-news/">Sports News</a></li>
	<li id="menu-item-59454" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-59454"><a href="http://theballerlife.com/category/celebrity-videos/">Videos</a></li>
	<li id="menu-item-59455" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59455"><a href="http://theballerlife.com/category/heartfelt-post/">Heartfelt Post</a></li>
	<li id="menu-item-59456" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-59456"><a href="http://theballerlife.com/category/celebrity-videos/">Celebrity Videos</a></li>
	<li id="menu-item-59457" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59457"><a href="http://theballerlife.com/category/motivational-videos/">Motivational Videos</a></li>
</ul>
</li>
<li id="menu-item-59461" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-59461"><a href="http://theballerlife.com/category/baller-lifestyle/">Lifestyle<span role="button" class="dropdown-menu-toggle" aria-expanded="false"></span></a>
<ul class="sub-menu">
	<li id="menu-item-59462" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59462"><a href="http://theballerlife.com/category/baller-cars/">Baller Cars</a></li>
	<li id="menu-item-59463" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59463"><a href="http://theballerlife.com/category/baller-cribs/">Baller Cribs</a></li>
	<li id="menu-item-59464" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59464"><a href="http://theballerlife.com/category/marriage-proposals/">marriage proposals</a></li>
</ul>
</li>
<li id="menu-item-59465" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-59465"><a href="http://theballerlife.com/category/wife-girlfriend/">Wives/Girlfriends<span role="button" class="dropdown-menu-toggle" aria-expanded="false"></span></a>
<ul class="sub-menu">
	<li id="menu-item-59466" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59466"><a href="http://theballerlife.com/category/wife-girlfriend/movie-actors-wives/">Actors Wives</a></li>
	<li id="menu-item-59467" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59467"><a href="http://theballerlife.com/category/nba-ballers/">NBA Wives</a></li>
	<li id="menu-item-59468" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59468"><a href="http://theballerlife.com/category/nba-girlfriends/">NBA Girlfriends</a></li>
	<li id="menu-item-59469" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59469"><a href="http://theballerlife.com/category/nfl-ballers/">NFL Wives</a></li>
	<li id="menu-item-59470" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59470"><a href="http://theballerlife.com/category/nfl-girlfriends/">NFL Girlfriends</a></li>
	<li id="menu-item-59471" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59471"><a href="http://theballerlife.com/category/mlb-girlfriends/">MLB Girlfriends</a></li>
	<li id="menu-item-59472" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59472"><a href="http://theballerlife.com/category/mlb-ballers/">MLB Wives</a></li>
	<li id="menu-item-59473" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59473"><a href="http://theballerlife.com/category/rappers/">Rapper Wives</a></li>
	<li id="menu-item-59474" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59474"><a href="http://theballerlife.com/category/r-b-singer-wives/">R &#038; B Singer Wives</a></li>
	<li id="menu-item-59475" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59475"><a href="http://theballerlife.com/category/other-sports-wives-girlfriends/">Other Sports Wives Girlfriends</a></li>
</ul>
</li>
</ul></div>			</div><!-- .inside-navigation -->
		</nav><!-- #secondary-navigation -->
			
	<div id="page" class="hfeed site grid-container container grid-parent">
		<div id="content" class="site-content">
			<div class="featured-post-single">

		<div class="wposrp-recent-post design-1 wposrp-clearfix">

							
	<div class="wposrpcolumns wposrp-medium-5 responsive-1">
		<a class="recent-link-overlay" href="http://theballerlife.com/2018/01/06/watch-nba-star-russell-westbrook-surprises-family-with-car-he-won-for-being-all-star-game-mvp-video/"></a>

		<div class="recent-grid">
			<!-- <div class="recent-overlay"> -->
				<div class="recent-image-bg" style="height:150px">

											 <img src="http://theballerlife.com/wp-content/uploads/2018/01/russell-westbrok-surprises-family-with-new-car-video.jpg"/> 
					</div><!-- end .recent-image-bg -->				
				<!-- </div> end .recent-overlay -->
				<div class="recent-content">

					<div class="recent-title">
						<h5 style="font-size: 14px">Watch: NBA Star Russell Westbrook Surprises Family With Car He Won For Being All-Star Game MVP! (Video)</h5>
					</div>

				</div><!-- end .recent-content -->
			</div> <!-- End .recent-grid -->
	</div> <!-- End .wposrpcolumns -->	
	<div class="wposrpcolumns wposrp-medium-5 responsive-2">
		<a class="recent-link-overlay" href="http://theballerlife.com/2018/01/05/barack-obama-surprises-students-at-mckinley-tech-in-washington-d-c-video/"></a>

		<div class="recent-grid">
			<!-- <div class="recent-overlay"> -->
				<div class="recent-image-bg" style="height:150px">

											 <img src="http://theballerlife.com/wp-content/uploads/2018/01/barack-obama-surprises-high-school-kids-washington-video.jpg"/> 
					</div><!-- end .recent-image-bg -->				
				<!-- </div> end .recent-overlay -->
				<div class="recent-content">

					<div class="recent-title">
						<h5 style="font-size: 14px">Barack Obama Surprises Students At McKinley Tech In Washington, D.C. (Video)</h5>
					</div>

				</div><!-- end .recent-content -->
			</div> <!-- End .recent-grid -->
	</div> <!-- End .wposrpcolumns -->	
	<div class="wposrpcolumns wposrp-medium-5 responsive-3">
		<a class="recent-link-overlay" href="http://theballerlife.com/2018/01/04/kenny-britts-wife-sabrina-britt/"></a>

		<div class="recent-grid">
			<!-- <div class="recent-overlay"> -->
				<div class="recent-image-bg" style="height:150px">

											 <img src="http://theballerlife.com/wp-content/uploads/2018/01/kenny-britt-wife-sabrina-britt-pics.jpg"/> 
					</div><!-- end .recent-image-bg -->				
				<!-- </div> end .recent-overlay -->
				<div class="recent-content">

					<div class="recent-title">
						<h5 style="font-size: 14px">Kenny Britt’s Wife Sabrina Britt</h5>
					</div>

				</div><!-- end .recent-content -->
			</div> <!-- End .recent-grid -->
	</div> <!-- End .wposrpcolumns -->	
	<div class="wposrpcolumns wposrp-medium-5 responsive-4">
		<a class="recent-link-overlay" href="http://theballerlife.com/2018/01/04/steph-currys-wife-ayesha-speaks-on-why-she-will-never-call-herself-an-nba-wife-video/"></a>

		<div class="recent-grid">
			<!-- <div class="recent-overlay"> -->
				<div class="recent-image-bg" style="height:150px">

											 <img src="http://theballerlife.com/wp-content/uploads/2018/01/ayesha-curry-on-being-an-nba-wife.jpg"/> 
					</div><!-- end .recent-image-bg -->				
				<!-- </div> end .recent-overlay -->
				<div class="recent-content">

					<div class="recent-title">
						<h5 style="font-size: 14px">Steph Curry&#8217;s Wife Ayesha Speaks On Why She Will Never Call Herself An &#8216;NBA Wife&#8217; (Video)</h5>
					</div>

				</div><!-- end .recent-content -->
			</div> <!-- End .recent-grid -->
	</div> <!-- End .wposrpcolumns -->	
	<div class="wposrpcolumns wposrp-medium-5 responsive-5">
		<a class="recent-link-overlay" href="http://theballerlife.com/2018/01/03/dj-khaled-teams-up-with-oprah-and-joins-weight-watchers-as-its-newest-ambassador-video/"></a>

		<div class="recent-grid">
			<!-- <div class="recent-overlay"> -->
				<div class="recent-image-bg" style="height:150px">

											 <img src="http://theballerlife.com/wp-content/uploads/2018/01/djkhaled-weight-watchers-video.jpg"/> 
					</div><!-- end .recent-image-bg -->				
				<!-- </div> end .recent-overlay -->
				<div class="recent-content">

					<div class="recent-title">
						<h5 style="font-size: 14px">DJ Khaled Teams Up With Oprah And Joins &#8220;Weight Watchers&#8221; As It&#8217;s Newest Ambassador! (Video)</h5>
					</div>

				</div><!-- end .recent-content -->
			</div> <!-- End .recent-grid -->
	</div> <!-- End .wposrpcolumns -->
		</div><!-- end .wposrp-recent-post -->

	</div>
<div class="under-featured-post-ad-single">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- 728x90 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:90px"
     data-ad-client="ca-pub-5342939612884568"
     data-ad-slot="7719001020"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

		<div id="primary" class="content-area grid-parent mobile-grid-100 grid-70 tablet-grid-70">
		<main id="main" class="site-main">
				

			
<article id="post-61291" class="post-61291 post type-post status-publish format-standard hentry category-trending-news category-celebrity-news category-celebrity-videos" itemtype='http://schema.org/CreativeWork' itemscope='itemscope'>
	<div class="inside-article">
				
		<header class="entry-header">
										<h1 class="entry-title" itemprop="headline">2 Chainz Shows Off His Vacation Home And Plays Basketball On A $450,000 Court! (Video)</h1>								<div class="entry-meta">
			<span class="posted-on"><a href="http://theballerlife.com/2018/01/07/2-chainz-shows-off-his-vacation-home-and-plays-basketball-on-a-450000-court-video/" title="9:18 pm" rel="bookmark"><time class="entry-date published" datetime="2018-01-07T21:18:05+00:00" itemprop="datePublished">Sunday, January 7, 2018</time></a></span> <span class="byline"><span class="author vcard" itemtype="http://schema.org/Person" itemscope="itemscope" itemprop="author">by <a class="url fn n" href="http://theballerlife.com/author/admin/" title="View all posts by TBL Staff" rel="author" itemprop="url"><span class="author-name" itemprop="name">TBL Staff</span></a></span></span>		</div><!-- .entry-meta -->
			</header><!-- .entry-header -->
		
		
<div class="social-media-shre-buttons-top">
<aside class="mashsb-container mashsb-main mashsb-stretched"><div class="mashsb-box"><div class="mashsb-buttons"><a  class="mashicon-facebook mash-large mash-center mashsb-noshadow" href="https://www.facebook.com/sharer.php?u=http%3A%2F%2Ftheballerlife.com%2F2018%2F01%2F07%2F2-chainz-shows-off-his-vacation-home-and-plays-basketball-on-a-450000-court-video%2F" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Share&nbsp;On&nbsp;Facebook</span></a><a  class="mashicon-twitter mash-large mash-center mashsb-noshadow" href="https://twitter.com/intent/tweet?text=2%20Chainz%20Shows%20Off%20His%20Vacation%20Home%20And%20Plays%20Basketball%20On%20A%20%24450%2C000%20Court%21%20%28Video%29&url=http://theballerlife.com/2018/01/07/2-chainz-shows-off-his-vacation-home-and-plays-basketball-on-a-450000-court-video/&via=ballerwives" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Tweet&nbsp;This......</span></a><a  class="mashicon-subscribe mash-large mash-center mashsb-noshadow" href="#" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Subscribe&nbsp;To&nbsp;Email&nbsp;List</span></a><div class="onoffswitch2 mash-large mashsb-noshadow" style="display:none;"></div></div></div>
                    <div style="clear:both;"></div></aside>
            <!-- Share buttons made by mashshare.net - Version: 3.4.7--></div>		

<div class="entry-content" itemprop="text">

			<p><img src="http://theballerlife.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="http://theballerlife.com/wp-content/uploads/2018/01/2chainz-vacation-home-video.jpg" alt width="596" height="423" class="alignnone size-full wp-image-61292" srcset="http://theballerlife.com/wp-content/uploads/2018/01/2chainz-vacation-home-video.jpg 596w, http://theballerlife.com/wp-content/uploads/2018/01/2chainz-vacation-home-video-300x213.jpg 300w, http://theballerlife.com/wp-content/uploads/2018/01/2chainz-vacation-home-video-400x284.jpg 400w, http://theballerlife.com/wp-content/uploads/2018/01/2chainz-vacation-home-video-240x170.jpg 240w" sizes="(max-width: 596px) 100vw, 596px"><noscript><img src="http://theballerlife.com/wp-content/uploads/2018/01/2chainz-vacation-home-video.jpg" alt="" width="596" height="423" class="alignnone size-full wp-image-61292" srcset="http://theballerlife.com/wp-content/uploads/2018/01/2chainz-vacation-home-video.jpg 596w, http://theballerlife.com/wp-content/uploads/2018/01/2chainz-vacation-home-video-300x213.jpg 300w, http://theballerlife.com/wp-content/uploads/2018/01/2chainz-vacation-home-video-400x284.jpg 400w, http://theballerlife.com/wp-content/uploads/2018/01/2chainz-vacation-home-video-240x170.jpg 240w" sizes="(max-width: 596px) 100vw, 596px" /></noscript><br />
<span id="more-61291"></span><br />
Rapper 2 Chainz teamed up with GQ and gave his fans an inside peek at his vacation home and played basketball on a $450,000 court. </p>
<p><strong>Watch the video below:</strong></p><div id="single-between-post-ad"><div class="ad-after-first"><script type="text/javascript">var vclk_options = {sid:58120,media_id:1,media_type:5,version:"1.4"};</script><script class="vclk_pub_code" type="text/javascript" src="http://cdn.fastclick.net/js/adcodes/pubcode.min.js?sid=58120&media_id=1&media_type=5&version=1.4&exc=1"></script><noscript><a href="http://media.fastclick.net/w/click.here?sid=58120&m=1&c=1" target="_blank"><img src="http://theballerlife.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="http://media.fastclick.net/w/get.media?sid=58120&#038;m=1&#038;tp=5&#038;d=s&#038;c=1&#038;vcm_acv=1.4" width="728" height="90" border="1"><noscript><img src="http://media.fastclick.net/w/get.media?sid=58120&m=1&tp=5&d=s&c=1&vcm_acv=1.4" width="728" height="90" border="1"></noscript></a></noscript></div>
<div class="text-before-ad">ADVERTISEMENT - CONTINUE READING BELOW</div>
<div class="ad-after-first-mobile"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Mobile 300x250 Unit -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-5342939612884568"
     data-ad-slot="3453847020"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div>
<p><center><iframe width="560" height="315" src="https://www.youtube.com/embed/xr2iKPyATSg" frameborder="0" gesture="media" allow="encrypted-media" allowfullscreen></iframe></center></p>

		
</div><!-- .entry-content -->

<div class="social-media-share-buttons-bottom-small">
<iframe src="https://www.facebook.com/plugins/like.php?href=http://theballerlife.com/2018/01/07/2-chainz-shows-off-his-vacation-home-and-plays-basketball-on-a-450000-court-video/&width=90&layout=button_count&action=like&size=large&show_faces=false&share=false&height=21&appId" width="90" height="27" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true"></iframe>

<a href="#" onclick="window.open('https://www.facebook.com/sharer/sharer.php?u='+encodeURIComponent(location.href),'facebook-share-dialog','width=626,height=436');return false;"><img src="http://theballerlife.com/wp-content/uploads/2017/05/facebook-share-button-large.jpg" style="opacity:0.98;"></a>

<iframe id="tweet-button" allowtransparency="true" frameborder="0" scrolling="no"
            src="http://platform.twitter.com/widgets/tweet_button.html?size=l&via=ballerwives&amp;text=2 Chainz Shows Off His Vacation Home And Plays Basketball On A $450,000 Court! (Video)"
            style="width:80px; height:28px;"></iframe>
</div>

<div class="social-media-shre-buttons-bottom">
<aside class="mashsb-container mashsb-main mashsb-stretched"><div class="mashsb-box"><div class="mashsb-buttons"><a  class="mashicon-facebook mash-large mash-center mashsb-noshadow" href="https://www.facebook.com/sharer.php?u=http%3A%2F%2Ftheballerlife.com%2F2018%2F01%2F07%2F2-chainz-shows-off-his-vacation-home-and-plays-basketball-on-a-450000-court-video%2F" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Share&nbsp;On&nbsp;Facebook</span></a><a  class="mashicon-twitter mash-large mash-center mashsb-noshadow" href="https://twitter.com/intent/tweet?text=2%20Chainz%20Shows%20Off%20His%20Vacation%20Home%20And%20Plays%20Basketball%20On%20A%20%24450%2C000%20Court%21%20%28Video%29&url=http://theballerlife.com/2018/01/07/2-chainz-shows-off-his-vacation-home-and-plays-basketball-on-a-450000-court-video/&via=ballerwives" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Tweet&nbsp;This......</span></a><a  class="mashicon-subscribe mash-large mash-center mashsb-noshadow" href="#" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Subscribe&nbsp;To&nbsp;Email&nbsp;List</span></a><div class="onoffswitch2 mash-large mashsb-noshadow" style="display:none;"></div></div></div>
                    <div style="clear:both;"></div></aside>
            <!-- Share buttons made by mashshare.net - Version: 3.4.7--></div>

<div class="taboola-ad">
<div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'thumbnails-a',
    container: 'taboola-below-article-thumbnails',
    placement: 'Below Article Thumbnails',
    target_type: 'mix'
  });
</script> 
</div>

<div class="matched-content">
<div id="zergnet-widget-51646"></div>

<script language="javascript" type="text/javascript">
    (function() {
        var zergnet = document.createElement('script');
        zergnet.type = 'text/javascript'; zergnet.async = true;
        zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=51646';
        var znscr = document.getElementsByTagName('script')[0];
        znscr.parentNode.insertBefore(zergnet, znscr);
    })();
</script>
</div>

<div class="related-post-thumb">
<div class="crp_related "><h3>SEE ALSO:</h3><ul><li><a href="http://theballerlife.com/2017/11/20/watch-dwyane-wade-releases-new-backcourt-reality-show-giving-fans-a-look-into-his-personal-life-video/"    ><img src="http://theballerlife.com/wp-content/uploads/2017/11/dwyane-wade-reality-show-backcourt-video-220x200.jpg" alt="Watch: Dwyane Wade Releases New &#8216;BackCourt&#8217; Reality Show Giving Fans A Look Into His Personal Life! (Video)" title="Watch: Dwyane Wade Releases New &#8216;BackCourt&#8217; Reality Show Giving Fans A Look Into His Personal Life! (Video)" width="240" height="200" class="crp_thumb crp_correctfirst" /><span class="crp_title">Watch: Dwyane Wade Releases New &#8216;BackCourt&#8217; Reality Show Giving Fans A Look Into&hellip;</span></a></li><li><a href="http://theballerlife.com/2017/12/27/nba-star-john-wall-gives-back-for-christmas-off-the-court-video/"    ><img src="http://theballerlife.com/wp-content/uploads/2017/12/john-wall-gives-back-for-chrsitmas-video-240x149.jpg" alt="NBA Star John Wall Gives Back For Christmas Off The Court! (Video)" title="NBA Star John Wall Gives Back For Christmas Off The Court! (Video)" width="240" height="200" class="crp_thumb crp_correctfirst" /><span class="crp_title">NBA Star John Wall Gives Back For Christmas Off The Court! (Video)</span></a></li><li><a href="http://theballerlife.com/2017/10/27/tyrese-speaks-out-after-being-hospitalized-for-chest-pains-and-dehydration-after-leaving-stressful-child-custody-court-hearing-video/"    ><img src="http://theballerlife.com/wp-content/uploads/2017/10/tyrese-leaving-hospital-chest-pains--240x183.jpg" alt="Tyrese Speaks Out After Being Hospitalized For Chest Pains And Dehydration After Leaving Stressful Child Custody Court Hearing. (Video)" title="Tyrese Speaks Out After Being Hospitalized For Chest Pains And Dehydration After Leaving Stressful Child Custody Court Hearing. (Video)" width="240" height="200" class="crp_thumb crp_correctfirst" /><span class="crp_title">Tyrese Speaks Out After Being Hospitalized For Chest Pains And Dehydration After Leaving&hellip;</span></a></li><li><a href="http://theballerlife.com/2017/12/17/ex-wife-of-late-nba-star-lorenzen-wright-charged-in-connection-with-his-2010-murder-video/"    ><img src="http://theballerlife.com/wp-content/uploads/2017/12/lorenzen-white-ex-wife-sherra-wright-robinson-arrested-240x159.jpg" alt="Ex-wife Of Late NBA Star Lorenzen Wright Charged In Connection With His 2010 Murder! (Video)" title="Ex-wife Of Late NBA Star Lorenzen Wright Charged In Connection With His 2010 Murder! (Video)" width="240" height="200" class="crp_thumb crp_correctfirst" /><span class="crp_title">Ex-wife Of Late NBA Star Lorenzen Wright Charged In Connection With His 2010 Murder! (Video)</span></a></li><li><a href="http://theballerlife.com/2017/09/19/she-got-game-kobe-bryant-plays-1-on-1-basketball-with-his-daughter-gigi-video/"    ><img src="http://theballerlife.com/wp-content/uploads/2017/09/kobe-bryant-plays-basketball-with-daughter-video-206x200.jpg" alt="She Got Game: Kobe Bryant Plays 1-On-1 Basketball With His Daughter Gigi! (Video)" title="She Got Game: Kobe Bryant Plays 1-On-1 Basketball With His Daughter Gigi! (Video)" width="240" height="200" class="crp_thumb crp_correctfirst" /><span class="crp_title">She Got Game: Kobe Bryant Plays 1-On-1 Basketball With His Daughter Gigi! (Video)</span></a></li><li><a href="http://theballerlife.com/2017/10/30/lavar-ball-shows-off-new-16000-square-foot-house-its-the-best-house-in-chino-hills-video/"    ><img src="http://theballerlife.com/wp-content/uploads/2017/10/lavar-ball-new-house-chino-hills-240x161.jpg" alt="LaVar Ball Shows Off New 16,000-Square-Foot House: &#8216;It&#8217;s The Best House In Chino Hills!&#8217; (Video)" title="LaVar Ball Shows Off New 16,000-Square-Foot House: &#8216;It&#8217;s The Best House In Chino Hills!&#8217; (Video)" width="240" height="200" class="crp_thumb crp_correctfirst" /><span class="crp_title">LaVar Ball Shows Off New 16,000-Square-Foot House: &#8216;It&#8217;s The Best House In Chino&hellip;</span></a></li></ul><div class="crp_clear"></div></div></div>

		<footer class="entry-meta">
			<span class="cat-links"><span class="screen-reader-text">Categories </span><a href="http://theballerlife.com/category/trending-news/" rel="category tag">#Trending News</a>, <a href="http://theballerlife.com/category/celebrity-news/" rel="category tag">Celebrity News</a>, <a href="http://theballerlife.com/category/celebrity-videos/" rel="category tag">Celebrity Videos</a></span>				<nav id="nav-below" class="post-navigation">
		<span class="screen-reader-text">Post navigation</span>

		<div class="nav-previous"><span class="prev" title="Previous"><a href="http://theballerlife.com/2018/01/07/kevin-durant-donates-3-million-dollars-to-his-alma-mater-the-university-of-texas-video/" rel="prev">Kevin Durant Donates $3 Million Dollars To His Alma Mater The University of Texas (Video)</a></span></div><div class="nav-next"><span class="next" title="Next"><a href="http://theballerlife.com/2018/01/07/donovan-mcnabb-and-eric-davis-fired-from-espn-after-sxual-misconduct-investigation-video/" rel="next">Donovan McNabb And Eric Davis Fired From ESPN After S#xual Misconduct Investigation (Video)</a></span></div>	</nav><!-- #nav-below -->
			</footer><!-- .entry-meta -->
	

<div class="aha-health-post">
<a href="http://ahahealthnews.com/ananda-lewis-do-not-watch-this-if-you-eat-figs-youve-been-warned-video/" target="_blank" rel="noopener"><img class="aligncenter size-full wp-image-60636" src="http://theballerlife.com/wp-content/uploads/2017/11/ananda-lewis-talks-eating-figs-.jpg" alt="" width="650" height="550" /></a>
</div>


<h4 class="first-post-title"><span>Check Out These Related Post</span></h4>

<div class="related-post-thumb1">
<div style="clear: both"></div><div style="border: 0pt none ; margin: 0pt; padding: 0pt;"><a onmouseout="this.style.backgroundColor='#000'" onmouseover="this.style.backgroundColor='#000'" style="background-color: #000; border-right: 1px solid #000; border-bottom: medium none; margin: 0pt; padding: 6px; display: block; float: left; text-decoration: none; text-align: center; cursor: pointer;" href="http://theballerlife.com/2017/03/26/zoe-saldana-opens-up-about-her-family-life-husband-taking-her-last-name-video/"><div style="border: 0pt none ; margin: 0pt; padding: 0pt; width: 150px; height: 245px;"><div style="border: 0pt none ; margin: 0pt; padding: 0pt; background: transparent url(http://theballerlife.com/wp-content/uploads/2017/03/zoe-saldana-husband-pics-photos-150x150.jpg) no-repeat scroll 0% 0%; -moz-background-clip: border; -moz-background-origin: padding; -moz-background-inline-policy: continuous; width: 150px; height: 150px; background-size: cover;"></div><div style="border: 0pt none; margin: 3px 0pt 0pt; padding: 0pt; font-family: ; font-style: normal; font-variant: normal; font-weight: normal; font-size: 13px; line-height: normal; font-size-adjust: none; font-stretch: normal; -x-system-font: none; color: #fff;">Zoe Saldana Opens Up About Her Family Life &amp; Husband Taking Her Last Name! (Video)</div></div></a><a onmouseout="this.style.backgroundColor='#000'" onmouseover="this.style.backgroundColor='#000'" style="background-color: #000; border-right: 1px solid #000; border-bottom: medium none; margin: 0pt; padding: 6px; display: block; float: left; text-decoration: none; text-align: center; cursor: pointer;" href="http://theballerlife.com/2017/03/29/ohh-no-nfl-hall-of-famer-michael-irvin-accused-of-allegedly-sxually-assaulting-a-florida-woman-he-says-shes-lying-details/"><div style="border: 0pt none ; margin: 0pt; padding: 0pt; width: 150px; height: 245px;"><div style="border: 0pt none ; margin: 0pt; padding: 0pt; background: transparent url(http://theballerlife.com/wp-content/uploads/2017/03/michael-irvin-accused-assault-150x150.jpg) no-repeat scroll 0% 0%; -moz-background-clip: border; -moz-background-origin: padding; -moz-background-inline-policy: continuous; width: 150px; height: 150px; background-size: cover;"></div><div style="border: 0pt none; margin: 3px 0pt 0pt; padding: 0pt; font-family: ; font-style: normal; font-variant: normal; font-weight: normal; font-size: 13px; line-height: normal; font-size-adjust: none; font-stretch: normal; -x-system-font: none; color: #fff;">Ohh No: NFL Hall Of Famer Michael Irvin Accused Of Allegedly S#xually Assaulting A Florida Woman...H...</div></div></a><a onmouseout="this.style.backgroundColor='#000'" onmouseover="this.style.backgroundColor='#000'" style="background-color: #000; border-right: 1px solid #000; border-bottom: medium none; margin: 0pt; padding: 6px; display: block; float: left; text-decoration: none; text-align: center; cursor: pointer;" href="http://theballerlife.com/2017/04/07/gabrielle-union-shares-how-husband-dwyane-wades-leg-injury-affected-their-love-life-video/"><div style="border: 0pt none ; margin: 0pt; padding: 0pt; width: 150px; height: 245px;"><div style="border: 0pt none ; margin: 0pt; padding: 0pt; background: transparent url(http://theballerlife.com/wp-content/uploads/2017/04/gabby-dunion-dwyane-wade-pics-150x150.jpg) no-repeat scroll 0% 0%; -moz-background-clip: border; -moz-background-origin: padding; -moz-background-inline-policy: continuous; width: 150px; height: 150px; background-size: cover;"></div><div style="border: 0pt none; margin: 3px 0pt 0pt; padding: 0pt; font-family: ; font-style: normal; font-variant: normal; font-weight: normal; font-size: 13px; line-height: normal; font-size-adjust: none; font-stretch: normal; -x-system-font: none; color: #fff;">Gabrielle Union Shares How Husband Dwyane Wade’s Leg Injury Affected Their Love Life! (Video)</div></div></a><a onmouseout="this.style.backgroundColor='#000'" onmouseover="this.style.backgroundColor='#000'" style="background-color: #000; border-right: 1px solid #000; border-bottom: medium none; margin: 0pt; padding: 6px; display: block; float: left; text-decoration: none; text-align: center; cursor: pointer;" href="http://theballerlife.com/2017/04/14/ahhh-janet-jackson-releases-first-photo-of-her-3-month-old-baby-boy-photo/"><div style="border: 0pt none ; margin: 0pt; padding: 0pt; width: 150px; height: 245px;"><div style="border: 0pt none ; margin: 0pt; padding: 0pt; background: transparent url(http://theballerlife.com/wp-content/uploads/2017/04/janet-jackson-pics-photos-150x150.jpg) no-repeat scroll 0% 0%; -moz-background-clip: border; -moz-background-origin: padding; -moz-background-inline-policy: continuous; width: 150px; height: 150px; background-size: cover;"></div><div style="border: 0pt none; margin: 3px 0pt 0pt; padding: 0pt; font-family: ; font-style: normal; font-variant: normal; font-weight: normal; font-size: 13px; line-height: normal; font-size-adjust: none; font-stretch: normal; -x-system-font: none; color: #fff;">Ahhh: Janet Jackson Releases First Photo Of Her 3 Month Old Baby Boy! (Photo)</div></div></a><a onmouseout="this.style.backgroundColor='#000'" onmouseover="this.style.backgroundColor='#000'" style="background-color: #000; border-right: 1px solid #000; border-bottom: medium none; margin: 0pt; padding: 6px; display: block; float: left; text-decoration: none; text-align: center; cursor: pointer;" href="http://theballerlife.com/2017/04/16/so-sad-nba-star-isaiah-thomas-sister-chyna-dies-in-car-crash-in-washington-video/"><div style="border: 0pt none ; margin: 0pt; padding: 0pt; width: 150px; height: 245px;"><div style="border: 0pt none ; margin: 0pt; padding: 0pt; background: transparent url(http://theballerlife.com/wp-content/uploads/2017/04/Isaiah-Thomas-pics-photos-150x150.jpg) no-repeat scroll 0% 0%; -moz-background-clip: border; -moz-background-origin: padding; -moz-background-inline-policy: continuous; width: 150px; height: 150px; background-size: cover;"></div><div style="border: 0pt none; margin: 3px 0pt 0pt; padding: 0pt; font-family: ; font-style: normal; font-variant: normal; font-weight: normal; font-size: 13px; line-height: normal; font-size-adjust: none; font-stretch: normal; -x-system-font: none; color: #fff;">So Sad: NBA Star Isaiah Thomas' Sister, Chyna, Dies In Car Crash In Washington! (Video)</div></div></a><a onmouseout="this.style.backgroundColor='#000'" onmouseover="this.style.backgroundColor='#000'" style="background-color: #000; border-right: 1px solid #000; border-bottom: medium none; margin: 0pt; padding: 6px; display: block; float: left; text-decoration: none; text-align: center; cursor: pointer;" href="http://theballerlife.com/2017/04/26/tameka-tiny-harris-talks-strained-marriage-with-t-i-her-dancing-with-floyd-mayweather-reality-tv-and-more-video/"><div style="border: 0pt none ; margin: 0pt; padding: 0pt; width: 150px; height: 245px;"><div style="border: 0pt none ; margin: 0pt; padding: 0pt; background: transparent url(http://theballerlife.com/wp-content/uploads/2017/04/tiny-talks-marriage-to-TI-150x150.jpg) no-repeat scroll 0% 0%; -moz-background-clip: border; -moz-background-origin: padding; -moz-background-inline-policy: continuous; width: 150px; height: 150px; background-size: cover;"></div><div style="border: 0pt none; margin: 3px 0pt 0pt; padding: 0pt; font-family: ; font-style: normal; font-variant: normal; font-weight: normal; font-size: 13px; line-height: normal; font-size-adjust: none; font-stretch: normal; -x-system-font: none; color: #fff;">Tameka &quot;Tiny&quot; Harris Talks Strained Marriage With T.I.,  Her Dancing With Floyd Mayweather...</div></div></a><a onmouseout="this.style.backgroundColor='#000'" onmouseover="this.style.backgroundColor='#000'" style="background-color: #000; border-right: 1px solid #000; border-bottom: medium none; margin: 0pt; padding: 6px; display: block; float: left; text-decoration: none; text-align: center; cursor: pointer;" href="http://theballerlife.com/2017/09/18/nfl-star-michael-bennett-opens-about-his-scary-encounter-with-police-in-las-vegas-i-was-terrified-video/"><div style="border: 0pt none ; margin: 0pt; padding: 0pt; width: 150px; height: 245px;"><div style="border: 0pt none ; margin: 0pt; padding: 0pt; background: transparent url(http://theballerlife.com/wp-content/uploads/2017/09/michael-bennett-talks-police-encounter-150x150.jpg) no-repeat scroll 0% 0%; -moz-background-clip: border; -moz-background-origin: padding; -moz-background-inline-policy: continuous; width: 150px; height: 150px; background-size: cover;"></div><div style="border: 0pt none; margin: 3px 0pt 0pt; padding: 0pt; font-family: ; font-style: normal; font-variant: normal; font-weight: normal; font-size: 13px; line-height: normal; font-size-adjust: none; font-stretch: normal; -x-system-font: none; color: #fff;">NFL Star Michael Bennett Opens About His Scary Encounter With Police In Las Vegas: I Was Terrified! ...</div></div></a><a onmouseout="this.style.backgroundColor='#000'" onmouseover="this.style.backgroundColor='#000'" style="background-color: #000; border-right: 1px solid #000; border-bottom: medium none; margin: 0pt; padding: 6px; display: block; float: left; text-decoration: none; text-align: center; cursor: pointer;" href="http://theballerlife.com/2017/09/25/nfl-star-michael-thomas-gets-emotional-while-talking-about-trump-calling-him-a-son-of-a-btch-video/"><div style="border: 0pt none ; margin: 0pt; padding: 0pt; width: 150px; height: 245px;"><div style="border: 0pt none ; margin: 0pt; padding: 0pt; background: transparent url(http://theballerlife.com/wp-content/uploads/2017/09/nfl-star-michael-thomas-emotional-trump-video-150x150.jpg) no-repeat scroll 0% 0%; -moz-background-clip: border; -moz-background-origin: padding; -moz-background-inline-policy: continuous; width: 150px; height: 150px; background-size: cover;"></div><div style="border: 0pt none; margin: 3px 0pt 0pt; padding: 0pt; font-family: ; font-style: normal; font-variant: normal; font-weight: normal; font-size: 13px; line-height: normal; font-size-adjust: none; font-stretch: normal; -x-system-font: none; color: #fff;">NFL Star Michael Thomas Gets Emotional While Talking About Trump Calling Him A &quot;Son Of A B*tch!...</div></div></a></div><div style="clear: both"></div></div>

<h4 class="first-post-title"><span>Check Out These Stories</span></h4>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-5342939612884568"
     data-ad-slot="4938485821"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>

<div id="spaceundernav">
<div class="facebook">
<iframe src="https://www.facebook.com/plugins/page.php?href=https%3A%2F%2Fwww.facebook.com%2Fballerwives%2F&tabs&width=330&height=250&small_header=false&adapt_container_width=true&hide_cover=false&show_facepile=true&appId" width="330" height="250" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true"></iframe>
</div>
<div class="banner300">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- 300x250, created 6/22/10 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-5342939612884568"
     data-ad-slot="2117225603"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</div>

</div><!-- .inside-article -->
</article><!-- #post-## -->
<input type="hidden" name="IL_IN_TAG" value="2"/>
<h4 class="first-post-title"><span>Leave A Comment</span></h4>
								<div class="comments-area">
						
	<div id="comments">

	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2018/01/07/2-chainz-shows-off-his-vacation-home-and-plays-basketball-on-a-450000-court-video/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://theballerlife.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-form-comment"><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><input placeholder="Name *" id="author" name="author" type="text" value="" size="30" />
<input placeholder="Email *" id="email" name="email" type="text" value="" size="30" />
<input placeholder="Website" id="url" name="url" type="text" value="" size="30" />
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='61291' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="c8da6f39bd" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="126"/></p>			</form>
			</div><!-- #respond -->
	
</div><!-- #comments -->
					</div>
			
		
				</main><!-- #main -->

	</div><!-- #primary -->

<div id="right-sidebar" itemtype="http://schema.org/WPSideBar" itemscope="itemscope" role="complementary" class="widget-area grid-30 tablet-grid-30 grid-parent sidebar">
	<div class="inside-right-sidebar">
				<aside id="text-640378490" class="widget inner-padding widget_text">			<div class="textwidget"><iframe src="https://www.facebook.com/plugins/page.php?href=https%3A%2F%2Fwww.facebook.com%2Fballerwives%2F&tabs&width=300&height=250&small_header=false&adapt_container_width=true&hide_cover=false&show_facepile=false&appId" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true"></iframe></div>
		</aside><aside id="text-640378496" class="widget inner-padding widget_text">			<div class="textwidget"><p><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<!-- 300x600 --><br />
<ins class="adsbygoogle" style="display: inline-block; width: 300px; height: 600px;" data-ad-client="ca-pub-5342939612884568" data-ad-slot="3112505826"></ins><br />
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></p>
</div>
		</aside><aside id="text-640378492" class="widget inner-padding widget_text">			<div class="textwidget"><p><!-- Conversant Media 300x250 Medium Rectangle CODE for BallerWives.com --><br />
<script type="text/javascript">var vclk_options = {sid:58120,media_id:6,media_type:8,version:"1.4"};</script><script class="vclk_pub_code" type="text/javascript" src="http://cdn.fastclick.net/js/adcodes/pubcode.min.js?sid=58120&#038;media_id=6&#038;media_type=8&#038;version=1.4&#038;exc=1"></script><noscript><a href="http://media.fastclick.net/w/click.here?sid=58120&#038;m=6&#038;c=1" target="_blank"><img src="http://media.fastclick.net/w/get.media?sid=58120&#038;m=6&#038;tp=8&#038;d=s&#038;c=1&#038;vcm_acv=1.4" width="300" height="250" border="1"/></a></noscript><br />
<!-- Conversant Media 300x250 Medium Rectangle CODE for BallerWives.com --></p>
</div>
		</aside><aside id="text-640378495" class="widget inner-padding widget_text">			<div class="textwidget"><div id="zergnet-widget-51647"></div>

<script language="javascript" type="text/javascript">
    (function() {
        var zergnet = document.createElement('script');
        zergnet.type = 'text/javascript'; zergnet.async = true;
        zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=51647';
        var znscr = document.getElementsByTagName('script')[0];
        znscr.parentNode.insertBefore(zergnet, znscr);
    })();
</script></div>
		</aside><aside id="text-640378483" class="widget inner-padding widget_text">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- 336x280 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:336px;height:280px"
     data-ad-client="ca-pub-5342939612884568"
     data-ad-slot="3391707423"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</aside><aside id="text-640378494" class="widget inner-padding widget_text"><div class="widget-title"><span>You May Also Like:</span></div>			<div class="textwidget"><div id="taboola-right-rail-thumbnails"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'right-rail-bulk1',
    container: 'taboola-right-rail-thumbnails',
    placement: 'Right Rail Thumbnails',
    target_type: 'mix'
  });
</script></div>
		</aside><aside id="text-640378493" class="widget inner-padding widget_text">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- 300x600 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-5342939612884568"
     data-ad-slot="3112505826"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</aside><aside id="wpfp_recentpostlist_widget-5" class="widget inner-padding wpfp-featured-fplw"><div class="widget-title"><span>Latest Celeb News</span></div>
        <div class="wpfp-featured-post-widget-wrp wpfp-clearfix ">
            <div class="wpfp-widget wpfp-recent-post-widget" id="wpfp-recent-post-widget-1">

                
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2018/01/07/donovan-mcnabb-and-eric-davis-fired-from-espn-after-sxual-misconduct-investigation-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2018/01/donovan-mcnabb-eric-davis-fired-espn.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2018/01/07/donovan-mcnabb-and-eric-davis-fired-from-espn-after-sxual-misconduct-investigation-video/" title="Donovan McNabb And Eric Davis Fired From ESPN After S#xual Misconduct Investigation (Video)" style="font-size: 14px">Donovan McNabb And Eric Davis Fired From ESPN After S#xual Misconduct Investigation (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2018/01/07/2-chainz-shows-off-his-vacation-home-and-plays-basketball-on-a-450000-court-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2018/01/2chainz-vacation-home-video.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2018/01/07/2-chainz-shows-off-his-vacation-home-and-plays-basketball-on-a-450000-court-video/" title="2 Chainz Shows Off His Vacation Home And Plays Basketball On A $450,000 Court! (Video)" style="font-size: 14px">2 Chainz Shows Off His Vacation Home And Plays Basketball On A $450,000 Court! (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                            </div><!-- end .wpfp-recent-post -->

    </div><!-- end .wpfp-featured-post-widget-wrp -->

    </aside><aside id="wpfp_recentpostlist_widget-2" class="widget inner-padding wpfp-featured-fplw"><div class="widget-title"><span>NFL Wives &#038; Girlfriends</span></div>
        <div class="wpfp-featured-post-widget-wrp wpfp-clearfix ">
            <div class="wpfp-widget wpfp-recent-post-widget" id="wpfp-recent-post-widget-2">

                
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2018/01/04/kenny-britts-wife-sabrina-britt/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2018/01/kenny-britt-wife-sabrina-britt-pics.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2018/01/04/kenny-britts-wife-sabrina-britt/" title="Kenny Britt’s Wife Sabrina Britt" style="font-size: 14px">Kenny Britt’s Wife Sabrina Britt</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/11/17/nfl-star-marquise-goodwin-and-wife-morgan-open-up-about-tragic-loss-of-their-new-born-son-just-hours-before-game/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/11/marquise-goodwin-wife-morgan-goodwin-pics-photos.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/11/17/nfl-star-marquise-goodwin-and-wife-morgan-open-up-about-tragic-loss-of-their-new-born-son-just-hours-before-game/" title="NFL Star Marquise Goodwin And Wife Morgan Open Up About Tragic Loss Of Their New Born Son Just Hours Before Game!" style="font-size: 14px">NFL Star Marquise Goodwin And Wife Morgan Open Up About Tragic Loss Of Their New Born Son Just Hours Before Game!</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/11/16/watch-nfl-star-marvin-jones-auditions-for-the-new-american-idol-blows-the-judges-away-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/11/Marvin-Jones-wife-Jazmyn-Jones-pics-photos-american-idol.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/11/16/watch-nfl-star-marvin-jones-auditions-for-the-new-american-idol-blows-the-judges-away-video/" title="Watch: NFL Star Marvin Jones Auditions For The New American Idol&#8230;..Blows The Judges Away!! (Video)" style="font-size: 14px">Watch: NFL Star Marvin Jones Auditions For The New American Idol&#8230;..Blows The Judges Away!! (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/11/04/ex-nfl-star-kerry-rhodes-and-wife-nicky-whelan-file-for-divorce-after-less-than-6-months-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/11/kerry-rhodes-wife-nicky-wheelan-pics-photos.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/11/04/ex-nfl-star-kerry-rhodes-and-wife-nicky-whelan-file-for-divorce-after-less-than-6-months-video/" title="Ex-NFL Star Kerry Rhodes And Wife Nicky Whelan File For Divorce After Less Than 6 Months!!! (Video)" style="font-size: 14px">Ex-NFL Star Kerry Rhodes And Wife Nicky Whelan File For Divorce After Less Than 6 Months!!! (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/09/07/congratulations-nfl-star-reggie-bush-and-wife-lilit-welcome-baby-number-3-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/09/reggie-bush-wife-lilit-bush-pics-photos.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/09/07/congratulations-nfl-star-reggie-bush-and-wife-lilit-welcome-baby-number-3-video/" title="Congratulations: NFL Star Reggie Bush And Wife Lilit Welcome Baby Number # 3 (Video)" style="font-size: 14px">Congratulations: NFL Star Reggie Bush And Wife Lilit Welcome Baby Number # 3 (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/08/25/seth-devalves-wife-erica-says-im-proud-of-my-husband-for-kneeling-during-the-anthem-but-dont-make-him-a-white-savior/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/08/seth-devalve-wife-erica-harris-devalve-pics-photos8.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/08/25/seth-devalves-wife-erica-says-im-proud-of-my-husband-for-kneeling-during-the-anthem-but-dont-make-him-a-white-savior/" title="Seth Devalve&#8217;s Wife Erica Says: &#8216;&#8221;I’m Proud Of My Husband For Kneeling During The Anthem, But Don’t Make Him a White Savior!&#8221;" style="font-size: 14px">Seth Devalve&#8217;s Wife Erica Says: &#8216;&#8221;I’m Proud Of My Husband For Kneeling During The Anthem, But Don’t Make Him a White Savior!&#8221;</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/08/24/seth-devalve-becomes-1st-white-nfl-player-to-kneel-during-national-anthem-in-support-of-kaepernicks-protest-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/08/seth-devalve-white-player-kneel-national-anthem-video.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/08/24/seth-devalve-becomes-1st-white-nfl-player-to-kneel-during-national-anthem-in-support-of-kaepernicks-protest-video/" title="Seth DeValve Becomes 1st White NFL Player To Kneel During National Anthem In Support Of Kaepernick&#8217;s Protest! (Video)" style="font-size: 14px">Seth DeValve Becomes 1st White NFL Player To Kneel During National Anthem In Support Of Kaepernick&#8217;s Protest! (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                            </div><!-- end .wpfp-recent-post -->

    </div><!-- end .wpfp-featured-post-widget-wrp -->

    </aside><aside id="wpfp_recentpostlist_widget-3" class="widget inner-padding wpfp-featured-fplw"><div class="widget-title"><span>NBA Wives &#038; Girlfriends</span></div>
        <div class="wpfp-featured-post-widget-wrp wpfp-clearfix ">
            <div class="wpfp-widget wpfp-recent-post-widget" id="wpfp-recent-post-widget-3">

                
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/12/18/adorable-lebron-james-daughter-zhuri-perfectly-impersonates-her-dad-reacting-to-referee-calls-during-game-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/12/zhuri-james-impersonates-dad-lebron-james-video.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/12/18/adorable-lebron-james-daughter-zhuri-perfectly-impersonates-her-dad-reacting-to-referee-calls-during-game-video/" title="Adorable: LeBron James’ Daughter Zhuri Perfectly Impersonates Her Dad Reacting To Referee Calls During Game!  (VIDEO)" style="font-size: 14px">Adorable: LeBron James’ Daughter Zhuri Perfectly Impersonates Her Dad Reacting To Referee Calls During Game!  (VIDEO)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/12/17/ex-wife-of-late-nba-star-lorenzen-wright-charged-in-connection-with-his-2010-murder-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/12/lorenzen-white-ex-wife-sherra-wright-robinson-arrested.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/12/17/ex-wife-of-late-nba-star-lorenzen-wright-charged-in-connection-with-his-2010-murder-video/" title="Ex-wife Of Late NBA Star Lorenzen Wright Charged In Connection With His 2010 Murder! (Video)" style="font-size: 14px">Ex-wife Of Late NBA Star Lorenzen Wright Charged In Connection With His 2010 Murder! (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/10/23/gabrielle-union-responds-to-critics-on-if-she-really-tosses-husband-dwyane-wades-salad-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/10/gabrielle-union-responds-to-tossing-salad.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/10/23/gabrielle-union-responds-to-critics-on-if-she-really-tosses-husband-dwyane-wades-salad-video/" title="Gabrielle Union Responds To Critics On If She Really Tosses Husband Dwyane Wade&#8217;s Salad! (Video)" style="font-size: 14px">Gabrielle Union Responds To Critics On If She Really Tosses Husband Dwyane Wade&#8217;s Salad! (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/10/23/ayesha-curry-speaks-on-couplegoals-with-husband-steph-reveals-steph-really-loves-her-feet-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/10/ayesha-curry-and-steph-curry-.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/10/23/ayesha-curry-speaks-on-couplegoals-with-husband-steph-reveals-steph-really-loves-her-feet-video/" title="Ayesha Curry Speaks On #CoupleGoals With Husband Steph + Reveals Steph &#8216;Really Loves&#8217; Her Feet! (Video)" style="font-size: 14px">Ayesha Curry Speaks On #CoupleGoals With Husband Steph + Reveals Steph &#8216;Really Loves&#8217; Her Feet! (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/10/06/gabrielle-union-opens-up-about-her-infertility-struggles-ive-had-eight-or-nine-miscarriages-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/10/gabrielle-union-infertility-interview-.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/10/06/gabrielle-union-opens-up-about-her-infertility-struggles-ive-had-eight-or-nine-miscarriages-video/" title="Gabrielle Union Opens Up About Her Infertility Struggles: &#8216;I&#8217;ve Had Eight or Nine Miscarriages!&#8217; (Video)" style="font-size: 14px">Gabrielle Union Opens Up About Her Infertility Struggles: &#8216;I&#8217;ve Had Eight or Nine Miscarriages!&#8217; (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/09/23/nba-star-jrue-holidays-wife-laurens-health-continues-to-improve-after-battling-brain-tumor-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/09/jrue-holiday-wife-lauren-holiday-pics-photos-video.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/09/23/nba-star-jrue-holidays-wife-laurens-health-continues-to-improve-after-battling-brain-tumor-video/" title="NBA Star Jrue Holiday&#8217;s Wife Lauren&#8217;s Health Continues To Improve After Battling Brain Tumor! (Video)" style="font-size: 14px">NBA Star Jrue Holiday&#8217;s Wife Lauren&#8217;s Health Continues To Improve After Battling Brain Tumor! (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                            </div><!-- end .wpfp-recent-post -->

    </div><!-- end .wpfp-featured-post-widget-wrp -->

    </aside><aside id="wpfp_recentpostlist_widget-4" class="widget inner-padding wpfp-featured-fplw"><div class="widget-title"><span>Actor Wives &#038; Girlfriends</span></div>
        <div class="wpfp-featured-post-widget-wrp wpfp-clearfix ">
            <div class="wpfp-widget wpfp-recent-post-widget" id="wpfp-recent-post-widget-4">

                
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/12/12/congratulations-dwayne-the-rock-johnson-announces-hes-expecting-baby-2-with-girlfriend-lauren-hashian-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/12/dwyane-johnson-girlfriend-lauren-hashian-expecting-baby-2-sm-Optimized.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/12/12/congratulations-dwayne-the-rock-johnson-announces-hes-expecting-baby-2-with-girlfriend-lauren-hashian-video/" title="Congratulations: Dwayne &#8216;The Rock&#8217; Johnson Announces He&#8217;s Expecting Baby #2 With Girlfriend Lauren Hashian! (Video)" style="font-size: 14px">Congratulations: Dwayne &#8216;The Rock&#8217; Johnson Announces He&#8217;s Expecting Baby #2 With Girlfriend Lauren Hashian! (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/10/04/idris-elba-open-up-about-his-relationship-with-girlfriend-sabrina-dhowre-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/10/idris0elba-girlfriend-sabrina-dhowre-pics-photos-.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/10/04/idris-elba-open-up-about-his-relationship-with-girlfriend-sabrina-dhowre-video/" title="Idris Elba Open Up About His Relationship With Girlfriend Sabrina Dhowre (Video)" style="font-size: 14px">Idris Elba Open Up About His Relationship With Girlfriend Sabrina Dhowre (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/09/27/tyrese-and-wife-samantha-gibson-speak-on-haters-finding-the-right-woman-their-marriage-and-more-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/09/tyrese-gibson-wife-samantha-gibson-pics-photos.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/09/27/tyrese-and-wife-samantha-gibson-speak-on-haters-finding-the-right-woman-their-marriage-and-more-video/" title="Tyrese And Wife Samantha Gibson Speak On Haters, Finding The Right Woman, Their Marriage And More. (Video)" style="font-size: 14px">Tyrese And Wife Samantha Gibson Speak On Haters, Finding The Right Woman, Their Marriage And More. (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/09/15/idris-elba-goes-public-with-new-girlfriend-sabrina-dhowre-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/09/idris-elba-new-girlfriend-Sabrina-Dhowre-pics-photos-video.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/09/15/idris-elba-goes-public-with-new-girlfriend-sabrina-dhowre-video/" title="Idris Elba Goes Public With New Girlfriend Sabrina Dhowre (Video)" style="font-size: 14px">Idris Elba Goes Public With New Girlfriend Sabrina Dhowre (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/08/04/wesley-snipes-speaks-on-why-he-has-not-worked-with-denzel-washington-and-doing-prison-time-for-a-tax-mishap-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/08/wesley-snipes-taxes-jail-time-video-Optimized.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/08/04/wesley-snipes-speaks-on-why-he-has-not-worked-with-denzel-washington-and-doing-prison-time-for-a-tax-mishap-video/" title="Wesley Snipes Speaks On Why He Has Not Worked With Denzel Washington And Doing Prison Time For A Tax Mishap! (Video)" style="font-size: 14px">Wesley Snipes Speaks On Why He Has Not Worked With Denzel Washington And Doing Prison Time For A Tax Mishap! (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/07/23/mike-colters-wife-iva-colter/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/07/mike-colter-wife-_Iva_Colter-pics-photos-wiki-bio.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/07/23/mike-colters-wife-iva-colter/" title="Mike Colter&#8217;s Wife Iva Colter" style="font-size: 14px">Mike Colter&#8217;s Wife Iva Colter</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/07/19/terrence-j-and-his-girlfriend-jasmine-sanders-visit-the-wendy-williams-show-speaks-on-their-relationship-how-they-first-met-and-more-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/07/terrence-j-girlfriend-jasminine-sanders-pics-photos-7.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/07/19/terrence-j-and-his-girlfriend-jasmine-sanders-visit-the-wendy-williams-show-speaks-on-their-relationship-how-they-first-met-and-more-video/" title="Terrence J And His Girlfriend Jasmine Sanders Visit The &#8216;Wendy Williams Show&#8217;&#8230;..Speaks On Their Relationship, How They First Met And More! (Video)" style="font-size: 14px">Terrence J And His Girlfriend Jasmine Sanders Visit The &#8216;Wendy Williams Show&#8217;&#8230;..Speaks On Their Relationship, How They First Met And More! (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                            </div><!-- end .wpfp-recent-post -->

    </div><!-- end .wpfp-featured-post-widget-wrp -->

    </aside><aside id="wpfp_recentpostlist_widget-8" class="widget inner-padding wpfp-featured-fplw"><div class="widget-title"><span>Heartfelt Stories</span></div>
        <div class="wpfp-featured-post-widget-wrp wpfp-clearfix ">
            <div class="wpfp-widget wpfp-recent-post-widget" id="wpfp-recent-post-widget-5">

                
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/12/27/heartfelt-stranger-brings-christmas-presents-to-5-kids-whose-father-was-murdered-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/12/floyd-miley-brought-christmas-presents-to-kids.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/12/27/heartfelt-stranger-brings-christmas-presents-to-5-kids-whose-father-was-murdered-video/" title="Heartfelt: Stranger Brings Christmas Presents to 5 Kids Whose Father Was Murdered (Video)" style="font-size: 14px">Heartfelt: Stranger Brings Christmas Presents to 5 Kids Whose Father Was Murdered (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/11/17/watch-nfl-star-andre-branch-suprises-his-mother-with-a-home-and-new-mercedes-truck-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/11/andre-branch-buys-mother-new-house-and-truck-video.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/11/17/watch-nfl-star-andre-branch-suprises-his-mother-with-a-home-and-new-mercedes-truck-video/" title="Watch: NFL Star Andre Branch Suprises His Mother With A Home And New Mercedes Truck! (Video)" style="font-size: 14px">Watch: NFL Star Andre Branch Suprises His Mother With A Home And New Mercedes Truck! (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/11/01/heartfelt-tyrese-gibson-breaks-down-over-legal-battle-with-ex-wife-please-dont-take-my-daughter-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/11/tyrese-breaks-down-over-daughter-shayla-video.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/11/01/heartfelt-tyrese-gibson-breaks-down-over-legal-battle-with-ex-wife-please-dont-take-my-daughter-video/" title="Heartfelt: Tyrese Gibson Breaks Down Over Legal Battle With Ex-Wife: &#8216;Please Don&#8217;t Take My Daughter!&#8217; (Video)" style="font-size: 14px">Heartfelt: Tyrese Gibson Breaks Down Over Legal Battle With Ex-Wife: &#8216;Please Don&#8217;t Take My Daughter!&#8217; (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/09/18/divine-intervention-mans-act-of-kindness-toward-distressed-woman-who-ran-out-of-gas-leads-to-an-incredible-bond-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/09/Man’s_Act_Of_Kindness_Toward_Woman_Out_Of_Gas_Leads_To_‘Godwink_Video.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/09/18/divine-intervention-mans-act-of-kindness-toward-distressed-woman-who-ran-out-of-gas-leads-to-an-incredible-bond-video/" title="Divine Intervention: Man’s Act Of Kindness Toward Distressed Woman Who Ran Out Of Gas Leads To An Incredible Bond! (Video)" style="font-size: 14px">Divine Intervention: Man’s Act Of Kindness Toward Distressed Woman Who Ran Out Of Gas Leads To An Incredible Bond! (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/09/14/watch-lavar-ball-surprises-his-struggling-handyman-with-a-brand-new-truck-and-new-job-as-property-manager-for-big-baller-brand-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/09/lavar-ball-buys-handyman-new-truck-video-.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/09/14/watch-lavar-ball-surprises-his-struggling-handyman-with-a-brand-new-truck-and-new-job-as-property-manager-for-big-baller-brand-video/" title="Watch: LaVar Ball Surprises His Struggling Handyman With A Brand New Truck And New Job As Property Manager For Big Baller Brand! (Video)" style="font-size: 14px">Watch: LaVar Ball Surprises His Struggling Handyman With A Brand New Truck And New Job As Property Manager For Big Baller Brand! (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/09/08/heartfelt-mother-shows-appreciation-for-her-daughters-dad-and-step-mother-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/09/Mother-Shows-Appreciation-For-Her-Daughters-Dad-video.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/09/08/heartfelt-mother-shows-appreciation-for-her-daughters-dad-and-step-mother-video/" title="Heartfelt: Mother Shows Appreciation For Her Daughter&#8217;s Dad And Step Mother (Video)" style="font-size: 14px">Heartfelt: Mother Shows Appreciation For Her Daughter&#8217;s Dad And Step Mother (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                    
                <div class="wpfpcolumns">
                    <a class="featured-link-overlay" href="http://theballerlife.com/2017/08/13/paying-it-forward-former-homeless-hairdresser-gives-free-monthly-makeovers-to-women-in-need-video/"></a>

                    <div class="featured-grid" style="height:200px">
                        <div class="featured-overlay">
                            <div class="featured-image-bg">
                                                                     <img src="http://theballerlife.com/wp-content/uploads/2017/08/vanessa-howard-gives-back-hairdresser-tampa-video.jpg"/> 
                                    
                                </div><!-- end .featured-image-bg -->

                                <div class="featured-content">
                                    
                                    <div class="featured-title">
                                        <a href="http://theballerlife.com/2017/08/13/paying-it-forward-former-homeless-hairdresser-gives-free-monthly-makeovers-to-women-in-need-video/" title="Paying It Forward: Former Homeless Hairdresser Gives Free Monthly Makeovers To Women In Need! (Video)" style="font-size: 14px">Paying It Forward: Former Homeless Hairdresser Gives Free Monthly Makeovers To Women In Need! (Video)</a>
                                    </div>

                                    
                                </div><!-- end .featured-content -->
                            </div><!-- end .featured-overlay-->
                        </div> <!-- End .featured-grid -->
                    </div> <!-- End .wpfpcolumns -->
                            </div><!-- end .wpfp-recent-post -->

    </div><!-- end .wpfp-featured-post-widget-wrp -->

    </aside>			</div><!-- .inside-right-sidebar -->
</div><!-- #secondary -->
	</div><!-- #content -->
</div><!-- #page -->



<div class="site-footer grid-container grid-parent  ">
		<footer class="site-info" itemtype="http://schema.org/WPFooter" itemscope="itemscope">
		<div class="inside-site-info grid-container grid-parent">
			<a href='http://theballerlife.com/contact-us'>Contact Us</a> | <a href='http://theballerlife.com/terms-of-use'>Terms of Use</a> | <a href='http://theballerlife.com/sitemap.xml'>Site Map</a> | <a href='http://theballerlife.com/privacy'>Privacy Statement</a><br />Copyright © 2016 TheBallerLife.com All Rights Reserved.
		</div>
	</footer><!-- .site-info -->
	</div><!-- .site-footer -->

	<nav itemtype="http://schema.org/SiteNavigationElement" itemscope="itemscope" id="generate-slideout-menu" class="main-navigation slideout-navigation">
		<div class="inside-navigation grid-container grid-parent">
			<div class="main-nav"><ul id="menu-men-mobile-1" class=" slideout-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-46666"><a href="http://theballerlife.com"><i class="fa fa-home" aria-hidden="true"></i> HOME</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-46663"><a href="http://theballerlife.com/category/celebrity-videos/">Videos<span role="button" class="dropdown-menu-toggle" aria-expanded="false"></span></a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56718"><a href="http://theballerlife.com/category/heartfelt-post/">Heartfelt Post</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-56724"><a href="http://theballerlife.com/category/celebrity-videos/">Celebrity Videos</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56719"><a href="http://theballerlife.com/category/motivational-videos/">Motivational Videos</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-46664"><a href="http://theballerlife.com/category/celebrity-news/">News<span role="button" class="dropdown-menu-toggle" aria-expanded="false"></span></a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-56723"><a href="http://theballerlife.com/category/celebrity-news/">Celebrity News</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56722"><a href="http://theballerlife.com/category/sports-news/">Sports News</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-56667"><a href="http://theballerlife.com/category/baller-lifestyle/">Lifestyle<span role="button" class="dropdown-menu-toggle" aria-expanded="false"></span></a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56716"><a href="http://theballerlife.com/category/baller-cars/">Baller Cars</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56717"><a href="http://theballerlife.com/category/baller-cribs/">Baller Cribs</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56715"><a href="http://theballerlife.com/category/marriage-proposals/">marriage proposals</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-46665"><a href="http://theballerlife.com/category/wife-girlfriend/">Baller Wives<span role="button" class="dropdown-menu-toggle" aria-expanded="false"></span></a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56712"><a href="http://theballerlife.com/category/wife-girlfriend/movie-actors-wives/">Actors Wives</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56706"><a href="http://theballerlife.com/category/nba-ballers/">NBA Wives</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56710"><a href="http://theballerlife.com/category/nba-girlfriends/">NBA Girlfriends</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56707"><a href="http://theballerlife.com/category/nfl-ballers/">NFL Wives</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56711"><a href="http://theballerlife.com/category/nfl-girlfriends/">NFL Girlfriends</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56708"><a href="http://theballerlife.com/category/mlb-girlfriends/">MLB Girlfriends</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56709"><a href="http://theballerlife.com/category/mlb-ballers/">MLB Wives</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56713"><a href="http://theballerlife.com/category/rappers/">Rapper Wives</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56714"><a href="http://theballerlife.com/category/r-b-singer-wives/">R &#038; B Singer Wives</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56721"><a href="http://theballerlife.com/category/other-sports-wives-girlfriends/">Other Sports Wives Girlfriends</a></li>
</ul>
</li>
</ul></div>					</div><!-- .inside-navigation -->
	</nav><!-- #site-navigation -->
	<div class="slideout-overlay" style="display: none;"></div>
	<a title="Scroll back to top" rel="nofollow" href="#" class="generate-back-to-top" style="opacity:0;visibility:hidden;" data-scroll-speed="400" data-start-scroll="300">
			<i class="fa fa-angle-up" aria-hidden="true"></i>
			<span class="screen-reader-text">Scroll back to top</span>
		</a><!-- Scroll Triggered Boxes v2.2.1 - https://wordpress.org/plugins/scroll-triggered-boxes/-->			<div class="stb-container stb-center-container">
				<div class="scroll-triggered-box stb stb-56807 stb-center"
				     id="stb-56807"
				     style="display: none;">
					<div class="stb-content">
						<h4 id="fb-message"><strong>LIKE OUR SITE??</strong></h4>
<h4 style="text-align: center;"><span style="color: #000000;"><strong>Well, show us some love and support by clicking the Facebook <span style="color: #3366ff;">&#8220;Like&#8221; </span>Button Below!</strong></span></h4>
<p><iframe src="https://www.facebook.com/plugins/like.php?href=https%3A%2F%2Fwww.facebook.com%2Fballerwives%2F&#038;width=320&#038;layout=standard&#038;action=like&#038;size=large&#038;show_faces=false&#038;share=false&#038;height=35&#038;appId" width="320" height="35" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true"></iframe><br />
<a href="http://theballerlife.com/category/nba-ballers/" target="_blank" rel="noopener noreferrer"><img class="aligncenter size-full wp-image-57211" src="http://theballerlife.com/wp-content/uploads/2017/01/ballerwives-popup.png" alt="" width="300" height="152" /></a></p>
					</div>
											<span class="stb-close">&times;</span>
									</div>
			</div>
			<div id="stb-overlay"></div><!-- / Scroll Triggered Box --><script type='text/javascript' src='http://theballerlife.com/wp-content/plugins/gp-premium/menu-plus/functions/js/sticky.min.js?ver=1.5.2'></script>
<script type='text/javascript' src='http://theballerlife.com/wp-content/plugins/gp-premium/menu-plus/functions/js/sliiide.min.js?ver=1.5.2'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201802'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mashsb = {"shares":"0","round_shares":"1","animate_shares":"0","dynamic_buttons":"0","share_url":"http:\/\/theballerlife.com\/2018\/01\/07\/2-chainz-shows-off-his-vacation-home-and-plays-basketball-on-a-450000-court-video\/","title":"2+Chainz+Shows+Off+His+Vacation+Home+And+Plays+Basketball+On+A+%24450%2C000+Court%21+%28Video%29","image":null,"desc":"Rapper 2 Chainz teamed up with GQ and gave his fans an inside peek at his vacation home and played basketball on a $450,000 court. \r\n\r\nWatch the video below:","hashtag":"@ballerwives","subscribe":"link","subscribe_url":"http:\/\/feedburner.google.com\/fb\/a\/mailverify?uri=BallerWives","activestatus":"1","singular":"1","twitter_popup":"1","refresh":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='http://theballerlife.com/wp-content/plugins/mashsharer/assets/js/mashsb.min.js?ver=3.4.7'></script>
<script type='text/javascript' src='http://theballerlife.com/wp-content/themes/generatepress/js/navigation.min.js?ver=1.4'></script>
<script type='text/javascript'>
jQuery( document ).ready( function($) {
				$( '.secondary-navigation .menu-toggle' ).on( 'click', function( e ) {
					e.preventDefault();
					$( this ).closest( '.secondary-navigation' ).toggleClass( 'toggled' );
					$( this ).closest( '.secondary-navigation' ).attr( 'aria-expanded', $( this ).closest( '.secondary-navigation' ).attr( 'aria-expanded' ) === 'true' ? 'false' : 'true' );
					$( this ).toggleClass( 'toggled' );
					$( this ).children( 'i' ).toggleClass( 'fa-bars' ).toggleClass( 'fa-close' );
					$( this ).attr( 'aria-expanded', $( this ).attr( 'aria-expanded' ) === 'false' ? 'true' : 'false' );
				});
			});
</script>
<script type='text/javascript' src='http://theballerlife.com/wp-content/themes/generatepress/js/dropdown-click.min.js?ver=1.4'></script>
<script type='text/javascript' src='http://theballerlife.com/wp-content/themes/generatepress/js/navigation-search.min.js?ver=1.4'></script>
<script type='text/javascript' src='http://theballerlife.com/wp-content/themes/generatepress/js/back-to-top.min.js?ver=1.4'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='http://theballerlife.com/wp-content/themes/generatepress/js/html5shiv.min.js?ver=1.4'></script>
<![endif]-->
<script type='text/javascript' src='http://theballerlife.com/wp-content/plugins/lazy-load/js/jquery.sonar.min.js?ver=0.6.1'></script>
<script type='text/javascript' src='http://theballerlife.com/wp-content/plugins/lazy-load/js/lazy-load.js?ver=0.6.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var STB_Global_Options = {"testMode":""};
var STB_Box_Options = {"56807":{"id":56807,"title":"Facebook Like Message","trigger":"percentage","triggerPercentage":65,"triggerElementSelector":"","animation":"fade","cookieTime":1,"autoHide":true,"autoShow":true,"position":"center","minimumScreenWidth":0,"unclosable":false}};
/* ]]> */
</script>
<script type='text/javascript' src='http://theballerlife.com/wp-content/plugins/scroll-triggered-boxes/assets/js/script.min.js?ver=2.2.1'></script>
<script type='text/javascript' src='http://theballerlife.com/wp-includes/js/wp-embed.min.js?ver=4.9.1'></script>
<script async="async" type='text/javascript' src='http://theballerlife.com/wp-content/plugins/akismet/_inc/form.js?ver=4.0.2'></script>

<script src="http://services.picadmedia.com/js/picad.js" type="text/javascript"></script><script type="text/javascript">picadService.set('token','');picadService.initialize(); </script>

<script>!function(){var a,b="e473d7fe",c="https://g2.gumgum.com/javascripts/ggv2.js",d=top,e="script",f=d.document,g=f.getElementsByTagName(e)[0],h=d.XMLHttpRequest||d.XDomainRequest,i=function(a){var b=f.createElement(e);b.src=a,b.async=!0,g.parentNode.insertBefore(b,g)},j=function(){d.clearTimeout(a)};return d.ggv2id=b,h?(h=new h,h.open("GET",c),h.onload=function(){j();try{(d.execScript||function(a){d.eval.call(d,a)})(h.responseText)}catch(a){}},a=d.setTimeout(function(){h.abort()},3e3),void h.send()):i(c)}();</script>


 
<!-- start Vibrant Media IntelliTXT script section -->
<script type="text/javascript" src="http://ballerwives.us.intellitxt.com/intellitxt/front.asp?ipid=30857"></script>
<!-- end Vibrant Media IntelliTXT script section -->

<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({flush: true});
</script>

<script type="text/javascript">
var infolinks_pid = 2407402;
var infolinks_wsid = 1;
</script>
<script type="text/javascript" src="//resources.infolinks.com/js/infolinks_main.js"></script>
<script type="text/javascript">
    (function() {
        var a = document.createElement("script");
        var b = document.getElementsByTagName("script")[0];
        a.async = 1;
        a.src = "//cdn.earnify.com/widget.min.js";
        b.parentNode.insertBefore(a, b);
    })();
</script>
<!-- START MadadsMedia.com Private Marketplace Tag For TheBallerLife.com -->
<!-- Size: 300x250 Slider -->
<script data-cfasync="false" src="//ads-by.madadsmedia.com/tags/204/11633/async/slider/300x250s.js" type="text/javascript"></script>
<!-- MadadsMedia.com Private Marketplace Tag For TheBallerLife.com -->

<!-- START MadadsMedia.com Private Marketplace Tag For TheBallerLife.com -->
<!-- Size: 728x90 Slider -->
<script data-cfasync="false" src="//ads-by.madadsmedia.com/tags/204/11633/async/slider/728x90s.js" type="text/javascript"></script>
<!-- MadadsMedia.com Private Marketplace Tag For TheBallerLife.com -->


<script type="text/javascript">
        // Asynchronous Loading
        var script = document.createElement("script");
        script.src = script.src = document.location.protocol + '//platform.twitter.com/widgets.js';
        script.async = true;
        document.getElementsByTagName("body")[0].appendChild(script);
    </script>

<script>!function(d,s,id) {
	var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';
	if(!d.getElementById(id)) {
		js=d.createElement(s);
		js.id=id;
		js.async=true;
		js.src=p+'://platform.twitter.com/widgets.js';
		fjs.parentNode.insertBefore(js,fjs);
	}
}(document, 'script', 'twitter-wjs');</script>
</body>
</html>
<!-- This Quick Cache file was built for (  theballerlife.com/2018/01/07/2-chainz-shows-off-his-vacation-home-and-plays-basketball-on-a-450000-court-video/ ) in 1.05663 seconds, on Jan 8th, 2018 at 5:46 am UTC. -->
<!-- This Quick Cache file will automatically expire ( and be re-built automatically ) on Jan 8th, 2018 at 6:46 am UTC -->
<!-- +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ -->
<!-- Quick Cache Is Fully Functional :-) ... A Quick Cache file was just served for (  theballerlife.com/2018/01/07/2-chainz-shows-off-his-vacation-home-and-plays-basketball-on-a-450000-court-video/ ) in 0.00195 seconds, on Jan 8th, 2018 at 5:57 am UTC. -->